Last Comment Bug 355469 - Show Passwords dialog does not resize correctly (vertically)
: Show Passwords dialog does not resize correctly (vertically)
Status: RESOLVED FIXED
: regression
Product: Firefox
Classification: Client Software
Component: Preferences (show other bugs)
: 2.0 Branch
: PowerPC Mac OS X
: P1 minor (vote)
: Firefox 3 alpha1
Assigned To: Mano (::mano, needinfo? for any questions; not reading general bugmail)
:
:
Mentors:
Depends on:
Blocks: 349343 361243 361701
  Show dependency treegraph
 
Reported: 2006-10-04 20:01 PDT by Michael Newton
Modified: 2006-12-03 12:04 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
screenshot (38.23 KB, image/png)
2006-10-04 20:08 PDT, Michael Newton
no flags Details
patch (2.39 KB, patch)
2006-10-09 15:35 PDT, Mano (::mano, needinfo? for any questions; not reading general bugmail)
mconnor: review+
Details | Diff | Splinter Review

Description Michael Newton 2006-10-04 20:01:46 PDT
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1) Gecko/20061004 BonEcho/2.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1) Gecko/20061004 BonEcho/2.0

Resizing the list of passwords, the list and buttons do not move vertically.

Reproducible: Always
Comment 1 Michael Newton 2006-10-04 20:08:23 PDT
Created attachment 241280 [details]
screenshot
Comment 2 Jake Olefsky 2006-10-08 09:58:54 PDT
To elaborate: 

1. Open security tab of preferences.
2. Click "Show Passwords..."
3. Resize the window.  

The buttons and scrolling view are not pinned to the bottom of the window, so they do not stretch vertically.
Comment 3 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2006-10-09 15:35:56 PDT
Created attachment 241758 [details] [diff] [review]
patch
Comment 4 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2006-10-24 16:28:12 PDT
mozilla/toolkit/content/widgets/preferences.xml 1.57
Comment 5 Daniel Veditz [:dveditz] 2006-11-20 11:54:36 PST
Comment on attachment 241758 [details] [diff] [review]
patch

approved for 1.8 branch, a=dveditz for drivers
Comment 6 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2006-11-20 12:03:07 PST
1.8 branch: mozilla/toolkit/content/widgets/preferences.xml 1.31.2.24
Comment 7 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2006-11-24 13:12:32 PST
Backed out from the 1.8 branch.
Comment 8 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2006-11-24 13:14:12 PST
(due to bug 361701)

Note You need to log in before you can comment on or make changes to this bug.