[cocoa-cairo] initial pref pane does not draw when opening preferences

RESOLVED FIXED

Status

()

Core
Widget: Cocoa
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: Josh Aas, Assigned: Josh Aas)

Tracking

Trunk
x86
Mac OS X
Points:
---
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [blocking1.9a1+])

Attachments

(1 attachment)

(Assignee)

Description

12 years ago
Under cocoa-cairo, the initial preference pane does not draw when opening preferences. Switching to a new pref pane causes pref panes to start drawing. I can always repro under cocoa-cairo, but never under cocoa-quickdraw.
(Assignee)

Comment 1

12 years ago
Created attachment 245994 [details]
screenshot
Flags: blocking1.9+
Whiteboard: [blocking1.9a1+]

Comment 2

12 years ago
*** Bug 361701 has been marked as a duplicate of this bug. ***

Comment 3

12 years ago
In Bug 361701, it reproduces with 1.8branch Firefox/Thunderbird build. 
This is not Cocoa-Cairo build. 

Is the cause the same?

Comment 4

12 years ago
(In reply to comment #3)
> In Bug 361701, it reproduces with 1.8branch Firefox/Thunderbird build. 
> This is not Cocoa-Cairo build. 
> 
> Is the cause the same?

I think I got confused in the UA string, somehow; I'll reopen for now.
(the 2.0.0.1/Gecko 1.8.1.1 has a regression range between 20061120 and 20061121).

Comment 5

12 years ago
On Cairo-cocoa builds this regressed between 20061023 (works) and 20061028 (fails).
I don't have builds in between.

This may still be the same regression as bug 361701, which was apparently caused by the patch for bug 355469 (and that patch landed on trunk on 20061014).

Comment 6

12 years ago
On my local copy, I backed out the patch from bug 355469, and that solved the problem (just as it did for bug 361701).

The reason why this is not visible on non-cairo trunk builds is that opacity is broken there.
Depends on: 355469
is this fixed now that bug 361701 has been fixed ?

Comment 8

12 years ago
(In reply to comment #7)
> is this fixed now that bug 361701 has been fixed ?
>

Yup fixed by the patch in bug 361701.
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20061125 Minefield/3.0a1 ID:2006112514

Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.