Work Offline mode not remembered between browsing sessions

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
8 years ago

People

(Reporter: stevee, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1) Gecko/20061006 BonEcho/2.0 ID:2006100603

1. New profile, start firefox
2. Click File > Work Offline so it is ticked
3. Close and restart firefox

Expected:
- File > Work Offline is ticked

Actual:
- File > Work Offline is not ticked

This is different behaviour from firefox 1.5 which will remember if the user has ticked Work Offline and then closed and reopened the browser.

This might be intentional behaviour or not. Bug 251756 is the opposite of this bug, and the gavin has mentioned that bug 312793 might be relevant.

Comment 1

13 years ago
Or maybe even bug 76111?
It's bug 76111, pretty sure. I guess this is kinda intentional.
It's bug 76111, pretty sure. I guess this is kinda intentional.
Shouldn't File > Work Offline override the auto-detection, even if the browser is restarted?
We thought about this. The problem is that if we do that, there is then no obvious way to reenable automatic offline detection. We'd have to add some new and confusing UI.
I'd say unchecking "Work Offline" should enable auto-detection. This would cover the following cases:

- user is online and wants to work online (i.e. unchecks "Work Offline")
- user is online but wants to work offline (i.e. checks "Work Offline")
- user is offline and wants to work offline (can check "Work Offline",
  otherwise it will be detected)
- user is offline but wants to work online (obviously, he can't; checking
  "Work offline" would detect this)

That's just a quick thought. I didn't look into bug 76111 yet. And to be honest, I've never worked in offline mode.
(In reply to comment #6)
> - user is offline but wants to work online (obviously, he can't; checking
>   "Work offline" would detect this)

Erm, unchecking.
Actually, going into online mode when the network is down is important and useful.

Comment 9

13 years ago
*** Bug 358677 has been marked as a duplicate of this bug. ***

Comment 10

13 years ago
Session restore after browser restart and having multiple home pages is useless in association with this bug when people have low bandwidth or low monthly data transfer. (Suggestions like not starting Firefox when online is not an option.)

If this bug would never be fixed, it would be good to load such pages from cache instead of the internet (selectable in about:config with no new UI).

Comment 11

13 years ago
On trunk (to be Firefox 3) Session Restore, at least, loads all pages from the cache if it can.

Comment 12

12 years ago
0- OS: Win XP with Firefox 1.5 beta 1 installed.
1- Installed Firefox 2.0.0.1 while offline
2- Started Firefox
3- Error message came up for not finding server
4- File / Offline  caused it to crash.
5- Repeated steps 2, 3 and 4 (because Offline was not checked); crashed again.

Had to go online to be able to set the OFFLINE flag.
For those who think a browser is an online component and hence this report is
a non-issue;  I needed the browser to test Applets created by NetBeans 5.0 IDE, 
which is an offline system with its own emulation of a server.



Updated

12 years ago
Duplicate of this bug: 376827
I'm still seeing this issue on the latest trunk and shiretoko release: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3
Still present in 3.6RC1. The pref is not kept.
Whiteboard: [3.6RC1]
I think we fixed this. Re-open IF this is not the case in the latest Firefox 4 beta.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
OS: Windows 2000 → All
Hardware: x86 → All
Resolution: --- → WORKSFORME
Whiteboard: [3.6RC1]
Version: 2.0 Branch → Trunk
You need to log in before you can comment on or make changes to this bug.