Closed Bug 356321 Opened 17 years ago Closed 16 years ago

unable to open all items of a bookmarked feed, due to a tag:... guid

Categories

(Firefox :: Bookmarks & History, defect)

2.0 Branch
x86
All
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Firefox 3 alpha2

People

(Reporter: moco, Assigned: sayrer)

References

()

Details

Attachments

(2 files)

unable to open all items of a bookmarked feed, due to a tag:... guid

to reproduce, bookmark http://planet.mozilla.org/rss20.xml and then try to open all the livemark children at once with "open all in tabs"

we'll bail out, because of cbeard blog:

<guid>tag:typepad.com,2003:post-13205879</guid>

I'll attach the static rss20.xml and a screen shot
I'm using Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1) Gecko/20061011 BonEcho/2.0
OS: Mac OS X 10.3 → Mac OS X 10.4
<guid> has one attribute, isPermaLink, defaulting to true. That doesn't mean we should pay so much heed to it, though.
OS: Mac OS X 10.4 → Mac OS X 10.3
I see this as well using Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0, which is the RC3 candidate build we are testing.
Confirmed on Windows Firefox 2 RC3 with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
OS: Mac OS X 10.3 → All
* Broken in 1.5 as well, not a regression
* Broken feed (bogus rewriting by Planet)
* toolkit parser not fooled (see feed preview)
* will go away on trunk with places bookmarks, so targeting Fx3a2.

separate bug for the fact that the tab loads stop?
Assignee: nobody → sayrer
Target Milestone: --- → Firefox 3 alpha2
"see also" bug 260918 (of which this is a duplicate, but whatever/wherever).

What heuristic is the toolkit parser using to not get fooled?
(In reply to comment #8)
> "see also" bug 260918 (of which this is a duplicate, but whatever/wherever).
> 
> What heuristic is the toolkit parser using to not get fooled?

No heuristic. <link> is the item.link if present. The toolkit parser would have used the tag: url if there were no <link> element.
Reopened bug 302548 for getting planet.m.o fixed again.

Hrm, preferring <link> to <guid isPermaLink="true">? If you're certain you want to do that, I think you'll be needing to wontfix the bug I'll be filing on you. But, yay! for the opportunity to argue about interpretations of the RSS spec based on weblog posts, right?
(In reply to comment #10)
> Reopened bug 302548 for getting planet.m.o fixed again.
> 
> Hrm, preferring <link> to <guid isPermaLink="true">? If you're certain you want
> to do that, I think you'll be needing to wontfix the bug I'll be filing on you.

Show me real broken feeds or IE7 behavior (I should have checked that).

> But, yay! for the opportunity to argue about interpretations of the RSS spec
> based on weblog posts, right?

Won't be arguing those.
P.S. -- RSS1 and Atom don't have this problem (as phil knows)
Robert 

By this going away I assume you mean thanks to bug 353434?

I had noticed this problem recently but had made the assumption above because feed preview had no such problem.  
Thank Atom, everyone I knew who would be broken by preferring <link> (link blogs with comments enabled, with <link> being the linked-to URL and <guid> the permalink for the post about it) is no longer producing RSS, so parse them as you like, I can't be bothered to file on hypothetical wrongness.
(In reply to comment #13)
>
> By this going away I assume you mean thanks to bug 353434?

Yes. That will fix it for Places.
> separate bug for the fact that the tab loads stop?

see bug #356341
Depends on: 353434
this should be fixed now that we use the toolkit feed parser for livemarks. true?
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.