Copy/cut multiple addresses into a pasteable address list

RESOLVED DUPLICATE of bug 327621

Status

--
enhancement
RESOLVED DUPLICATE of bug 327621
12 years ago
5 years ago

People

(Reporter: jon.roland, Unassigned)

Tracking

(Depends on: 2 bugs)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

In Outlook one can copy and paste multiple email addresses in a single operation by using the cursor to select several of them, or by using ctrl-a to select all of them in a To:, From:, Reply-To:, Cc:, or Bcc: field, and then ctrl-c to copy them, ctrl-x to delete them, and ctrl-v to paste them somewhere else. This is a really useful feature that is missing from Thunderbird. In Outlook I often have to copy, paste, and delete multiple addresses among fields and to and from other documents. For paste to the Compose window this would mean separating the addresses onto separate lines, unless we were also provided the option to set a preference between separate lines and single lines on which the addresses are separated by (optionally) commas or semi-colons. For copy or delete from the Compose window, that would mean enabling selection of multiple lines.

Reproducible: Always




It would also be useful to enable such copy/delete/paste between the display and compose windows and an address book folder, and perhaps drag-and-drop as well. That way, instead of, say, setting the preferences to collect all addresses of recipients of all sent mail into the Collected folder, one could instead copy and paste them to an address book folder on a message-by-message basis, thereby avoiding cluttering the collection folder with too many addresses.

Comment 1

12 years ago
From where, exactly, are you trying to copy multiple addresses -- the envelope panel?  Then this part, at least, is a dupe of bug 327621.

Note that if you paste a comma-separated list into the address field, once you <tab> or <enter> to advance to the next field, TB automatically parses the individual addresses out into individual fields.  This doesn't work for semicolon-separated lists, which are technically nonstandard but ubiquitous.

Deletion of multiple addresses is obviously a compose window function -- so is *that* where you also want to do multiple-copy?  For the deletion case, see 
bug 252665, also suite bug 143147.  For general multiple-selection of addresses in the compose window, see (core) bug 136897.

Please pick one of these and mark this bug as a dupe of it, then CC/vote for the others if they interest you.  Don't get too hung up on whether the bug is TB or suite or core: any changes to the compose window's address fields, in particular, will either be changed in core components or quickly ported between the two platforms.
(Reporter)

Comment 2

12 years ago
Having reviewed the other bugs cited, I have concluded that this bug is not a duplicate of those, although it may include them as sub-bugs. To answer the question, I want mainly to be able to cut and paste multiple addresses from one of the three recipient lines (To, Cc, Bcc) to another, and one message to another, but also to and from other documents, such as saved files of lists of addresses. Yes, it should also be able to handle semicolon-separated addresses, since the source message might be Outlook-generated.

In other words, I want to be able to do whatever I can do in Outlook, which we need to do if Thunderbird and associated packages are to replace Outlook, something we should be working toward.

Comment 3

12 years ago
(In reply to comment #2)
> this bug is not a duplicate of those, although it may include them
> as sub-bugs.

We don't *do* "sub-bugs."  One bug per issue, one issue per bug.


> I want mainly to be able to cut and paste multiple addresses from one
> of the three recipient lines (To, Cc, Bcc) 

We can already paste lists of comma-separated addresses.  We cannot select multiple addresses within the compose window, but that's bug 136897.  It's also a lot harder, given the current architecture, than you might imagine.

The feature you seem to be most looking for that isn't covered at least partially elsewhere is: support multi-address Copy or Cut to create an address list; this requires multi-select, so I'm adding a dependency.

Multi-address delete is explicitly mentioned at the multi-address select bug.

Copy of multiple addresses from the envelope panel is bug 269094.

Paste of semicolon-separated lists are addressed by bug 242693.
Component: Mail Window Front End → Message Compose Window
Depends on: 136897
QA Contact: front-end → message-compose
Summary: RFE: Enable select of multiple addresses for copy, delete, paste → Copy/cut multiple addresses into a pasteable address list
Assignee: mscott → nobody
This bug makes Thunderbird extremely frustrating when trying to mail quickly to multiple addresses.
This is likely a dupe of some age-old annoying bugs, perhaps bug 167010, although I like the clarity of description here, so if you dupe, please file this description as a comment in the other bug.
Whiteboard: dupeme
Jon (reporter), thank you for filing this very desirable RFE.

However, albeit correct and perfectly justified in its overall vision, this RFE is not actionable in itself because it is not specific enough (one issue per bug). The good news is, afasics (per comment 1 and comment 3), all aspects of this bug have been filed as separate bugs, some of which already fixed.

So what remains is either a dupe of 
TB Bug 327621 for Message Reader's header pane (same as MailNews Core bug 167010), or Bug 136897 for Composition.

Composition is more likely to get some attention when it's put into a tab, so I'll mark this in support of the message reader problem.

-> duplicate of Bug 327621
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 327621

Updated

5 years ago
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.