Closed Bug 357190 Opened 13 years ago Closed 13 years ago

xbox.com - style information is missing, so page shows only content to non-Firefox UAs

Categories

(Tech Evangelism Graveyard :: English US, defect, major)

defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: mozilla.org, Unassigned)

References

()

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8.0.5) Gecko/20060720 SeaMonkey/1.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8.0.5) Gecko/20060720 SeaMonkey/1.0.3

On October 18, 2006, Microsoft revamped the www.xbox.com website.  The old site used to work just fine in Seamonkey.  The new site doesn't work at all, however, it works a lot better in Konqueror.

I'm attaching screen shots from both Seamonkey and Konqueror to demonstrate.

Reproducible: Always
FYI, this might be related to Flash support in Linux, which is lagging.  However, every page on xbox.com is broken in the same way, even pages with very little Flash content.
I just installed the beta version of Flash 9 for Linux, and it didn't make a difference.  The odd thing is that xbox.com still displays a graphic that says I need to have the Flash player installed.  So perhaps this is really just a problem with the xbox.com not recognizing my flash player?  Or maybe since I'm using a Linux browser, it does something different. 

Xbox.com works on my Mac, so I'm pretty sure this is a Linux-only bug.
I installed prefbar and changed the user agent to Netscape 6.2 on Linux, and the web page works fine.  Oddly, if I change it to IE 6 on XP, the page works mostly, but it still thinks I don't have Flash installed.  I'm guessing that's because the web page uses an IE-specific method to find the plugin.

So I guess this is an evangelism issue?
It's broken on Mac OS X now, too.

Retargetting to Tech Evangelism and changing the summary.
Component: General → Other
Product: Mozilla Application Suite → Tech Evangelism
Summary: xbox.com does not display properly, works better in Konqueror → xbox.com does not display properly in Linux & Mac Seamonkey
Component: Other → English US
Looks like the problem has been fixed on Mac, so now only Linux is affected.
Summary: xbox.com does not display properly in Linux & Mac Seamonkey → xbox.com does not display properly in Seamonkey (Linux)
I take that back - it's broken on Mac again.  This is so stupid.  Of course, I'm disappointed that no one else seems to have noticed this problem, or even care about it.

*** This bug has been marked as a duplicate of 259706 ***
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
I made a mistake.  Bug 259706 is two years old and talks about a specific problem, that's different than what I'm talking about.

I'm also making changes according to the Site Evangelism guidelines.

And last of all, it works again on the Mac.  On various forums, some have said that if you clear the cache, the problem goes away.  It's something to do with a CSS resource being cached.  This solution doesn't work for me, but I find it odd that xbox.com works on the Mac right now, even though it didn't work 30 minutes ago.  I suspect that it will fail again tomorrow.
Severity: normal → major
Status: RESOLVED → UNCONFIRMED
OS: Linux → All
Hardware: PC → All
Resolution: DUPLICATE → ---
Summary: xbox.com does not display properly in Seamonkey (Linux) → xbox.com - style information is missing, so page shows only content.
This has to do with MS's b0rken UA sniffing.  "Firefox" is an OK browser to server styles to, but SeaMonkey, Camino, Minefield, etc., are not :P

(I can get them to serve styles in Camino some of the time without spoofing, but can't figure out why exactly.)
Assignee: general → english-us
Blocks: MS, geckoisgecko
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: general → english-us
Summary: xbox.com - style information is missing, so page shows only content. → xbox.com - style information is missing, so page shows only content to non-Firefox UAs
I'm using Windows XP SP2 and it happens to me too using Seamonkey but not using IE.
I am using the production Firefox package from Fedora Core 6:

% rpm -qi firefox
Name        : firefox                      Relocations: (not relocatable)
Version     : 1.5.0.9                           Vendor: Red Hat, Inc.
Release     : 1.fc6                         Build Date: Tue 19 Dec 2006 01:56:31 PM EST
Install Date: Sun 31 Dec 2006 05:27:06 PM EST      Build Host: hs20-bc1-5.build.redhat.com
Group       : Applications/Internet         Source RPM: firefox-1.5.0.9-1.fc6.src.rpm
Size        : 35389292                         License: MPL/LGPL
Signature   : DSA/SHA1, Wed 20 Dec 2006 05:57:04 PM EST, Key ID b44269d04f2a6fd2
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.mozilla.org/projects/firefox/
Summary     : Mozilla Firefox Web browser.
Description :
Mozilla Firefox is an open-source web browser, designed for standards
compliance, performance and portability.

By default this RPM sets the UA to:

"Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.9) Gecko/20061219 Fedora/1.5.0.9-1.fc6 Firefox/1.5.0.9 pango-text"

To get xbox.com to send the style information I had to change the UA to read:

"Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.9) Gecko/20061219 Firefox/1.5.0.9 pango-text"

Notice that I took out the "Fedora/1.5.0.9-1.fc6" block.  I thought to try this as Firefox 1.5.0.9 rendered xbox.com fine on my Gentoo box but the same version failed to render from my Fedora box.  I used about:config to add my new string to the general.useragent.override preference.  Right-click on the preference list to add a new entry via the context menu.

Fedora users may find this comment helpful.  I really don't know where to go from here.  My inclination is to interpret this behavior as a bug in xbox.com rather than as an issue with Fedora.  I think the Fedora entry in the UA makes some sense while I can not see any justification for xbox.com to not send style information to Fedora Firefox builds.
(In reply to comment #13)
>
> Fedora users may find this comment helpful.  I really don't know where to go
> from here.  My inclination is to interpret this behavior as a bug in xbox.com
> rather than as an issue with Fedora.

As a Tech Evangelism bug, it is considered by us to be a problem with xbox.com. They perform vendor/version based detection and exclude support for anything but "official" user agents. Please complain to them and explain the error of their ways. 

Sorry for the rant, but I am so tired of these kinds of sites|people.

<rant>
You will probably hear some BS about officially supported browsers etc, but you should ignore any such idiots and keep complaining. Of course, it may be difficult to get someone whose career security or company bottom line is based upon a never ending task of maintaining lists of user agent strings but you can try. Alternatively, you can stop financially supporting such morons and use a different product|site.
</rant>
You can complain to Microsoft by clicking on this URL and filling out the form:

https://support.microsoft.com/common/survey.aspx?scid=sw;en;1208&showpage=1&WS=mscom&url=http%3a%2f%2fwww.xbox.com%2fen%2fus%2fdefault.aspx

I did that, I got this reply the next day:

Hello,
 
Thank you for contacting Microsoft Online Customer Service.
 
I understand that you would like to report that the Xbox.com Web site is not working with the "Seamonkey" web browser. I apologize for the inconvenience you experienced.
 
I am currently working with my colleagues to resolve your issue. As soon as one of my resources replies, I will forward the information to you. Typically, we hear from them in 24 to 72 hours, but it all depends on the complexity of the issue.

Please bear with us as we are trying to fulfill our customer's demand as fast as possible.
Thank you,
 
Raquel
Microsoft Online Customer Service Representative
(In reply to comment #15)

Thanks Timur, I certainly hope they all any browser to access their content but at the least (if they must detect browsers) begin by detecting Gecko instead of particular browsers based on Gecko. They might find <http://developer.mozilla.org/en/docs/Browser_Detection_and_Cross_Browser_Support> useful.
Duplicate of this bug: 372985
I would recommend checking, but it seems to be fixed.
Yeah, the URL in the bug works properly using the Camino 2007033004 nightly now, for whatever that's worth.

Bob, we can probably close this pending a check on Seamonkey and/or another non-Firefox browser.

cl
yeah, thanks all. especially thanks to the xbox guys. Looks like the web might move away from vendor/version detection after all. checked in firefox with spoofed ua and with seamonkey 1.5 on linux.
Status: NEW → RESOLVED
Closed: 13 years ago13 years ago
Resolution: --- → FIXED
It works now on both Linux and Mac.  Thanks, Microsoft!
Status: RESOLVED → VERIFIED
Duplicate of this bug: 373524
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.