If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Problems with Folder named CON

RESOLVED DUPLICATE of bug 312265

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 312265
11 years ago
6 years ago

People

(Reporter: Josep L. Guallar-Esteve, Unassigned)

Tracking

(Blocks: 1 bug)

x86
Windows XP
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.7) Gecko/20060802 Mandriva/1.5.0.7-0.1.20060mdk (2006.0) Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.7) Gecko/20060802 Mandriva/1.5.0.7-0.1.20060mdk (2006.0) Firefox/1.5.0.7

Thunderbird 1.5.0.7 does not handle IMAP folder with 3-letter name "CON". 

Even though the folder shows up in "subscribe to folders" dialog, folder doesn't always show up on left-panel IMAP folders list. When "CON" folder shows up, Thunderbird cannot display the contents of the folder.

Other email readers (both GUI-clients and web-based) have no problem with the "CON" folder.

Tested with Windows XP SP2, Windows 2000 SP4 OS. Tested on normal and "I just installed Windows XP SP2 and Thuderbird". Tested Thunderbird with brand new email accounts and normal accounts. Tested Thunderbird on real hardware and on VmWare Server virtual machine.

Server is CentOS 4.4 , postfix-2.2.10-1.RHEL4.2, dovecot-0.99.11-4.EL4, mailbox format. As I have access to mail server, I can see that CON folder exists, has proper permissions and it's not empty.

[root@mailserver conuser]# ll
total 28
-rw-------  1 conuser conuser     0 Oct 19 15:57 COM1
-rw-------  1 conuser conuser 22156 Oct 19 15:40 CON
-rw-------  1 conuser conuser  1673 Oct 19 15:45 Sent
-rw-------  1 conuser conuser     0 Oct 19 15:21 Trash
[root@mailserver conuser]#

Platforms afected: at least, Windwos XP SP2, Windows 2000 SP4
Versions affected: Thunderbird 1.5.0.7
Email connection:  IMAP
Reproducible?      Yes
Confirmed?         Yes

Reproducible: Always

Steps to Reproduce:
1. Start Thunderbird
2. Connect to IMAP account
3. Right-click on IMAP account in left panel
4. Select New Folder...
5. Type "CON" (without the quotes) as the folder name
6. Copy or move messages from any folder to "CON" folder (right-click on email, select "Copy to > your@imap.account.org > CON"
7. Try accessing emails from folder "CON"

And if you try to remove "CON" folder, you get the alert:
--------
Alert
The current command did not succeed. The mail server responded: Mailbox doesn't exist: CON.
[OK]
--------

Note: the folder exists fine in the server.
Actual Results:  
If IMAP folder "CON" shows up on left pannel view, clicking on "CON" folder will display an empty folder.
"CON" folder might not show up at all.

Expected Results:  
Clicking on any non empty folder should display all emails in the IMAP folder.
It should be possible to use "CON" as a valid name for IMAP folder.

Access to "CON" folder is fine in the same email account with, say, Squirrelmail or Kmail or you-name-it .
(Reporter)

Updated

11 years ago
Version: unspecified → 1.5

Comment 1

11 years ago
I'm using Thunderbird 1.5.0.7 (20060909) under XP Pro SP2. I also have problems with a "CON" folder using a Cyrus v2.3.7-fmsvn9682 IMAP server (www.fastmail.fm has free guest accounts) though some of the symptoms are different. The CON folder always shows up in the folder pane and I have no problem deleting the folder. 

If I copy a message to it the the unread column shows ??? and the total column is empty in the folder pane.  When I open the folder I can't see the message. If I rename the remote folder I can see and open the message, and the unread and total columns change accordingly. I don't have this problem using webmail or with any other three letter folders.  

Comment 2

11 years ago
I think there is a dupe for this, but I can't find it ATM.

And yes, it has to do with CON file name being "reserved" on windows.
Whiteboard: DUPEME

Comment 3

10 years ago
Me too. Interestingly, the "con" folder shows up in the list of folders available for offline use, but you can't actually check the box for that folder.
Root cause is same as Bug 311339 - restriction of MS Win.
Setting 311339 in Depends on:
Depends on: 311339
Blocks: 124287
Assignee: mscott → nobody
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Problems with IMAP Folder named CON → Problems with Folder named CON
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Duplicate of bug: 312265
You need to log in before you can comment on or make changes to this bug.