page jump when clicking a link with autoScroll 'true'

RESOLVED DUPLICATE of bug 351491

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 351491
12 years ago
12 years ago

People

(Reporter: Aaron Griffin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

When general.autoScroll is set to true, scrolling while the page is still rendering causes the first left click to jump to the top of the page, _if and only if_ that first left click is on a link.  The clicked link is never 'clicked'.

Reproducible: Always

Steps to Reproduce:
1) Set general.autoScroll: true
2) Load a long page and mouse scroll while the page is still rendering.
3) Click on a link.
Actual Results:  
View jumps to the top of the document in question.

Expected Results:  
Link is clicked, location changed, etc etc just like a normal link click.

I have only tested on Windows - I have no idea if this affects Linux builds at all.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

I can't reproduce this. With a new profile (default settings, no extensions) I did a bugzilla search for the word "bookmarks" which gave as result a very long page, while loading I scrolled down (with autoscroll, with mouse wheel or with the bar) and when I clicked a link it just stopped loading and scrolling, did a new request, waited for that page and rendered it.

Comment 2

12 years ago
same thing for me both on windows and linux. but no sure about general.autoScroll: true, 'cause I've tried to change it to false but 'jump' is still happens.

Comment 3

12 years ago
I have found site on which you can find this bug. it's ogame.org (search in google for games's site on you language). register in game and go to Building page. scroll down to and click on last building name. page jumping to top. but if you scroll down next time this page - everything is ok. after reloading Building page bug appear again.
I have seen this on Linux too, on various sites including deviantart.com and bugzilla.mozilla.org.

The clicked link is actuated if it is an image link and the mouse pointer is still on it after the jump to top.

I believe that bug 360412 and bug 359424 are dupes of this one but I lack the privilege to resolve.

I am currently on "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061114 BonEcho/2.0" - Build ID: 2006111404
Aaron: Are you sure it was the autoScroll pref, and not the caret browsing pref? I think it's likely that this bug is a duplicate of bug 351491. Do the steps in bug 360412 comment 5 fix this for you?
(Reporter)

Comment 6

12 years ago
I think you are correct.  This is related to caret browsing and my initial reactions are wrong.

*** This bug has been marked as a duplicate of 351491 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.