100% CPU When reading and displaying long text messages, several minutes to reply

RESOLVED DUPLICATE of bug 298297

Status

Thunderbird
Mail Window Front End
--
major
RESOLVED DUPLICATE of bug 298297
11 years ago
11 years ago

People

(Reporter: Michael Wheeler, Assigned: Scott MacGregor)

Tracking

({perf})

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

I have a few long messages that are all text (no HTML-mail). They are multiple short replies as I have been working with CommVault tech support on an issue with our backup software. The message has grown to be fairly long.

Whenever I click on the message to display it, it takes several seconds with the status bar saying "loading message". When I click reply, it takes 100% of one of my CPUs ( I have a dual opteron Windows XP SP2 system) for several minutes of both Thunderbird and the reply window locked up before it loads the message. I have noticed that as the message gets longer, the time to display it takes longer, too.

There isn't really any sensitive information in the e-mail, so I can provide it to a developer if needed.

Reproducible: Always

Steps to Reproduce:
1. As described above, receive long e-mail
2. Attempt to display or reply to said e-mail
3. Thunderbird locks up for several seconds to minutes

Actual Results:  
If I'm patient enough, the e-mail will eventually display

Expected Results:  
Should be displaying quicker and not taking up 100% of my CPU?

I have tried disabling all of my extensions (only 2 of them) and it doesn't seem to make any difference.

Comment 1

11 years ago
suggest you check the following dup possibilities: bug 240307, bug 101064, bug 289644, bug 311223, bug 100835 and then comment in this bug  (ATM I don't have time to check them myself)
Severity: critical → major
Keywords: perf
Summary: 100% CPU When reading and displaying long messages → 100% CPU When reading and displaying long text messages, several minutes to reply
Version: unspecified → 2.0
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> suggest you check the following dup possibilities: bug 240307, bug 101064, bug
> 289644, bug 311223, bug 100835 and then comment in this bug  (ATM I don't have
> time to check them myself)

It looks like this bug is a dup, sorry that I missed it when I was originally searching. Seems to be a dupe of 298297, although the last time a comment was made on that bug was over a year ago.

Is there anything I can do to help this bug along?

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 298297
You need to log in before you can comment on or make changes to this bug.