Closed Bug 358661 Opened 13 years ago Closed 13 years ago

Leak monitor doesn't work anymore

Categories

(Core :: JavaScript Engine, defect, major)

x86
Windows 2000
defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: Peter6, Assigned: dbaron)

References

()

Details

(Keywords: regression)

after Bug 358528 landed Leak Monitor has stopped regestering leaks
Product: Firefox → Core
QA Contact: general → general
Assignee: nobody → general
Component: General → JavaScript Engine
QA Contact: general → general
When I go to about:config and then enter this in the URL bar:
javascript:void(alert(Components.classes["@mozilla.org/observer-service;1"].getService(Components.interfaces.nsIObserverService).addObserver({},"foo-topic",false)))
which should cause a leak, in my debug build of leak-monitor I see:

WARNING: NS_ENSURE_TRUE(str) failed: file /home/dbaron/builds/trunk/mozilla/extensions/leak-monitor/src/leakmonJSObjectInfo.cpp, line 113
WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv)) failed: file /home/dbaron/builds/trunk/mozilla/extensions/leak-monitor/src/leakmonReport.cpp, line 136
WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv)) failed: file /home/dbaron/builds/trunk/mozilla/extensions/leak-monitor/src/leakmonService.cpp, line 380
I'm seeing the same failure in my 1.8 branch build, though.
should patch to bug 357169 be backed out?
Severity: normal → major
It would be helpful if somebody isolated when the regression actually occurred.  I haven't had the chance to do that, and I'm not sure that "after bug 358528 landed" is correct.
Bonsai: 2006-10-27 12:38 , checkin for Bug 357169 (GC temp roots cleanup) which caused bug Bug 358528 (crash on startup with Leak Monitor installed)

regressionwindow:
from checkin for Bug 357169 to checkin for Bug 358528

http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=PhoenixTinderbox&branch=HEAD&branchtype=match&filetype=match&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2006-10-27+12%3A38&maxdate=2006-10-28+15%3A57&cvsroot=%2Fcvsroot

but it's probably a leftover from Bug 357169
This is just a replica of 358528.

*** This bug has been marked as a duplicate of 358528 ***
Status: NEW → RESOLVED
Closed: 13 years ago
Keywords: fixed1.8.1.1
Resolution: --- → DUPLICATE
No longer depends on: 358528
I don't see how this can be a duplicate of bug 358528 - that bug is about a hang due to infinite recursion, this one is about leak monitor not being effective. There's no hang involved here. It was also reported after bug 358528 was fixed.
Status: RESOLVED → REOPENED
Keywords: fixed1.8.1.1
Resolution: DUPLICATE → ---
Flags: blocking1.8.1.1?
Hmm, I'm not sure I can reproduce this bug - if I install Leak Monitor into a clean profile, and run either a branch build or trunk build from yesterday (both 2006-11-28-04), and then follow the steps in bug 323402, I see a leak monitor leak notification window. The tree part of the window is empty, but I've been told that that happens sometimes and isn't an indication of breakage.
A broken tool is sucky (although it's not clear it really is broken from the comments), but it's not going to block.

Is it really broken on the branch?
Flags: wanted1.8.1.x?
Flags: blocking1.8.1.1?
Flags: blocking1.8.1.1-
(In reply to comment #8)
> Hmm, I'm not sure I can reproduce this bug - if I install Leak Monitor into a
> clean profile, and run either a branch build or trunk build from yesterday
> (both 2006-11-28-04), and then follow the steps in bug 323402, I see a leak
> monitor leak notification window. The tree part of the window is empty, but
> I've been told that that happens sometimes and isn't an indication of breakage.

Is this bug still valid?

/be
I'm waiting for Peter to confirm - I'm guessing he had different steps to reproduce than I did.
The bookmark leaks have misteriously vanished but I see the monitor pop-up now and than.

Resolving for now.
Status: REOPENED → RESOLVED
Closed: 13 years ago13 years ago
Resolution: --- → WORKSFORME
After some more testing is seems it isn't properly working after all.

with the extension, close a bookmark or open the menu-customise window doesn't leak.

leak-gauge does show leaks.

Eiter leak-gauge is making mistakes or the extension doesn't work like it used to before bug 357169 landed

The only leaks I see with the extension, pop up out of the blue and are unreproducable.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
<Owner> I'm trying to track down why dbaron's leak monitor extension doesn't work in firefox 2.0.0.1rc -- I've narrowed it down to working in the nightly on 2006-11-09-03-mozilla1.8 and not in 2006-11-10-05-mozilla1.8  (on windows)
If I revert the patch in bug #353090, the about:config/javascript: test works, on current 1.8 branch code.
Blocks: 353090
We probably do want this tool to work on the branch, and it sounds like there's some recent progress, but I'm not sure it's an actual blocker since this is not part of the end-user product.

-> dbaron because bug 353090 is currently being blamed as the regressor
Assignee: general → dbaron
Status: REOPENED → NEW
Flags: wanted1.8.1.x?
Flags: wanted1.8.1.x+
Flags: blocking1.8.1.2?
So I'm fixing this in leak monitor.

I discussed this with brendan briefly, and JS_ValueToString isn't expected to work after a JS_ClearScope on Object.prototype.  So I've written my own simple ValueToString in leak monitor that does what I need.

I'll try to release a new version of leak monitor with this fix in the next few days.
Fixed by release of leak monitor 0.3.5:
https://addons.mozilla.org/firefox/2490/
http://dbaron.org/mozilla/leak-monitor/
Status: NEW → RESOLVED
Closed: 13 years ago13 years ago
Resolution: --- → FIXED
Clearing nomination, looks like dbaron fixed this in the leak monitor.
Flags: blocking1.8.1.2?
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.