Closed Bug 359236 Opened 15 years ago Closed 3 years ago

Filters: Outgoing Filters, Before send and After Send.

Categories

(Penelope Graveyard :: General, defect, P5)

defect

Tracking

(Not tracked)

RESOLVED WONTFIX
Future

People

(Reporter: mdudziak, Assigned: beckley)

References

Details

Penelope needs to have filtering contexts like the current Eudora. Penelope (Thunderbird) does not differentiate, though does allow filters to be run manually on a folder (but not a specific message or selection of messages).

Penelope needs to support various contexts for filtering:
Incoming
Manual
Before sending
After sending


Manual filters should only be applied to selected messages, not entire mailboxes.
Assignee: mozilla-bugs → gwenger
Definitely need all of these contexts. And definitely manual filters should only be applied to selected messages, not the whole mailbox (see below for more reasons why).

I would like to see the ability to filter messages that have been detected as spam (ie, the spam number is greater than the threshold). At present, they end up in the Junk malbox without any chance to apply a filter. If the other filters could be run, messages that match a filter should be unmarked as spam and follow the filter action. (I am thinking here of, say, a mailing list, which is filtered into its own mailbox. Even if a message was detected as spam, the filter would put it where it belongs rather than the Junk mailbox.)

Another context is when you want to do something to existing messages once only. Doing a search to identify the messages, then manually doing the action is certainly possible for some things, eg, setting the label colour for all messages older than a year. But what if you want to forward a bunch of messages to someone without having to forward them individually? A temporary filter could do this easily - select the messages, invoke the temporary filter, set any selection criteria, set the action to Forward, and click Go.

It would probably also be useful to be able to select individual filters from the existing list. For example, if you create a new filter but want to get all the messages that you have already received processed by the filter also. You could select just that filter to be applied.

(Note that if you just create the new filter, then run all filters as at present, there can be unexpected side-effects, eg, where you have changed messages from where the filter initially put them, they will go back to what the filter determined.)
My vote is also for the ideas expresses by David in comment #1.
Status: NEW → ASSIGNED
Summary: Filtering: Filter Contexts: Incoming, Manual, Before send, After Send. → Filters: Filter Contexts: Incoming, Manual, Before send, After Send.
Duplicate of this bug: 363802
Absolutely vital.  The ability in Eudora to filter manually to a specified folder a single message with a single keystroke is the one thing that has prevented me moving to other mailers such as Mac Mail and Thunderbird. 
To me, filtering the outgoing messages is very important, so my own sent messages get sorted properly into the correct mailboxes.
This is  valuable filtering mechanism that makes Eudora very useful.  Please add this filtering, very important for keeping track of emails.
Assignee: gwenger → dwiggins
Status: ASSIGNED → NEW
Priority: -- → P5
Status: NEW → ASSIGNED
I agree, this is crucial.  Being able to filter single messages with a keystroke was an extremely efficient means of managing the storage of messages from the inbox in Eudora. As each item of mail is read and delt with, it can be filed away quickly and without any further thought by filters. Currently, the workflow in Thunderbird seems very clumsy and laborious after having used Eudora -  I am hoping this feature will be added soon, otherwise I'll have to swap back.  

This involves a keystroke or "run filters" button that is applied to the selected message or messages, not the entire mailbox.
Depends on: 440635
Assignee: dwiggins → beckley
Status: ASSIGNED → NEW
Depends on: 444209
I agree and when I talk to ppl who have never heard of Eudora and filters - they have no idea what they are missing and after thinking about filtering, they usually try eudora and never go back. Right now, I'm having trouble staying with Eudora 8 - is this suposed to be Eudora or 1/2 Eudora?
bug 11039 and bug 359236

are chalked full of good ideas
No Filters in Eudora 8 ?!?
For filtering messages in Thunderbird, I found that the Nostalgy add-on was a good solution:
https://addons.mozilla.org/en-US/thunderbird/addon/2487
You can define very specific filter criteria and execute the filter with a single keystroke.  Without this add-on, I wouldn't be using Thunderbird...
renaming this to 'Filters: Outgoing Filters, Before send and After Send.' as we already have various incoming contexts (Incoming, Manually run, and combinations before and after junk classification)
Summary: Filters: Filter Contexts: Incoming, Manual, Before send, After Send. → Filters: Outgoing Filters, Before send and After Send.
Duplicate of this bug: 536329
Duplicate of this bug: 361321
Penelope didn't see any activity in the vcs for the last 8 years, closing.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.