Last Comment Bug 360336 - Firefox doesn't detect missing wmp plugin, prompts to install Player, not plugin
: Firefox doesn't detect missing wmp plugin, prompts to install Player, not plugin
Status: RESOLVED WONTFIX
:
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: x86 Windows XP
: -- normal with 4 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 363632 365190 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-10 20:06 PST by Majken Connor [:Kensie]
Modified: 2013-02-05 14:17 PST (History)
13 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Majken Connor [:Kensie] 2006-11-10 20:06:11 PST
It seems like Windows Media Player no longer comes with the npdsplay.dll plugin and firefox doesn't find and install it.

Also, I seem to recall some cases where people had a plugin installed but still had issues (on myspace for instance) where this plugin http://www.microsoft.com/windows/windowsmedia/player/version64/plugin.aspx made things work.  I was hoping to get more info about this case before filing, but I haven't had much luck and a lot of people are having problems.  I'm not sure if this is the most recent plugin, or if it's an old one or what.

In any case, there's a lot of windows media content out there and we're seeing quite a number of people in #firefox with this issue now.  I'll comment back with more info if I can get it and some links.
Comment 1 Frank Wein [:mcsmurf] 2006-11-11 05:25:28 PST
Do you know if those people happen to run a special version of Windows XP, like the Media Center edition? kb.mozillazine.org mentions that this version does not include the WMP plugin and/or has a problem with it.
Comment 2 Majken Connor [:Kensie] 2006-11-11 18:10:19 PST
No, I've had this happen to me myself and both my pc's are home edition.  In any case, even if those versions don't come with the plugin, that doesn't solve the problem that firefox isn't detecting that it's the wmp plugin needed.
Comment 3 Majken Connor [:Kensie] 2006-11-14 12:36:50 PST
added url

Just helped someone with media center edition.  What happened to him is he was being directed to download windows media player, but he already had that installed, he needed the plugin.  I'll delete my version of the plugin and report back on what happens on xp home.
Comment 4 Nick Thomas [:nthomas] 2006-12-12 13:27:46 PST
*** Bug 363632 has been marked as a duplicate of this bug. ***
Comment 5 Steven Ostrowski 2006-12-31 05:17:46 PST
Same problem here, I am running XP Media Center Edition, videos like the URL don't play (neither does CNN.com videos which is the most annoying).  My research shows it's only an issue with MCE.  However, I don't think the proper resolution is to say it's a bug with MCE.  Firefox should be able to work on MCE, a lot of people view things like CNN.com videos and don't have the expertise to figure out manual workarounds.  This can be a big turnoff to someone trying out Firefox.
Comment 6 Patrick 2006-12-31 05:34:14 PST
*** Bug 365190 has been marked as a duplicate of this bug. ***
Comment 7 Lisa M Livingston 2007-01-13 12:20:02 PST
I am having the same issue. Sadly I am not an expert on Windows Media Player. I really like my music and I view videos on cnn and yahoo. When I do try to view them I get an error that says install missing plug ins. When I click install, there aren't any there to install. I have no clue what to do next! If anyone can help me please reply!
Comment 8 Majken Connor [:Kensie] 2007-01-13 17:55:37 PST
Lisa,

If you read the description there is a link to the plugin you need to get things to work.
Comment 9 Alice Wyman 2007-01-14 15:52:55 PST
Lisa,
 
If you need more help, see:
http://kb.mozillazine.org/Windows_Media_Player#Missing_plugin
Comment 10 Patrick Kelly 2007-02-21 16:12:35 PST
I'm new to Firefox so please forgive me if I'm repeating something...

I'm writing a web page with an embed tag for a ".avi" file and cannot get it to work in Firefox.  I've tried:
<embed height="240" width="320" src="filename.avi" type="application/avi" />
and
<embed height="240" width="320" src="filename.avi" type="video/avi" autostart="true" controls="false" loop="false" />
but neither works in Firefox.  They both work in IE6 and the Netscape plug-in finder works fine and shows the video.
I use WXP-Pro and Media Player Classic instead of WMP.

Am I coding this correctly or is this the same problem being reported here?

Thanks,

Patrick.
Comment 11 Jim Ruble Sr 2007-02-21 17:35:59 PST
(In reply to comment #10)
> I'm new to Firefox so please forgive me if I'm repeating something...
> I'm writing a web page with an embed tag for a ".avi" file and cannot get it to
> work in Firefox.  I've tried:
> <embed height="240" width="320" src="filename.avi" type="application/avi" />
> and
> <embed height="240" width="320" src="filename.avi" type="video/avi"
> autostart="true" controls="false" loop="false" />
> but neither works in Firefox.  They both work in IE6 and the Netscape plug-in
> finder works fine and shows the video.
> I use WXP-Pro and Media Player Classic instead of WMP.
> Am I coding this correctly or is this the same problem being reported here?
> Thanks,
> Patrick.

Comment 12 Jim Ruble Sr 2007-02-21 17:40:17 PST
Sorry, I hit the wrong thing and sent the previous email before I could comment. I am sorry I can't assist you on the web page writing, the only one I have done was via Earthlink and it was just a matter of clicking and selecting. The problem I was having was trying to get plugins to install for Windows Media Player 10. Good luck, hope someone can help you. 
(In reply to comment #10)
> I'm new to Firefox so please forgive me if I'm repeating something...
> I'm writing a web page with an embed tag for a ".avi" file and cannot get it to
> work in Firefox.  I've tried:
> <embed height="240" width="320" src="filename.avi" type="application/avi" />
> and
> <embed height="240" width="320" src="filename.avi" type="video/avi"
> autostart="true" controls="false" loop="false" />
> but neither works in Firefox.  They both work in IE6 and the Netscape plug-in
> finder works fine and shows the video.
> I use WXP-Pro and Media Player Classic instead of WMP.
> Am I coding this correctly or is this the same problem being reported here?
> Thanks,
> Patrick.

Comment 13 Don Yung 2007-04-07 09:27:55 PDT
I am running vista home premium.  When I try to view videos fron CNN the screen comes up with no vmp installed.  (I have VMP 11 installed.)  I tried going to Micro and download it again but when I try to install it it says it is alredy installed which I knew it was but it still get the same VMP not installed after I tried that.
Comment 14 Pavel Cvrcek [:JasnaPaka] 2007-04-07 09:30:30 PDT
(In reply to comment #13)
> I am running vista home premium.  When I try to view videos fron CNN the screen
> comes up with no vmp installed.

See #bug 342323.

Comment 15 Jim Ruble Sr 2007-04-07 11:57:05 PDT
Since I have downloaded a newer version of FireFox ( Firefox/2.0.0.3 ) I haven't had the problem with the message appearing and the media player has played everything I have tried. Thanks to all those who replied to my original post.
Comment 16 Majken Connor [:Kensie] 2007-04-25 11:10:59 PDT
Firefox still prompts the user to install the entire wmp program, which still doesn't include the plugin. Editing the summary to reflect.
Comment 17 Robert Strong [:rstrong] (use needinfo to contact me) 2007-04-25 11:13:12 PDT
majken, the url you added points to a page with a flash video. Did the page change? If so, can another example url be added and if not the url should be removed unless I'm missing something here.
Comment 18 Majken Connor [:Kensie] 2007-04-25 11:20:08 PDT
It must have changed.  I just helped a user that said they were prompted for the whole program on http://www.tv5.fr/TV5Site/programmes/accueil_continent.php
Comment 19 Majken Connor [:Kensie] 2007-04-25 11:30:18 PDT
I've just tested this myself, and the manual install button does link me to the new page now.
Comment 20 Corey May 2007-04-25 11:44:43 PDT
While not a solution within FF, MS has come up with a workaround in a new plugin.
http://preview.tinyurl.com/2j3bds
Comment 21 Steven Ostrowski 2007-04-25 12:03:11 PDT
(In reply to comment #20)
> While not a solution within FF, MS has come up with a workaround in a new
> plugin.
> http://preview.tinyurl.com/2j3bds
> 

This only works with WMP 11, which means you need to upgrade and accept all their additional DRM restrictions.  Just wanted to comment so that people realize there's still an issue for everyone else who doesn't use WMP 11.
Comment 22 Alice Wyman 2007-04-25 13:47:38 PDT
(In reply to comment #21)
> This only works with WMP 11, which means you need to upgrade and accept all
> their additional DRM restrictions. 
The new plugin also works with WMP10 and WMP9 on Windows XP SP2, according to the feedback here:
http://kb.mozillazine.org/Talk:Windows_Media_Player#New_WMP_plugin_for_firefox 
and here:
http://forums.mozillazine.org/viewtopic.php?p=2846556#2846556




Comment 23 Lisa M Livingston 2007-07-05 10:32:14 PDT
(In reply to comment #0)
> It seems like Windows Media Player no longer comes with the npdsplay.dll plugin
> and firefox doesn't find and install it.
> 
> Also, I seem to recall some cases where people had a plugin installed but still
> had issues (on myspace for instance) where this plugin
> http://www.microsoft.com/windows/windowsmedia/player/version64/plugin.aspx made
> things work.  I was hoping to get more info about this case before filing, but
> I haven't had much luck and a lot of people are having problems.  I'm not sure
> if this is the most recent plugin, or if it's an old one or what.
> 
> In any case, there's a lot of windows media content out there and we're seeing
> quite a number of people in #firefox with this issue now.  I'll comment back
> with more info if I can get it and some links.
> 

I have installed the new plugin an will let you know if this is actually working.
Thanks for all the help. I really hope this works, I really prefer firefox. (In reply to comment #9)
> Lisa,
> 
> If you need more help, see:
> http://kb.mozillazine.org/Windows_Media_Player#Missing_plugin
> 

Thank you! I have followed your link and I am hoping this solves my problem. Firefox is the best and I want to keep using it. I will comment back if it doesn't work. Thanks again!
Comment 24 Benjamin Smedberg [:bsmedberg] 2013-02-05 14:17:56 PST
We are removing PFS, and will not prompt users to install this plugin in the future.

Note You need to log in before you can comment on or make changes to this bug.