Last Comment Bug 342323 - windows media player plugin isn't provided with windows vista
: windows media player plugin isn't provided with windows vista
Status: RESOLVED WORKSFORME
:
Product: Plugins Graveyard
Classification: Graveyard
Component: Windows Media Player (Microsoft) (show other bugs)
: unspecified
: x86 Windows Vista
: -- normal
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
http://members.aol.com/jrzycrim01/moz...
: 345944 376732 (view as bug list)
Depends on:
Blocks: 352420
  Show dependency treegraph
 
Reported: 2006-06-21 11:21 PDT by Derek Pugh
Modified: 2016-04-28 09:16 PDT (History)
32 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Derek Pugh 2006-06-21 11:21:35 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1a3) Gecko/20060526 BonEcho/2.0a3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1a3) Gecko/20060526 BonEcho/2.0a3

FireFox and Bon Echo (tested both) do not detect the windows media player plugin when installed on a fresh install of Windows Vista Beta 2 x86.  This comes by default with Media Player 11 Beta, and will not allow me to install any older WMP verions or codecs (I tried).  I have not reinstalled Vista Beta to see if it was something with the install.

Reproducible: Always

Steps to Reproduce:
1.Install Firefox or Bon Echo on a Fresh install of Windows Vista Beta 2
2.Go to any website with inbeded WMP
3.Won't work
Comment 1 Christian :Biesinger (don't email me, ping me on IRC) 2006-06-25 11:29:53 PDT
the pluginfinder service is not involved here, core:plugins was the right component...
Comment 2 Tom Graham 2006-07-09 03:25:36 PDT
Confirming Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4.

WMP 11 still seems quite unstable at the moment. The WMP plugin doesn't appear in about:plugins as I think it does in XP / lower. For those looking for a work-around, download VLC, and use the browser plugin feature on that - it does basic WMV playback in browser.
Comment 3 Matthew Kairys 2006-09-20 08:09:05 PDT
Windows Vista RC1 still has the same problems. Might need to wait until WMP supports other browsers in Vista since Opera 9.01 does not pick up that plugin either.
Comment 4 Doug Turner (:dougt) 2006-09-20 09:14:59 PDT
looking around on a clean install of Vista rc1, i do not find any npapi style plugins related to WMP.
Comment 5 Doug Turner (:dougt) 2006-09-28 11:36:11 PDT
*** Bug 345944 has been marked as a duplicate of this bug. ***
Comment 6 Jan M 2006-10-25 16:30:34 PDT
The WMP 11 Beta installer for XP/lower doesnt contain any netscapeplugin either. (The installer is unzipable, that s how i checked) 
So on those system the old plugins will be used. Therefor you will see the old controls (unless you switch to fullscreen)
Just for the record there wasnt any plugin file in question on a RC2 install either.

Is MS going to drop nsplugin support on WMP?

Comment 7 Jan M 2006-10-31 14:25:38 PST
Yesterday, the final Version of WMP 11 was released. Now the plugin uses the new designed controls.
However, this isnt done by the plugin itself.. as those are still unchanged in the WMP folder in /Program Files/. And there is no plugin shiped with the WMP installer.
Comment 8 Dave Carlson 2006-12-05 01:42:22 PST
same problem under Vista RTM
Comment 9 samuelmarks 2006-12-06 01:03:17 PST
Please help!


(maybe a third party wmv player?)
Comment 10 Scott 2006-12-22 21:25:16 PST
This is a major issue. I end up having to use Internet Explorer on any number of sites with embedded video.
Comment 11 Nick Thomas [:nthomas] 2007-01-14 16:27:41 PST
Work around, install this http://www.microsoft.com/windows/windowsmedia/player/version64/plugin.aspx
even though it says it's version 6.4 of WMP and for Netscape 4. We've helped many people on IRC with this.
Comment 12 john ruskin 2007-01-18 18:19:32 PST
I ve seen 3 or 4 various bugs that allude to WMP 11, CNN, WinXP and the plugins for WMP.

I have
WMP 11
Plugins -are- showing WMP plugins on about:plugins
WinXP home
2.0.0.1 Firefox
Inability for CNN videos [ever since i installed Fox 2.0; NOT cured by moving from WMP10 to 11]

I wonder what plugins for WMP are registered for my Firefox?  Are they different from those in the prior Comment#11?

I went to view SLATE.COM WMP files, per another related bug as a test case, and WMP 11 undertook a startup routine, texting Win Validity and other items, but returning to CNN did not result in a working video view.
Comment 13 john ruskin 2007-01-19 16:04:42 PST
The suggested work around in #11 does not change the behavior of CNN and video viewing failure.  I note that the prior fox [1.5, as updated], CNN video worked, but the buttons/sliders, for things such as volume control did not work.  IE worked, and continues to work with V7.  Unless this is a quirk to my machine and select others, I would recommend this bug for a major/blocking problem, akin to the crashes which still occur when picking up Yahoo mail...
Comment 14 Robert Strong [:rstrong] (use needinfo to contact me) 2007-01-19 16:08:45 PST
John, you are using WinXP per comment #12... right? This bug is about Win Vista.
Comment 15 john ruskin 2007-01-19 16:46:36 PST
Yes.  The failure[s] alluded to in all of the bugs implied, for me, that the bug isn't within the OS <--> Fox realm but within Fox.  Now, however, I wonder if the failure is more at between CNN's Server and my browser/client's report of its status; one or the other isn't recognizing the install on my machine.  Should that be true, does my bug/comment [also or solitarily] belong in non-compliant websites?
Comment 16 Robert Strong [:rstrong] (use needinfo to contact me) 2007-01-19 16:48:43 PST
Per comment #4 this bug is regarding the plugin not shipping with Vista... your bug is not this bug.
Comment 17 john ruskin 2007-01-19 22:12:09 PST
Yes, though I do note comments 6/7, and still infer the possibility that my install of WMP 11, and the CNN failure to recognize the product, may be connected to the interpositioning of the new WMP 11 and the new Fox 2, on my machine.  Seemed reasonable to raise this [the possible connection] to those looking at the series of bugs I alluded to; I accept that it is plausible that I am wrong and the two failures are unrelated, and that what began as a vista bug report on plugins, and morphed slightly into land-of-the-other-bug, is completely unrelated to the other bugs.
Comment 18 Robert Strong [:rstrong] (use needinfo to contact me) 2007-01-19 22:20:20 PST
That is a different issue than this bug... what you are experiencing is known and you can get help with fixing that in the support forums.

http://forums.mozillazine.org/
Comment 19 Michael Gabriel 2007-02-05 05:48:00 PST
wmp11 works for me if i copy the np*.dlls into the program files (x86)/plugins install folder of seamonkey, but the video breaks when i scroll or the video moves outside of the browser window (wmp 11.0.6000.6324 on vista x64 business, sm 1.1)
Comment 20 Adam Guthrie 2007-02-17 15:57:06 PST
If anything, we should put the workaround in the relnotes of whatever 1.8.1.x version will claim to support Vista.
Comment 21 Scott 2007-03-02 03:53:36 PST
(In reply to comment #11)
> Work around, install this
> http://www.microsoft.com/windows/windowsmedia/player/version64/plugin.aspx
> even though it says it's version 6.4 of WMP and for Netscape 4. We've helped
> many people on IRC with this.
> 

Interesting..

I went to that page and noticed that Microsoft specifically states

"Note: This plug-in is not supported on the Windows Vista operating system."

Was this there when you were suggesting it on IRC or has it since been added?
Comment 22 Michael Gabriel 2007-03-02 10:49:42 PST
that plugin fails to install on windows vista 64 business cause of unregmp2.exe
Comment 23 Ben 2007-03-20 12:49:46 PDT
Confirming this bug on Vista Business x86. Very annoying. I have VLC installed, if that makes a difference.
Comment 24 Masatoshi Kimura [:emk] 2007-04-06 13:27:59 PDT
*** Bug 376732 has been marked as a duplicate of this bug. ***
Comment 25 Masatoshi Kimura [:emk] 2007-04-17 05:17:38 PDT
Microsoft released WMP Plugin for Windows Vista now.
http://port25.technet.com/pages/windows-media-player-firefox-plugin-download.aspx
FIXED?
Comment 26 cheetos 2007-04-17 08:09:47 PDT
(In reply to comment #25)
> Microsoft released WMP Plugin for Windows Vista now.
> http://port25.technet.com/pages/windows-media-player-firefox-plugin-download.aspx
> FIXED?
> 

Excellent! That works perfectly! I'm using Vista x64. Thank you!
Comment 27 Majken Connor [:Kensie] 2007-04-25 11:05:08 PDT
We still have the problem that the plugin finder detects that the plugin is missing and prompts the user to install the whole program, which doesn't include the plugin - Bug 360336
Comment 28 Marco Bonardo [::mak] 2007-07-05 09:42:11 PDT
this is not really fixed, so adding dependancy to 360336
Comment 29 Robert Strong [:rstrong] (use needinfo to contact me) 2007-07-05 09:53:15 PDT
(In reply to comment #28)
> this is not really fixed, so adding dependancy to 360336
This bug was for the Vista specific issue of not providing a WMP plugin... bug 360336 is for an issue that affects XP and is a separate issue. Fixing this bug does not depend on fixing bug 360336.
Comment 30 Marco Bonardo [::mak] 2007-07-05 10:14:58 PDT
sorry but "Vista specific issue of not providing a WMP plugin..." can be fixed only by microsoft.

the plugin now exists and the only problem that can be fixed here is Bug 360336, that does affect Vista also, not only XP (i had to explicitely install the plugin in Vista)
Comment 31 Robert Strong [:rstrong] (use needinfo to contact me) 2007-07-05 10:19:15 PDT
(In reply to comment #30)
> sorry but "Vista specific issue of not providing a WMP plugin..." can be fixed
> only by microsoft.
Right, and this is the bug we tracked Microsoft providing a WMP plugin.

> the plugin now exists and the only problem that can be fixed here is Bug
> 360336, that does affect Vista also, not only XP (i had to explicitely install
> the plugin in Vista)
No, bug 360336 can be fixed in bug 360336.
Comment 32 Chris Cunningham 2008-02-14 04:27:24 PST
So what's the purpose of this bug, now? To add the technet plugin to the PFS on Vista?
Comment 33 Michael Gabriel 2008-02-14 10:40:26 PST
the technet plugin might work for ff, but it doesnt for sm !

Note You need to log in before you can comment on or make changes to this bug.