Closed Bug 360428 Opened 18 years ago Closed 18 years ago

Instances of "AskJeeves" should be replaced with "Ask.com"

Categories

(SeaMonkey :: Search, defect)

defect
Not set
trivial

Tracking

(Not tracked)

RESOLVED FIXED
seamonkey2.0a1

People

(Reporter: it_gone, Assigned: mail)

References

Details

Attachments

(2 files, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061111 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061111 SeaMonkey/1.5a

Due to the site's name change, instances of "AskJeeves" should be changed to the current name, "Ask.com". Such instances appear in Edit -> Preferences -> Navigator -> Internet Search under the "Default Search Engine" drop-down and on the location bar when "AskJeeves" is selected as the default search engine.

Reproducible: Always

Actual Results:  
"AskJeeves" is seen.

Expected Results:  
"Ask.com" should be seen.
I'll post a patch for this when bug 360495 is fixed.
Status: UNCONFIRMED → NEW
Component: General → Search
Depends on: 360495
Ever confirmed: true
Product: Mozilla Application Suite → Core
Version: unspecified → Trunk
No longer depends on: 360495
If I have this right... this should make the changes required to fix this bug (I haven't renamed 'jeeves.src' as I didn't really know how to do that and it didn't seem v important)
It also adds queryCharset and Charset parameters.
And updates the parsing to take account of the current site formatting.

I haven't added any update info as it's outside the scope of this bug and would require the file to be hosted at, for example, http://www.mozilla.org/projects/search/jeeves.src.

Neil, I was pointed your way for review so my apologies if you're not the right person. I'd be grateful if you could point me in the correct direction.
Attachment #245980 - Flags: review?(neil)
Comment on attachment 245980 [details] [diff] [review]
AskJeeves->Ask.com, cater for utf-8, update parsing

>-<inputnext name="page" factor="1">
>-<inputprev>
May I ask why you removed these? I found that I had to click "Next" twice to get the search sidebar to advance to the next page of results, but I guess that's because Ask uses page numbering rather than result offsets?
It was more habit than anything else to be honest.
That habit comes from the fact that there are a few bugs with previous/next.
In particular bug 150337 comes to mind. (Click next to get to page 4 and then previous takes you to page 2)

If you'd prefer to leave them in then that's fine with me. (At the moment the Google plugin has them, this has them and dmoz doesn't)
See bug 150333 for the reason you have to click next twice. (0 based and 1 based indices)
Status: NEW → ASSIGNED
Assignee: general → bzmozilla
Status: ASSIGNED → NEW
(Apologies, changed the wrong field first)
Status: NEW → ASSIGNED
Attached patch With inputnext/inputprev (obsolete) — Splinter Review
Attachment #246027 - Attachment is obsolete: true
I've added an alternate patch which retains the inputnext/inputprev values.
See also comment #4.
r=me on that latest patch (did you want me to move the flag?)
Attachment #245980 - Flags: review?(neil) → review-
Attachment #246028 - Flags: review?(neil)
Attachment #246028 - Flags: review?(neil) → review+
Um... not actually sure what needs to be done to finish this off.
Does this need super-review - it's not really code so it doesn't seem to be required but I might be wrong. Or do I just ask someone to check it in now.
(Apologies for ignorance, I'm rather new to this)
Attachment #246028 - Flags: review?(gavin.sharp)
Attachment #246028 - Flags: review?(gavin.sharp) → review+
Whiteboard: [checkin needed]
mozilla/xpfe/components/search/datasets/jeeves.src 	1.7
Status: ASSIGNED → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]
Target Milestone: --- → mozilla1.9alpha
Product: Core → SeaMonkey
Target Milestone: mozilla1.9alpha1 → seamonkey2.0a1
You need to log in before you can comment on or make changes to this bug.