Account manager must allow multiple email addresses per user id

RESOLVED INVALID

Status

Thunderbird
Account Manager
--
major
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: Philip Chalmers, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Thunderbird version 1.5.0.8 (20061025)

My ISP (blueyonder - www.blueyonder.co.uk) provides 15 email addresses spread over 4 user ids. The user ids are base-userid, base-userid_2, base-userid_3, base-userid_4. I have multiple email addresses per user id, for example my wife and I used different email addresses for different classes of email, so we can scrap the most public email addresses if we get too much spam (this was before I installed T-bird).
But when I tried to set up a 2nd email address for a user id, Account manager objected.
This is a serious problem - some people will not be able to email me using the addresses I've given them.

Reproducible: Always

Steps to Reproduce:
1. Get ISP which allows multiple email addresses per user id.
2. Try to set up multiple email addresses per user id (user name in Account manager's "Server Settings" tab.
3.

Actual Results:  
Error message saying I can't have multiple accounts with same user name.

Expected Results:  
Allow multiple email addresses per user id.

Occurs with default theme, have not tried again since using another theme).

Comment 1

12 years ago
Since you only have 4 user ids you can only set up 4 accounts. You can add the other e-mail addresses as identities though. (Click "Manage Identities" under account settings)

If that resolves the issue, mark this bug as resolved|invalid.

Comment 2

12 years ago
This report is pretty vague, not to mention confusing.  How are you trying to "set up multiple accounts for a single userid"?  An "account" in Mozilla describes a server+userid configuration where mail can be retrieved.  If your ISP is directing mail to the 15 addresses into four separate userids, why do you need to set up more than four accounts?

If the problem is about outgoing messages (altho I don't think that's what you're saying) you can define as many outgoing email addresses as you like by creating a new identity for each one -- click the Manage Identities button in the Account Settings for this.
(Reporter)

Comment 3

12 years ago
(In reply to comment #2)
> This report is pretty vague, not to mention confusing.  How are you trying to
> "set up multiple accounts for a single userid"?  An "account" in Mozilla
> describes a server+userid configuration where mail can be retrieved.  If your
> ISP is directing mail to the 15 addresses into four separate userids, why do
> you need to set up more than four accounts?
> 
> If the problem is about outgoing messages (altho I don't think that's what
> you're saying) you can define as many outgoing email addresses as you like by
> creating a new identity for each one -- click the Manage Identities button in
> the Account Settings for this.
> 

OK, I see what the problem is. My last email client was Outlook, where:
* account = email address.
* each account also has a separate displayed name, e.g. I call the one I register on web sites with and use ofr general correspondence (and am prepared to scrap if I get too much spam) "Phil (general)", and the one I reserve for correspondence is called "Phil (friends)".

Most of the people who are likely to switch to T-bird are currently using Outlook or Outlook Express, so T-bird needs to make it easy for them.

Comments #1 and #2 correctly point out that the "manage identities" button makes it possible to have multiple email addresses for each of the user ids as seen by the ISP.

But that does not resolves the issue, it transforms it into 2 further sets of issues:
* UI
* documentation.

For the rest of this note:
* I will not use the term "account" except in "Account Manager".
* User id is what the ISP's login process deals with.
* Email address is email address.

UI issues (note plural)
---------
(1) Nothing in Account Manager tells a newbie (like me! and like all the other people you hope will switch to T-bird!) that "identity" = email address.
(2) There's no context-sensitive Help.
(3) The grouping of items in the first pane / tab / whatever of Account Manager is very unhelpful and it harder for newbies to deal with UI issue (1), since "Manage identities" is in a separate field group from the default identity and (illogically!!!) SMPT details are within the "default identity" group. I suggest: field group 1 contains account name (as at present) PLUS "account = user id as seen by your ISP", IF "account name" continues to have any usefulness (see 4 below); field group 2 is headed "Add / edit / delete identities", has a comment "identity = email address", and contains a button "Add / edit / delete additional identities"; field group 3 is SMTP details. And Each identity should have a separate name to be displyed in the "Compose message" window (see 4 below).
(4) In the "Compose message" window the "From" field contains a drop-down list of identities, each showing the name seen by the recipient (e.g. "John Smith"), the email address and the account name. Account name should be replaced by identity name (see last sentence of 3 above) and shown in a normal colour (not pale grey) an dpreferably bold, in order to differentiate easily between different identities where the person's name is the same and / or the email addresses are very similar - or the email address has changed (happened to me when the same ISP changed its own name).

Documentation issue
-------------------
The standard T-bird help facility is a single Web page, which links to a FAQ and to Nidelven IT's tutorial. The Web page takes time to load, while Help should be instant. Neither the FAQ nor the tutorial says anything about identities. Yet setting up accounts is something that new users have to do when they first launch T-bird.
T-bird needs a decent Help facility which is downloaded with the software but can be updated. I'll help write the Help if required.

Comment 4

12 years ago
(In reply to comment #3)
> (1) Nothing in Account Manager tells a newbie (like me! and like all the
> other people you hope will switch to T-bird!) that "identity" = email
> address.

Bug 274142.


> (2) There's no context-sensitive Help.

Bug 262465.


> (3) The grouping of items in the first pane / tab / whatever of Account
> Manager is very unhelpful

Bug 327120, maybe others.  This is about the only thing you're complaining about that I agree is a problem; the differences between identity and account are not well enough distinguished in the UI for the account manager.  (In particular, the "account manager" settings for Copies&Folders and Composition are all actually identity-specific settings.)



> (4) In the "Compose message" window the "From" field contains a drop-down
> list of identities, each showing the name seen by the recipient (e.g. "John
> Smith"), the email address and the account name.  Account name should be
> replaced by identity name

Bug 360927 (posted by someone who understands the "one issue per bug" rule).


> I'll help write the Help if required.

Great.  Start here:  http://www.mozilla.org/contribute/
In the newsgroups: mozilla.dev.documentation

In the mean time: stop filing bugs.  Bugzilla is not a user-support forum.
Ask around in  mozilla.support.thunderbird  to get a handle on things before coming in here and opening a bug for every frustration you encounter.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

12 years ago
(In reply to comment #4)
> (In reply to comment #3)
>... someone who understands the "one issue per bug" rule"
This started as 1 issue, but responses #1 and #2 made me realise that the difficulty I had experienced was a result of a combination of issues.

>...opening a bug for every frustration you encounter
* I encountered this particular frustration the first time I launched T-bird. A newbie-UNfriendly UI and lack of newbie-friendly documentation are very serious defects.
* I searched Bugzilla for status=all product=Thunderbird words:[account multiple email address] and got no genuine matches before I posted this one.

>> I'll help write the Help if required.
>Great.  Start here:  http://www.mozilla.org/contribute/
>In the newsgroups: mozilla.dev.documentation
http://www.mozilla.org/contribute/ seems to be entirely programming-oriented, and I don't have the skills for that.
I searched Google Groups for mozilla.dev.documentation and got 1 hit, with the comments "Low activity, 7 subscribers". The hit linked to page http://groups.google.co.uk/group/mozilla.dev.documentation?lnk=gschg&hl=en - which is spam-infested and contains only 2 items about documentation, but both programming-oriented.

So where do I start in order to contribute to user-oriented documentation?

Comment 6

12 years ago
There are other things than programming there, perhaps this would suit you?
http://wiki.mozilla.org/Thunderbird:Help_Documentation
http://wiki.mozilla.org/Thunderbird:Help_Documentation:Base
You need to log in before you can comment on or make changes to this bug.