[Proto] Event dialog: Thunderbird freezes after clicking the close button of New Events Window

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: elichak, Unassigned)

Tracking

Lightning 0.3
x86
Windows XP

Details

(Reporter)

Description

12 years ago
Overview Description: Thunderbird freezes after the New Event close button (top right) is clicked

Steps to Reproduce: 

1) Double-click on a date on the calendar.
2) The New Event window will pop-up.
3) Type in a Title and put the same date/time for Start and End
4) Click on the close button (top right)
5) Click on yes to save

Actual Results: Thunderbird freezes

Expected Results: The calendar should show the new event or tell the user that the start and end date has to be different?

Build Date & Platform: 2006120103 Lightning on Windows
(Reporter)

Updated

12 years ago
Severity: normal → critical

Comment 1

12 years ago
this sounds like a lightning issue
Severity: critical → normal
Component: General → General
Product: Thunderbird → Calendar
Version: 2.0 → Lightning 0.3

Updated

12 years ago
Assignee: mscott → nobody
QA Contact: general → base
(In reply to comment #0)

> 4) Click on the close button (top right)
> 5) Click on yes to save

As far as I know the 'normal' Lightning doesn't offer this functionality. 
Did you use the 'wcap' enabled Lightning that uses the prototype event dialog?
> (In reply to comment #2)
The normal event dialog doesn't offer this functionality -> prototype event dialog was used.
Summary: Thunderbird freezes after clicking the close button of New Events Window → [proto event dialog] Thunderbird freezes after clicking the close button of New Events Window
Duplicate of this bug: 362503
Summary: [proto event dialog] Thunderbird freezes after clicking the close button of New Events Window → [Proto] Event dialog: Thunderbird freezes after clicking the close button of New Events Window

Comment 5

12 years ago
I can't reproduce this with Lightning 2007072204 / Thunderbird 2.0.0.5
and using the prototype event dialog.
WFM with Tb 2.0.0.6pre + Lightning 0.7pre (2007072704) on WinXP, but the event dialog should not allow to create such events (same start/end time) as long as we can't show them in Lightning.
(In reply to comment #6)
> but the event dialog should not allow to create such events (same start/end
> time) as long as we can't show them in Lightning.
Although I totally agree that the event dialog shouldn't allow to create zero-length events (at least for newly created events), I would like to add that there might be zero-length events need to be displayed (in the calendar views) that were created by some external instance and our dialog needs to handle this case gracefully. Just for reference purposes, bug #324662 is dedicated to displaying zero-length events in the views.
If we allow showing zero-length events (which should be the case), I don't think anything should speak against creating zero-length events. As long as we find a way to display them in a sensible way, everything should be fine.
Whiteboard: [qa discussion needed]

Comment 9

11 years ago
We should definitely allow zero length events.  It is part of the spec, and for some reason I can't fathom, people may want to use them.  

We also need to understand the display implications of that.  I think the display implications are being addressed in bug 387402, so I am going to mark this bug as WFM: Lightning ID: 2007100109 (0.7RC1) Tbird: version 2.0.0.6 (20070728) Windows XP 
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Whiteboard: [qa discussion needed]
You need to log in before you can comment on or make changes to this bug.