Closed Bug 363043 Opened 13 years ago Closed 13 years ago

Unfork Sb's customizeToolbar

Categories

(Calendar :: Sunbird Only, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: philor, Assigned: philor)

References

Details

(Keywords: fixed1.8.1.2)

Attachments

(1 file)

Once bug 359656 lands, it's just a matter of a little #ifdef-wrapped % style and packaging the XUL file from toolkit/.
Depends on: 363098
Depends on: 359656
Attached patch Approach 1Splinter Review
Unfortunately, I didn't get home with enough time to land the bug 359656 patch before the reflow tree closure tonight, but if you imagine that checked in, this is my probably-preferred approach: we could just alias chrome://calendar/content/customizeToolbar.xul to the toolkit URL in the jar.mn instead, and just have one openDialog, if you really don't want to preprocess calendar.js, but that seems less likely to get cleaned up properly when you decide to get rid of the 1.8branch ifdefs somewhere down the line.
*** Bug 358386 has been marked as a duplicate of this bug. ***
Comment on attachment 247928 [details] [diff] [review]
Approach 1

Yeah, I think this is the best way to be obvious about what we're doing, and thus catch the attention of J. Random Toolkithacker when he's mucking with callers of chrome://global/content/customizeToolbar.xul
Attachment #247928 - Flags: first-review?(jminta)
Status: NEW → ASSIGNED
Comment on attachment 247928 [details] [diff] [review]
Approach 1

r=jminta
Attachment #247928 - Flags: first-review?(jminta) → first-review+
Trunk:
calendar/sunbird/base/jar.mn 1.15
calendar/resources/content/calendar.js 1.247
calendar/resources/jar.mn 1.146

Branch:
calendar/sunbird/base/jar.mn 1.9.2.6
calendar/resources/content/calendar.js 1.200.2.36
calendar/resources/jar.mn 1.114.2.31

Welcome back :)
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Keywords: fixed1.8.1.2
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.