libgfxps.a to lubxul.so link error - Bustage caused by printing on linux bug 323928

RESOLVED FIXED

Status

()

RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: romaxa, Assigned: laurent)

Tracking

({regression})

Trunk
x86
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 obsolete attachments)

(Reporter)

Description

12 years ago
XULRunner build was broken after this commit:

http://bonsai.mozilla.org/cvsquery.cgi?module=MozillaTinderboxAll&branch=HEAD&cvsroot=/cvsroot&date=explicit&mindate=1164843420&maxdate=1164843721&who=pavlov%25pavlov.net

tinderbox:
http://tinderbox.mozilla.org/showbuilds.cgi?tree=XULRunner&hours=24&maxdate=1164918837&legend=0

printing on linux bug 323928.

I think we should remove nsGfxPSModule from nsStaticXULComponents.cpp and

gfxps from  libxul-config.mk
(Reporter)

Comment 1

12 years ago
Created attachment 247796 [details] [diff] [review]
Build fix
Attachment #247796 - Flags: first-review?(benjamin)
(Reporter)

Updated

12 years ago
Attachment #247796 - Flags: second-review?(pavlov)

Comment 2

12 years ago
Comment on attachment 247796 [details] [diff] [review]
Build fix

You should just get rid of the POSTSCRIPT_MODULES define entirely, since it's blank in all cases.
Attachment #247796 - Flags: first-review?(benjamin) → first-review+

Comment 3

12 years ago
*** Bug 363436 has been marked as a duplicate of this bug. ***

Updated

12 years ago
Attachment #247796 - Flags: second-review?(pavlov) → second-review+
(Assignee)

Comment 4

12 years ago
Created attachment 248650 [details] [diff] [review]
the updated patch

this is a new patch, following benjamin's advices...
Attachment #247796 - Attachment is obsolete: true
Attachment #248650 - Flags: second-review?
Attachment #248650 - Flags: first-review?
(Assignee)

Updated

12 years ago
Attachment #248650 - Flags: second-review?
Attachment #248650 - Flags: first-review?(benjamin)
Attachment #248650 - Flags: first-review?

Updated

12 years ago
Attachment #248650 - Flags: second-review?(pavlov)
Attachment #248650 - Flags: first-review?(benjamin)
Attachment #248650 - Flags: first-review+

Updated

12 years ago
Attachment #248650 - Flags: second-review?(pavlov) → second-review+

Updated

12 years ago
Keywords: regression
Summary: Bustage fix printing on linux bug 323928 → libgfxps.a to lubxul.so link error - Bustage caused by printing on linux bug 323928
*** Bug 364105 has been marked as a duplicate of this bug. ***

Updated

12 years ago
Assignee: nobody → laurent
(Assignee)

Comment 6

12 years ago
could somebody check in the patch please ?
Whiteboard: [checkin needed]
(Assignee)

Comment 7

12 years ago
Timeless has landed the patch (thanks !)
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=MozillaTinderboxAll&branch=HEAD&branchtype=match&dir=mozilla%2Ftoolkit%2Flibrary&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2006-12-17+01%3A18&maxdate=2006-12-17+01%3A20&cvsroot=%2Fcvsroot

The last version of the trunk compiles on my desktop, but the build still fails on  the tinderbox, because of an other reason (see bug 364231). So the current bug is fixed for me.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]

Comment 8

12 years ago
Comment on attachment 248650 [details] [diff] [review]
the updated patch

mozilla/toolkit/library/libxul-config.mk 	1.37
mozilla/toolkit/library/nsStaticXULComponents.cpp 	1.40
Attachment #248650 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.