Closed Bug 363388 Opened 14 years ago Closed 14 years ago

[reflow branch] Forum threads disappear near end of page load

Categories

(Core :: Layout: Block and Inline, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: neil, Unassigned)

References

()

Details

(Keywords: regression)

When the page starts loading, you can see all the threads listed. However just before the page finishes loading, all the threads disappear.

I double-checked using a build from the reflow branch and that exhibits the same problem.
I too see this with
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/2006120804 Minefield/3.0a1 (post-reflow branch)

But not with
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/2006120606 Minefield/3.0a (pre-reflow branch)
Summary: Forum threads disappear near end of page load → [reflow branch] Forum threads disappear near end of page load
The long blank space is caused by an <img> inside a <span> with style="display: -moz-inline-boz;". I tried removing the rating controls and that solves the long blank space problem, but the content still fails to display

So, I believe this bug depends on either:
Bug 359769 - [reflow branch] huge white space on the page (OR)
Bug 363176 - [reflow branch] Very large scrollbar with this img inside -moz-inline-box
and once that's fixed the other problem may be easier to isolate. I'll come back to this later to try and reduce a testcase for the disappearing content.
Aaargh, I just spent the last hour verifying that because I didn't get biff :-(
Component: Layout → Layout: Block and Inline
QA Contact: layout → layout.block-and-inline
As a workaround I added this to my userContent.css

.CommonRateControlReadOnly { display: inline !important; }
(In reply to comment #4)
> As a workaround I added this to my userContent.css
> 
> .CommonRateControlReadOnly { display: inline !important; }
> 
You will also want to add
.ForumThreadRateControlReadOnly { display: inline !important; }

Now that I look at this again, bug 363176 is responsible for the disappearing content issue. I didn't test this properly - just removed the images using the DOM Inspector and the content didn't reappear. Not sure why that is.

There seems to be one other issue with the navigation images being cut off but that should be a different bug.

I think this should be marked as a dupe of bug 359769
(In reply to comment #5)
>You will also want to add
>.ForumThreadRateControlReadOnly { display: inline !important; }
Yes, that works well, thanks!

>I think this should be marked as a dupe of bug 359769
I'll mark the dependency for now, so we can see what happens when it's fixed.
Depends on: 359769
The patch attached to bug 9458 makes this page render correctly.
I can see the bug in a 2007-01-11 build, but not anymore in a 2007-01-14 build, fixed by the patch from bug 366667.
Status: NEW → RESOLVED
Closed: 14 years ago
Depends on: 366667
Resolution: --- → FIXED
If you don't mind I'll wait for the page to render correctly.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Is the bug still present, or not?  Neil, were you reopening because you thought it was closed in comment 7?  It was closed in comment 8.
(In reply to comment #10)
> Is the bug still present, or not?  Neil, were you reopening because you thought
> it was closed in comment 7?  It was closed in comment 8.
> 
The huge vertical space is gone, but the page rendering is incorrect.  The ratings  icons (which is the part of the page that created the issue) are now not displaying at all, or are displaying with a zero height.

The page renders correctly with the patch for bug 9458 applied.  It appears there are still issues relating to -moz-box-inline height.
(In reply to comment #11)
> there are still issues relating to -moz-box-inline height.
> 
                                     ^^^^^^^^^^^^^^^
                                     -moz-inline-box
I propose closing this bug and working the remaining issue either in a new bug or reopening bug 363176 which has a simplified testcase which exhibits the remaining issue.
I filed bug 368137 on the issue concerning height calculation on -moz-inline-block.
Fixed by bug 366667.
Status: REOPENED → RESOLVED
Closed: 14 years ago14 years ago
Resolution: --- → FIXED
(In reply to comment #11)
>The huge vertical space is gone, but the page rendering is incorrect. The
>ratings icons (which is the part of the page that created the issue) are now
>not displaying at all, or are displaying with a zero height.
Note that according to the DOM Inspector it has a negative position.
With the check-in for bug 9458, this page now renders as desired.
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.