Imported history items are not shown in sidebar (2)

VERIFIED FIXED

Status

()

Firefox
Bookmarks & History
VERIFIED FIXED
12 years ago
5 years ago

People

(Reporter: Ria Klaassen (not reading all bugmail), Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Could not reopen Bug 364269, so I'm filing this bug.
When I import a history.dat file, the items older than 6 days are not shown in the sidebar.
It is a history.dat file with old items, that is only used for the few last days and then imported. Sorry that I have no additional information.
I will add a screenshot.
(Reporter)

Comment 1

12 years ago
Created attachment 250325 [details]
comparison branch-trunk
(Reporter)

Comment 2

12 years ago
Just checked, but it is the same bug as Bug 364269.
Maybe it can't import the data when some days in between are missing.
I'll try to reproduce this, but ria, could you send me your history.dat?
(Reporter)

Comment 4

12 years ago
Setting browser.history_expire_days to 0 has no effect since Bug 355738 landed, it does not delete the history entries from the sqlite file; history is still present in the sidebar. Although it stops gathering new history.
The sanitize function (Tools > Clear Private Data) works however.
Could be that this is an independent bug, for I see it also without imported history.

So the steps are:
- Start Firefox in a new profile
- Visit www.cnn.com
- Set Tools > Options > Privacy > History > Remember visited pages to 0 days
- Close the browser
When you start the browser you'll see that www.cnn.com is still present; should be empty. 
I was just looking at the listener for browser.history_expire_days.

When the pref changes, we should get notified and if the value has changed

http://lxr.mozilla.org/seamonkey/source/toolkit/components/places/src/nsNavHistory.cpp#2884, which will set mNextExpirationTime to 0, but it may not be forcing and expiration.

If fx 2.0 cleared history when you set it to 0, fx 3.0 should do the same thing.

I'll investigate as I'm poking at the expiration code lately for bug #363621

thanks ria!
Assignee: nobody → sspitzer
ria, I've spun out your issue (from comments #4 and #5) to bug #366075.
(Reporter)

Comment 7

11 years ago
Bug 366589 seems to have fixed this, but now there is a new issue: it takes very long (half a minute here) before the history "By Last Visited" appears in the sidebar.
Don't know if I should close this bug and file a new one, for maybe this issue is already covered by another bug.
But this bug, as filed, is fixed.
(Reporter)

Comment 8

11 years ago
Indeed fixed.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 9

11 years ago
verified with: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007080805 Minefield/3.0a8pre

this is basically covered in a general litmus testcase, but we'll break out each item of import into separate bugs in our work to flesh that area out.
Status: RESOLVED → VERIFIED
Flags: in-litmus?

Updated

10 years ago
Component: History → Bookmarks & History
QA Contact: history → bookmarks
removing in-litmus flag, it no longer exists
Flags: in-litmus?
You need to log in before you can comment on or make changes to this bug.