Closed Bug 365879 Opened 14 years ago Closed 14 years ago

Don't ship movemail.rdf on the Mac

Categories

(Thunderbird :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird2.0

People

(Reporter: mscott, Assigned: mscott)

References

Details

(Keywords: fixed1.8.1.2)

Attachments

(1 file)

Now that the RDF files can be installed via extensions for the account manager, I'd like to turn off movemail for the mac. if the demand is there we can ship it as an extension. I think the dotmac and gmail rdf files are going to be much more useful for most users.

We'll leave movemail on for unix
Attached patch the fixSplinter Review
don't define MOZ_MOVEMAIL in configure.in for the Mac.
Attachment #250419 - Flags: superreview?(bienvenu)
Comment on attachment 250419 [details] [diff] [review]
the fix

this will probably make a few folks unhappy, but anyone who can set up movemail can drop the rdf file in the right place :-)
Attachment #250419 - Flags: superreview?(bienvenu) → superreview+
Status: NEW → RESOLVED
Closed: 14 years ago
Keywords: fixed1.8.1.2
Resolution: --- → FIXED
Depends on: 379705
Movemail does not work in the official Mac builds even with movemail.rdf installed in the right place. It *does* work if you reverse this patch and make a custom build. IOW, this patch makes it impossible to use movemail on the Mac, rather than simply hiding the functionality. I take it that the latter is what was intended?
I can also confirm that Movemail does not work on MacOS X, even with the movemail.rdf in "/Applications/Thunderbird.app/Contents/MacOS/isp"

Was there good reason why this was taken out? Removing this has caused a bit of an inconvenience.
I also need the ability to access my OSX mail spool in Thunderbird, as I'm doing a lot of development involving postfix, and don't want to use an external mail server for testing, especially when offline.

At least please point to the location of a working .rdf file so that those who need it can re-enable this functionality. 

Thanks

Is there any way to re-enable movemail support on MacOS?

(In reply to daviewales from comment #6)

Is there any way to re-enable movemail support on MacOS?

It was re-enabled in official builds a long time ago. Currently working fine for me in 60.8.0.

Perhaps I'm missing something then.

I am working on the assumption that the movemail option should appear when I go to 'Tools -> Account Settings', then click 'Account Actions -> Other Account'. However, I only see the option 'Newsgroup Account'.

An old resolved bug is not a good place for this discussion in any case. Better to use the support forum: https://support.mozilla.org/en-US/questions/thunderbird

You need to log in before you can comment on or make changes to this bug.