Firefox's About Box claims "All Rights Reserved", which doesn't make sense for free software

RESOLVED DUPLICATE of bug 536336

Status

RESOLVED DUPLICATE of bug 536336
12 years ago
8 years ago

People

(Reporter: eric, Assigned: hecker)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.1) Gecko/20061205 Iceweasel/2.0.0.1 (Debian-2.0.0.1+dfsg-1)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.1) Gecko/20061205 Iceweasel/2.0.0.1 (Debian-2.0.0.1+dfsg-1)

The About Box contains the phrase "All Rights Reserved" next to the copyright declaration. Mozilla clearly hasn't reserved all it's rights since Firefox is licensed under the GPL/LGPL/MPL.

Even if it could be somehow argued that this phrase made sense for free software, it apparently doesn't make sense to use this phrase at all. Please see <http://en.wikipedia.org/wiki/All_rights_reserved> and <http://www.iusmentis.com/copyright/allrightsreserved/>.

Reproducible: Always
Assignee: nobody → hecker
Component: General → Licensing
OS: Linux → All
Product: Firefox → mozilla.org
QA Contact: general → gerv
Hardware: PC → All
Summary: About Box claims "All Rights Reserved", which doesn't make sense for free software → Firefox's About Box claims "All Rights Reserved", which doesn't make sense for free software
Version: unspecified → other
I think it makes reasonable sense. You start by reserving all rights, and then you grant some under whichever licence you are using. 

Presumably, if you are looking at any document or software you did not write which says "all rights reserved", then not _all_ the rights have been reserved, because you had the right to make the copy you have :-)

Having said that, it's quite possible that, as the Wikipedia article claims, it's unnecessary. But, just as I don't go to Slashdot for legal advice, I don't go to Wikipedia either. To remove it, we'd need to check with a lawyer.

Gerv
(Assignee)

Comment 2

12 years ago
I'll echo Gerv's comments: As far as I'm aware the practice of using "All rights reserved" on copyright notices is a traditional practice that once had a solid legal justification, but that at present is not (or at least may not be) necessary. However at the same time I know of no reason why this language in the notice would affect the rights of licensees of Mozilla code as granted by the MPL and other licenses. As Gerv notes, the copyright notice is a statement of ownership, i.e., who owns what; the notice is basically saying that the identified entity or entities (Initial Developer plus any Contributors) is entitled to all rights granted by government(s) under the applicable copyright law(s) (e.g., to make copies, create derivative works, etc.). Having thus established that they have such rights (as a necessary prelude), the entities in question can then proceed to grant certain of those rights to others per the MPL and/or other free software licenses. In this sense the licenses override or modify the perceived implications of the copyright notices.

In this case the "All rights reserved" language is not only in the About box, it's in the license boilerplate for every Mozilla source file; thus "fixing" this in the manner suggested (i.e., modifying the copyright notices) would be a major undertaking. Unless someone can provide a compelling argument that the "All rights reserved" language adversely affects the rights of Mozilla licensees, then I propose to leave the notices as is and resolve this bug as WONTFIX.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 3

12 years ago
I'd sooner claim invalid. The summary says that it doesn't make sense. And you've just explained that it does make sense :).

As for not fixing this, I'd agree. If we ever undertake yet another relicensing, the new license would of course be written in accordance with accepted standards of the time, and it would probably not include this line.

Now, it's /possible/ that the meaningless statement could be removed from just the about box, but that's the slippery slope to which you allude.

For comparison, this is MSIE 6's nested about content:
Based on NCSA Mosaic. NCSA Mosaic(TM); was developed at the National Center for Supercomputing Applications at the University of Illinois at Urbana-Champaign.
Distributed under a licensing agreement with Spyglass, Inc.
Contains security software licensed from RSA Data Security Inc.
Portions of this software are based in part on the work of the Independent JPEG Group.
Multimedia software components, including Indeo(R); video, Indeo(R) audio, and Web Design Effects are provided by Intel Corp.
Unix version contains software licensed from Mainsoft Corporation. Copyright (c) 1998-1999 Mainsoft Corporation. All rights reserved. Mainsoft is a trademark of Mainsoft Corporation.
Warning: This computer program is protected by copyright law and international treaties. Unauthorized reproduction or distribution of this program, or any portion of it, may result in severe civil and criminal penalties, and will be prosecuted to the maximum extent possible under the law.

The IE copyright statement itself does not have this line, and notepad's dialog does not, although it links to a EULA which has:
    * Reservation of Rights. Microsoft reserves all rights not
      expressly granted to you in this EULA.

The Nokia PC Suite 6.82.22.0 software I have says:
Copyright (c) 1997-2006 Nokia. All Rights Reserved.

Acrobat Reader 7.0 (7.0.3) says:

Copyright 1984-2004 Adobe Systems Incorporated and its licensors. All rights reserved.

Symantec AntiVirus (10.1.4.4010) says:
Copyright 2006 Symantec Corporation. All rights reserved.

Visual C++ 2005 Express Edition says:
Microsoft Visual Studio 2005
Version 8.0.50727.42 (RTM.050727-4200)
(c) 2005 Microsoft Corporation.
All rights reserved.

Microsoft .NET Framework
Version 2.0.50727
(c) 2005 Microsoft Corporation.
All rights reserved.

For real fun reading, I'd suggest snv/SUNWspro's /opt/SUNWspro/prod/lib/locale/C/html/manuals/shared/copyright.html

snv 53 contains: /etc/umountall:# Copyright 2006 Sun Microsystems, Inc.  All rights reserved.

http://src.opensolaris.org/source/xref/onnv/onnv-gate/usr/src/cmd/initpkg/umountall.sh

Note that snv is based on OpenSolaris, and the file I'm referencing is under CDDL.

http://www.sun.com/cddl/CDDL_why_summary.html notes that CDDL is an MPL derivative of sorts.

I think for the time being we should assume that Sun's lawyers have done their homework.

In case people are curious, it seems that standard practice (at least from my readings of the Open Solaris lists) is to only retain the most recent year instead of all years in the copyright notice.

That said; I am not a lawyer, I am at best an aggregator, at worse a typoist with bad memory (hopefully not given that the readings are from yesterday, but...).

Oh, did I mention that gnome-about on snv 53 says:
Copyright 2006 Sun Microsystems, Inc. All rights reserved.

Note that snv 53 is from 2006. Build Date: 11/13/06. Just in case you were wondering why it didn't say 2007. There's an snv 54, but I didn't really feel like installing it yesterday.
The about text that I see mentions the copyrights, but has no mention of 
the MPL at all.  I think most folks who are alarmed by these copyright 
notices would be assuaged by text pointing out that the product may be 
used under the terms of the MPL (etc.)
(Reporter)

Comment 5

12 years ago
(In reply to comment #1)
> I think it makes reasonable sense. You start by reserving all rights, and then
> you grant some under whichever licence you are using. 

Why wouldn't you just directly specify what rights are rather than taking a needlessly circuitous route? In any case, even if you want to keep the "All Rights Reserved" language, it should probably mention the rights that are granted, like the about: page does.

> Presumably, if you are looking at any document or software you did not write
> which says "all rights reserved", then not _all_ the rights have been reserved,
> because you had the right to make the copy you have :-)

Well lots of people copy software illegally, or don't even realize that copying software could be illegal. So I don't know if you can assume that much even.

> Having said that, it's quite possible that, as the Wikipedia article claims,
> it's unnecessary. But, just as I don't go to Slashdot for legal advice, I don't
> go to Wikipedia either. To remove it, we'd need to check with a lawyer.

This is why I pointed to that other link, and a quick Googling will reveal lots of sources that say this is case (like the Library of Congress: http://loc.gov./nls/reference/factsheets/copyright.html, about 2/3 down the page). And I certainly didn't imply you shouldn't seek your own counsel. 
(Reporter)

Comment 6

12 years ago
(In reply to comment #2)
> I'll echo Gerv's comments: As far as I'm aware the practice of using "All
> rights reserved" on copyright notices is a traditional practice that once had a
> solid legal justification, but that at present is not (or at least may not be)
> necessary. However at the same time I know of no reason why this language in
> the notice would affect the rights of licensees of Mozilla code as granted by
> the MPL and other licenses. As Gerv notes, the copyright notice is a statement
> of ownership, i.e., who owns what; the notice is basically saying that the
> identified entity or entities (Initial Developer plus any Contributors) is
> entitled to all rights granted by government(s) under the applicable copyright
> law(s) (e.g., to make copies, create derivative works, etc.). Having thus
> established that they have such rights (as a necessary prelude), the entities
> in question can then proceed to grant certain of those rights to others per the
> MPL and/or other free software licenses. In this sense the licenses override or
> modify the perceived implications of the copyright notices.

I suppose to draw a software engineering parallel, if you refactor a piece of code so that now no one calls function foo() anymore, do you leave that function in the codebase or do you remove it? In theory leaving it there does no real harm, but really it creates confusion and bloat. 

> In this case the "All rights reserved" language is not only in the About box,
> it's in the license boilerplate for every Mozilla source file; thus "fixing"
> this in the manner suggested (i.e., modifying the copyright notices) would be a
> major undertaking. Unless someone can provide a compelling argument that the
> "All rights reserved" language adversely affects the rights of Mozilla
> licensees, then I propose to leave the notices as is and resolve this bug as
> WONTFIX.

I'm personally more interested in the about box because it is more user facing. No one says you have to remove it from both places or leave it in both (well maybe a lawyer would, but you would have to ask them). But even if it really has no legal meaning anymore, removing it from the boiler plate doesn't change the meaning of the boiler plate one bit.

In any case, as I've said before, even if you decide to retain the sentence, you should probably add another one pointing to the license. 
(In reply to comment #6)
> (In reply to comment #2)
> > I'll echo Gerv's comments: As far as I'm aware the practice of using "All
> > rights reserved" on copyright notices is a traditional practice that once had a
> > solid legal justification, but that at present is not (or at least may not be)
> > necessary. However at the same time I know of no reason why this language in
> > the notice would affect the rights of licensees of Mozilla code as granted by
> > the MPL and other licenses. As Gerv notes, the copyright notice is a statement
> > of ownership, i.e., who owns what; the notice is basically saying that the
> > identified entity or entities (Initial Developer plus any Contributors) is
> > entitled to all rights granted by government(s) under the applicable copyright
> > law(s) (e.g., to make copies, create derivative works, etc.). Having thus
> > established that they have such rights (as a necessary prelude), the entities
> > in question can then proceed to grant certain of those rights to others per the
> > MPL and/or other free software licenses. In this sense the licenses override or
> > modify the perceived implications of the copyright notices.
> 
> I suppose to draw a software engineering parallel, if you refactor a piece of
> code so that now no one calls function foo() anymore, do you leave that
> function in the codebase or do you remove it? In theory leaving it there does
> no real harm, but really it creates confusion and bloat. 

Well, if you are sure no one calls foo(), that's fine, but at least in the Firefox world, if we don't understand what extensions might rely on foo() and thus don't know the consequences of removing foo(), we tend to just leave it until we're sure we're not breaking anyone, or there's enough time to catch the bustage before it creates significant harm.
(Reporter)

Comment 8

12 years ago
(In reply to comment #7)
> Well, if you are sure no one calls foo(), that's fine, but at least in the
> Firefox world, if we don't understand what extensions might rely on foo() and
> thus don't know the consequences of removing foo(), we tend to just leave it
> until we're sure we're not breaking anyone, or there's enough time to catch the
> bustage before it creates significant harm.

You've rather stretched my analogy much further than I think it will bear :) I'm not exactly seeing how it relates to issue. 
Basically, unless there is a clear reason why it is harmful, and the possibility exists that removing it may be harmful, its better to leave the cruft in...

Comment 10

11 years ago
Might I suggest consulting A Lawyer(tm) on this issue?

Comment 11

10 years ago
Related: bug 415128

Comment 12

10 years ago
Leave the cruft in for now. It's not harmful, and may even be helpful, to the extent it tells users the code is protected by copyright and it is not share-ware put into the public domain. Even though the software is free, we still maintain copyright protection, we just happen to license it for "free" under the tri-license a specific enumeration of rights under both patent and copyright law.
WONTFIX, as per comment 12.

Gerv
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 14

10 years ago
(In reply to comment #12)
> Leave the cruft in for now. It's not harmful, and may even be helpful, to the
> extent it tells users the code is protected by copyright and it is not
> share-ware put into the public domain. Even though the software is free, we
> still maintain copyright protection, we just happen to license it for "free"
> under the tri-license a specific enumeration of rights under both patent and
> copyright law.

I have to say I think that's a pretty poor argument. The Copyright 1998-2008 is more than enough to indicate that Firefox is under copyright.

Fixed in bug 536336
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 536336
You need to log in before you can comment on or make changes to this bug.