Last Comment Bug 367341 - l10n CVS/Hg account for Yannig Marchegay, Occitan (oc)
: l10n CVS/Hg account for Yannig Marchegay, Occitan (oc)
Status: RESOLVED FIXED
voucher,ssh-key,form
:
Product: mozilla.org
Classification: Other
Component: Repository Account Requests (show other bugs)
: other
: All All
: -- normal (vote)
: ---
Assigned To: Aravind Gottipati [:aravind]
:
Mentors:
Depends on: 369830
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-18 02:18 PST by Yannig MARCHEGAY
Modified: 2008-10-04 03:13 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
SSH key for Occitan CVS account (403 bytes, text/plain)
2007-01-18 02:19 PST, Yannig MARCHEGAY
no flags Details
CVS access for Occitan (Yannig Marchegay) (92.86 KB, application/pdf)
2008-09-11 14:00 PDT, Yannig MARCHEGAY
no flags Details

Description Yannig MARCHEGAY 2007-01-18 02:18:27 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.1) Gecko/20060601 Firefox/2.0.0.1 (Ubuntu-edgy)
Build Identifier: CVS access for Occitan translations

I'm responsible of Occitan translations for GNOME and I'd also like to translate (or make translate) Mozilla Firefox and Thunderbird.
I'm trying to understand how to do this. Meanwhile, could I have a CVS account?

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Comment 1 Yannig MARCHEGAY 2007-01-18 02:19:30 PST
Created attachment 251895 [details]
SSH key for Occitan CVS account
Comment 2 Marcia Knous [:marcia - use ni] 2007-01-19 16:07:58 PST
Need a voucher as well as the hacking form filled out and returned (www.mozilla.org/hacking/form.html).
Comment 3 Yannig MARCHEGAY 2007-01-20 05:53:00 PST
If I understand well, I have to mail the filled form, just for a translation CVS access :o(
Sorry to seem so dumb but I cannot find a single page with all the information for localizing Mozilla Firefox and Thunderbird :o(
Comment 4 Marcia Knous [:marcia - use ni] 2007-03-16 17:49:15 PDT
Yannig: I need an existing CVS user to vouch for you. Axel will also have to review this request before I can create your CVS account. Have you sent the CVS form my way? You can send it via email instead of faxing if that is more convenient.
Comment 5 Axel Hecht [pto-Aug-30][:Pike] 2007-03-19 02:13:16 PDT
This needs to go through registration yet, and there are a few odd ends as to what "Occitan" really means, as it's a language group rather than a particular language.
Comment 6 Yannig MARCHEGAY 2007-03-19 03:07:19 PDT
It's sure there are several variants for Occitan, so you can call my language Lengadocian, it would be more precise.
Comment 7 Toni Hermoso Pulido 2007-03-19 07:58:19 PDT
Just as a suggestion, you might also try "Occitan Lengadocian" o "Occitan (Lengadocian)". Other variants might be called accordingly.
Just as a curiosity, how do native speakers in Lengadoc normally call their language, Lengadocian or Occitan (not in English, I mean)? 
Comment 8 Yannig MARCHEGAY 2007-07-04 13:20:20 PDT
That's it, the CVS contributor form has just been e-mailed to marcia@mozilla.org :-)
Comment 9 Marcia Knous [:marcia - use ni] 2007-07-05 15:33:21 PDT
Form received via email. Awaiting Axel's go ahead to create.
Comment 10 Yannig MARCHEGAY 2007-07-06 08:36:40 PDT
Great :o)
Comment 11 Yannig MARCHEGAY 2007-08-22 03:36:59 PDT
What's up? :-)
Comment 12 Yannig MARCHEGAY 2007-09-12 07:55:23 PDT
Sorry to try and "up" again but if we wait several months to have a CVS, the motivated persons won't be motivated anymore :-(
Would it be possible to have some news please?
Comment 13 Yannig MARCHEGAY 2008-02-06 02:49:33 PST
Any news?
Comment 14 Cédric Corazza 2008-02-08 11:48:26 PST
Yannig,
My guess is that you have to provide the tarball of your translation attached in a bug before accessing CVS. That sounds fair, according to me.

Axel?
Comment 15 Reed Loden [:reed] (use needinfo?) 2008-06-15 23:06:52 PDT
Due to a recent overhaul of the committer's agreement, we are requiring new forms be sent for accounts that have yet to be created, even if you have already filled out and submitted the old CVS Contributor Form. Please download the form at http://www.mozilla.org/hacking/committer/committers-agreement.pdf and submit it according to the directions specified at http://www.mozilla.org/hacking/notification/. We apologize for this necessary inconvenience. If you have any questions, feel free to ask. Thanks!
Comment 16 Yannig MARCHEGAY 2008-06-16 07:57:12 PDT
I'll do it...
More than 1/3 is now translated (and it works on my computer). Which percentage should I reach to show you my job?
Comment 17 Yannig MARCHEGAY 2008-07-26 02:49:14 PDT
100% done. Just have to send the new form (and I hope there won't be another one meanwhile).
Comment 18 Yannig MARCHEGAY 2008-07-27 07:04:57 PDT
The addon proving the translation is 100% is now available at https://addons.mozilla.org/fr/firefox/addon/7854
The new committer's agreement was sent to Marcia a few minutes ago.
Comment 19 Axel Hecht [pto-Aug-30][:Pike] 2008-09-10 14:27:53 PDT
Vouching based on my review in the registration bug, ssh key is in, too. Marcia, did you get the form?

Note, this is for hg, too.
Comment 20 Marcia Knous [:marcia - use ni] 2008-09-10 14:37:34 PDT
adding erica to comment re: receiving the form. Going forward she is the point person for all the forms related to account requests.
Comment 21 Erica McClure 2008-09-10 14:53:52 PDT
I have not received a Committer's Agreement from Yannig.
Comment 22 Yannig MARCHEGAY 2008-09-10 21:53:46 PDT
I sent it by e-mail to Marcia more than two months ago and I have no copy. I'll have to do it again (I hope I'll have time to do it for the third time before the week-end).
Comment 23 Yannig MARCHEGAY 2008-09-11 14:00:55 PDT
Created attachment 338181 [details]
CVS access for Occitan (Yannig Marchegay)

I've just sent you the file. In case, I attach it too here.
Thanks
Comment 24 Erica McClure 2008-09-11 14:13:29 PDT
I have received Yannig's Committer's Agreement.
Comment 25 Axel Hecht [pto-Aug-30][:Pike] 2008-09-11 14:27:14 PDT
Marcia, are you going to continue to push the bugs over to IT? This one should be ready.
Comment 26 Marcia Knous [:marcia - use ni] 2008-09-11 14:39:50 PDT
Yes, moving this one over now. Over to server-ops...
Comment 27 Aravind Gottipati [:aravind] 2008-09-15 21:29:18 PDT
Your CVS account has been created.  Your CVSROOT should be:
   yannig%marchegay.org@cvs.mozilla.org:/l10n
Don't forget to set your CVS_RSH environment variable to 'ssh'.

Your mercurial account is ready as well.  The user name is 'yannig@marchegay.org'.  The repositories are at svn+ssh://hg.mozilla.org/l10n-central.

If you have any problems connecting, let me know.
Comment 28 Yannig MARCHEGAY 2008-10-04 00:55:48 PDT
Thanks a lot.
I thought it was 100% translated, why isn't on http://www.mozilla.com/en-US/firefox/all.html#languages then?
Comment 29 Axel Hecht [pto-Aug-30][:Pike] 2008-10-04 03:01:02 PDT
Yannig, there is bug 454159 about shipping firefox. Which is blocked by a few other bugs. Please follow up in those bugs to drive them to resolution.

This bug is about getting you write access to our repos, nothing else. Please keep your comments on topic, we file different bugs for different issues exactly for that.

About this bug, have you tested your accounts yet? I see no commit on either cvs or hg for Occitan other than my own ones yet. Cedric might be able to talk you through the steps.
Comment 30 Yannig MARCHEGAY 2008-10-04 03:13:17 PDT
Sorry about that, I'll try and solve the bugs still open.
The account works (I've just make a commit).

Note You need to log in before you can comment on or make changes to this bug.