Closed Bug 368029 Opened 14 years ago Closed 13 years ago

Strange traces appear on most pages(but not all) when using auto scrolling in firefox.

Categories

(Firefox :: Shell Integration, defect)

x86
Linux
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 282109

People

(Reporter: jayerza, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.8.1.1) Gecko/20070107 BonEcho/2.0.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.8.1.1) Gecko/20070107 BonEcho/2.0.0.1

four users reported this bug. Duplicating it here as it does not happens with other browsers in Linux, using the Xorg server with AIGLX enabled.

1st user: I'm using the Beryl SVN on Ubuntu Edgy, with the 'ati' driver & AIGLX. It is remnants of the autoscroll icon itself. It appears to smear down the page. scrolling regularly until they're off the page makes them go away.
2nd user: I get the same here... Nvidia Drivers 96.31, Gentoo.

the redraw bug when scrolling goes away, when swichting to metacity

I am using a IMPS/2 mouse (genius netscroll), when the midlle button is clicked the autoscroll icons copies itself to the bottom or top
3rd user: I have a problem similar to this.

Going to sites with menus that are stationary. e.g. http://cairographics.org/samples/libsvg.html Then scrolling makes the stationary items get drawn onto the non-stationary parts of the page.


please Check this video for details 
*Attach: (media-video) @ video.google 
http://video.google.es/videoplay?docid=1321933765673255061

Reproducible: Always

Steps to Reproduce:
You must have the xorg-server with the aiglx flag enabled.

1.Open firefox.
2.Click the autoscroll middle button
3.Scroll the URL given before.
Actual Results:  
redraws of the autoscrolling icon, depending where you autoscroll, below our above.

Expected Results:  
no redraws of the autoscrolling icon.

Since Ubuntu in it's new release is shipping by default with aiglx rendering enabled, I'll set the severity to Major. Because it really gives the user a very poor usability (or none), adding that the average user won't understand if this is a bug or a enhancement...
Please notice that this does not happen in other browsers in Linux (Epiphany, Konqueror, etc)
related bug tickets 

https://bugzilla.mozilla.org/show_bug.cgi?id=215762

"possible problem": the autoscroll image.
yes, it is the problem i think
Becose there is no problem in Seamonkey, becouse scrolling image have no transparency there
Keywords: uiwanted
Keywords: uiwanted
The problem will not be only auto-scrolling. Look at this page for example:

test: http://www.smoula.net/nexus/fixed-bug.html

when I use autoscrolling, everything works fine. But when scrolling is done via scrollbar, mouse wheel or pgUp/Down keys - the fixed div in a right corner leaves ugly traces :(

screenshot: http://www.smoula.net/nexus/2007-02-13-104554_2560x1024_scrot.png

Using: beryl svn version, Firefox 2.0.0.1, Gentoo Linux.
When beryl is replaced with other WM (ie. metacity), it works ok.
Another example is the GMail indicator for conversation replies below the fold. It stays stationary at the bottom right hand side, but in Minefield, it flickers brutally (although overall the scrolling is much faster than it was in F2)
Hi, good to know that is_only_related/w close source drivers.
I am testing Grand Paraiso (which should become FF 3). The bug is still there,  since this  promoted as the FF "eye candy release", it would be indeed usefull if some developer could explain the differents behaviours among FF 2.0 and 3.0alpha.
I have noticed, tracking and searching over here, some sort of similar bug on windows NT 4.x w/autoscrolling "odd-strange colours when autoscrolling" at Firebird.
the bug in 3.0 alpha doesn´t redraw the autoscroll-image the same times/speed, I don´t know how to explain, ¿could it be related with the cairo engine support on FF? 
I think this has been fixed as the autoscroll icon has been moved out of the DOM:
https://bugzilla.mozilla.org/show_bug.cgi?id=242621
Ye, it fixed in 3.0
But some elements now look ugly when scrolling pages with beryl ON, like 'static' backgrounds
Example: http://community.livejournal.com/ru_swine/
I don't know how this big is being handled right now, but I figured since I have the problem I would give my info. I've seen this with Gentoo Linux and Firefox versions dating back to 1.5.x.x. It seems like I was always either using KDE 3.5.X or XFCE < 4.4. cairo versions are unknown. Currently I use Compiz-Fusion (WITHOUT AIGLX), but the problem existed before I used it. It seems to me that on this installation I noticed it starting immediately after i used xmodmap to map my mouse buttons.
I can confirm that this bug is now fixed. Can someone mark it as such?
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 282109
Depends on: 242621
You need to log in before you can comment on or make changes to this bug.