Various components missing from win32 installer builds (chardet.dll, universalchardet.dll) -- no auto-detect character encoding

RESOLVED FIXED

Status

SeaMonkey
Installer
--
critical
RESOLVED FIXED
11 years ago
9 years ago

People

(Reporter: Andrew Schultz, Assigned: neil@parkwaycc.co.uk)

Tracking

({fixed-seamonkey1.1.1, regression})

Trunk
x86
Windows XP
fixed-seamonkey1.1.1, regression
Dependency tree / graph
Bug Flags:
blocking-seamonkey1.1.1 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
Bug 361437 switched the installer to use local GRE by default.  With local GRE, various things are missing after installation.  Specifically, chardet.dll and unversalchardet.dll, probably others.  The symptom people seem to notice is that the "auto-detect" character encoding menu item is missing.

The reason for the bustage is that browser.jst deletes the files after they get installed.  The upgradeCleanup first deletes files it thinks are not part of the GRE and then files that are part of the GRE /if/ the GRE was not installed locally.  Unforunately, the lists are wrong.  chardet.dll and universalchardet.dll (among others) are both in the non-GRE list.

To fix this, either
1. Identify all files that are part of the GRE (see mozilla/embedding/config/)
2. Move those files from the non-GRE list to the GRE list.
or
Switch back to non-local GRE.
Flags: blocking-seamonkey1.1.1?
Neil, can I have your r and sr to back out BenoitRen's patch?  And KaiRo's approval?  Non-local GRE got much more testing than local.
Flags: blocking-seamonkey1.1.1? → blocking-seamonkey1.1.1+
(Assignee)

Comment 2

11 years ago
Created attachment 252897 [details] [diff] [review]
Proposed patch

By saving the installer files locally and removing the call to upgradeCleanup I was able to verify that only these two files are affected.
Assignee: benoit → neil
Status: NEW → ASSIGNED
Attachment #252897 - Flags: review?(ajschult)

Comment 3

11 years ago
Nice. I'd much more prefer if we are able to solve this with keeping locale GRE in place.
(Reporter)

Comment 4

11 years ago
Comment on attachment 252897 [details] [diff] [review]
Proposed patch

right.  I just verified that all the other files from gre.xpi were not deleted.
Attachment #252897 - Flags: review?(ajschult) → review+
(Assignee)

Comment 5

11 years ago
Fix checked in to the trunk, but leaving on the radar for the branch.
(Assignee)

Comment 6

11 years ago
Created attachment 253032 [details] [diff] [review]
Branch patch

Branch really doesn't want chardet.dll but it wants universalchardet.dll (View/Character Coding/Auto-Detect/Universal).
Attachment #253032 - Flags: review?(ajschult)
Attachment #253032 - Flags: approval-seamonkey1.1.1?

Comment 7

11 years ago
Comment on attachment 253032 [details] [diff] [review]
Branch patch

a=me for 1.1.1 (given it gets r+)
Attachment #253032 - Flags: approval-seamonkey1.1.1? → approval-seamonkey1.1.1+
(Reporter)

Comment 8

11 years ago
Comment on attachment 253032 [details] [diff] [review]
Branch patch

r=me
(note that packager/build/ is super-obsolete)
Attachment #253032 - Flags: review?(ajschult) → review+
(Assignee)

Comment 9

11 years ago
Fixed on the branch too.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Keywords: fixed-seamonkey1.1.1
Resolution: --- → FIXED

Updated

11 years ago
Duplicate of this bug: 370040

Updated

11 years ago
Blocks: 368823

Updated

9 years ago
Component: Installer: XPI Packages → Installer
QA Contact: xpi-packages → general
You need to log in before you can comment on or make changes to this bug.