Trunk install takes over as default browser from a release build

RESOLVED FIXED in Firefox 3 beta1

Status

()

defect
--
blocker
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: wgianopoulos, Assigned: rstrong)

Tracking

({regression, verified1.8.1.2})

Trunk
Firefox 3 beta1
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: See comment #21 and bug 353814 for info)

Attachments

(1 attachment)

Reporter

Description

13 years ago
If you have the latest Firefox release build set as your default browser and install the latest trunk nightly it takes over as the default browser.  This interferes with the ability to test trunk nightlies without impact to your normal browser usage.

Whatever it is the code in this checkin is trying to fix, it should only be doing it if the new version is being installed in the same folder as the previous default browser.
Reporter

Updated

13 years ago
Flags: blocking-firefox3?
Reporter

Comment 1

13 years ago
Sorry, should have made it clear that the code I was referring to was that checked in for bug 369048.
Reporter

Comment 2

13 years ago
(In reply to comment #0)

> Whatever it is the code in this checkin is trying to fix, it should only be
> doing it if the new version is being installed in the same folder as the
> previous default browser.
> 
Or perhaps only if the previous default browser was named firefox.exe and the executable in no longer present?

Comment 3

13 years ago
dup of bug 353814?



Reporter

Comment 4

13 years ago
I don;t think so.  That bug was filed way before this started happening.
For all practical purposes this is a dupe of bug 353814 - it was filed in anticipation of side by side installs breaking. What happened with Vista coming out is MS recommended that an app take over all system wide defaults on install. I've talked with a couple of people at MS and Mozilla about this and we decided it would be a better user experience to only take over when an instance of Firefox is default.

Windows has been moving more and more towards only supporting a single install of an app (e.g. StartMenuInternet under XP and now the Vista API's for handling default app) and with UAC in Vista we need to elevate to set the required reg keys. This makes things very difficult for us to support side by side installs though we are looking at ways to improve this on trunk but not for 2.0.0.x.

For a workaround after 2.0.0.2 comes out you can run <install dir>\uninstall\helper.exe /SetAsDefaultAppGlobal to set that install as the default.
Reporter

Comment 6

13 years ago
Well, if that is the case, why does this need to be done if the OS is not Vista?

Also, I guess if that is the way Microsoft ways it should work, could we make this an install option normally set and only changeable on custom install?  So there is a checkbox in the install somewhere saying "Make Firefox my default browser" that is normally checked?

My personal opinion in all of this is the Microsoft is trying to set the Application vendors up.  It is good we are only doing this if the old default was a different version on Firefox.  There is nothing that alienates users more than finding that when they install an application to test it, it takes over as the default.  Many people use this as a reason to NEVER run that application again and tell all of their friends not to either.

This is a particular issue if you have further customized file associations so that some file types normally associated with the Internet browser are associated with a non-browser application.

If the pan is to release Firefox 2.0.0.2 with this behavior, I think that is a huge mistake.

I can see the Blog headlines now.

"I installed Firefox and it took over my browser settings - avoid this malware!"
Reporter

Comment 7

13 years ago
Thinking on this more, I should prefer this show up even in a non-custom install.  I think this needs to be a checkbox on the last installer screen, right above the Launch Firefox now checkbox.  The box should be checked by default, and if the OS is Vista and the install is not a custom install the choice should be omitted form the screen.

This should prevent normal users from doing the wrong thing without confusing Windows XP users with this new behavior.

If you think I am kidding about bad user reaction to the browser taking over file associations, just think how many people you know who refuse to install Real Player over this exact same issue.
(In reply to comment #6)
> Well, if that is the case, why does this need to be done if the OS is not
> Vista?
To support the upgrade case.

>...
> "I installed Firefox and it took over my browser settings - avoid this
> malware!"
We are only doing it to existing installs of Firefox and not other apps and we have to because of shared reg keys between multiple installs of Firefox. Also, the average use case is only one install of Firefox so this most definitely should not be the case.
btw: the upgrade case mentioned in comment #8 is in regards to an OS upgrade.

(In reply to comment #7)
> Thinking on this more, I should prefer this show up even in a non-custom
> install.  I think this needs to be a checkbox on the last installer screen,
> right above the Launch Firefox now checkbox.  The box should be checked by
> default, and if the OS is Vista and the install is not a custom install the
> choice should be omitted form the screen.
String changes are not an option for 2.0.0.2

> If you think I am kidding about bad user reaction to the browser taking over
> file associations, just think how many people you know who refuse to install
> Real Player over this exact same issue.
As mentioned in comment #8 we are only doing this to existing installs of Firefox and not to other apps which was the issue with Real Player.
Reporter

Comment 10

13 years ago
(In reply to comment #8)
> (In reply to comment #6)
> > Well, if that is the case, why does this need to be done if the OS is not
> > Vista?
> To support the upgrade case.
Why would the OS upgrade possibly care if my default browser is the most recently installed version of Firefox or the one I installed a month previously as long as they are both present????
Reporter

Comment 11

13 years ago
(In reply to comment #9)
> As mentioned in comment #8 we are only doing this to existing installs of
> Firefox and not to other apps which was the issue with Real Player.
> 
Not true, you are taking over as the protocol handler for FTP which the user could have assigned to a real ftp application, you know one that actually supports 2-way file transfers!

(In reply to comment #10)
> (In reply to comment #8)
> > (In reply to comment #6)
> > > Well, if that is the case, why does this need to be done if the OS is not
> > > Vista?
> > To support the upgrade case.
> Why would the OS upgrade possibly care if my default browser is the most
> recently installed version of Firefox or the one I installed a month previously
> as long as they are both present????
There are one set of registry keys used to configure the default. If the keys aren't set during install then it is not possible to set that install as default when running on Vista. If they aren't set prior to upgrade then it is not possible to set that install as default after upgrading to Vista.

(In reply to comment #11)
> (In reply to comment #9)
> > As mentioned in comment #8 we are only doing this to existing installs of
> > Firefox and not to other apps which was the issue with Real Player.
> > 
> Not true, you are taking over as the protocol handler for FTP which the user
> could have assigned to a real ftp application, you know one that actually
> supports 2-way file transfers!
I'll change that to check each key and if it has firefox.exe in the open command then it will take over that specific key to avoid this.
Reporter

Comment 13

13 years ago
OK.  Sounds like you were already aware of most of these issues and this was the best you could come up with then.  It seems like Vista gives users less flexibility in deciding how they want their computer to operate.  I wonder shat the EU is going to have to say about this.
For the side by side use case it is worse but for the single install average use case the OS provides simplified UI for setting individual protocol handlers on a per app basis.
Reporter

Comment 15

13 years ago
So is the way Vista does the default browser more like the way previous versions of windows did e-mail clients?  For e-mail when you install a new client you are supposed to register it as a mail client and register what all the commands are for handling mailto: links and stuff like that which you should also set, none of whch alters at all what mail client is the default one.  Then when you go into IE and tell it you want to change the default mail client, and select say "Thunderbird" from the dropdown list, it just takes all the registry settings for Thunderbird defaults and copies them to the system defaults.  If Vista does the same fro browsers, then that is a step in the right direction.

If they did something different then they are not very bright because they had a model they were using for other applications that worked.  All they needed to do was expand it to browsers as well (and of course remove the application setting UI from IE and put it in the OS where it always belonged).

But it does leave you with the upgrade issue because there is only one set of browser defaults in the Windows/XP registry.

I take that without doing this for Windows/XP then after an upgrade from Windows/XP to Vista you might have to reinstall Firefox in order to get it to be settable as the default browser?
(In reply to comment #15)
> So is the way Vista does the default browser more like the way previous
> versions of windows did e-mail clients? ...
It uses Set Defaults now and is similar in some ways though the underlying methods used are significantly different... there are also new api's for checking / setting default apps.

> ...
> I take that without doing this for Windows/XP then after an upgrade from
> Windows/XP to Vista you might have to reinstall Firefox in order to get it to
> be settable as the default browser?
Correct

Comment 17

13 years ago
I notice this behaviour also on MacOS X 10.4 (Tiger). Since several days, I have installed Safari, Safari Nightly, Firefox Release 2.0.0.1, Firefox Nightly (Minefield). Since I have installed Firefox Nightly (Minefield), I cannot convince the system (via preferences menu of Safari) to use Firefox (stable release) as the default browser. The system insists to link to Firefox Nightly, even if I explicit advice it to use the normal Firefox release. No problem, to advice the system to use Safari as default browser, but this is not that what I want -- I want back Firefox stable as my default browser, not Firefox Nightly. Very annoying. 
(In reply to comment #17)
The changes this bug is discussing have absolutely nothing to do with Mac OS X so you would be experiencing something totally unrelated to this bug

Assignee: nobody → robert.bugzilla
Status: NEW → ASSIGNED
Attachment #254118 - Flags: review?(sspitzer)
Comment on attachment 254118 [details] [diff] [review]
patch per comment #12

r=sspitzer
Attachment #254118 - Flags: review?(sspitzer) → review+
attachment #254118 [details] [diff] [review] checked in to trunk. We'll try to improve the side by side experience in bug 353814
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
fixed on the branch.
Keywords: fixed1.8.1.2
Target Milestone: --- → Firefox 2
i can verify that:

-> a side by side installation works fine here with 1.8.1.2 and trunk
-> i can verify comment #8 - when different apps have are also default programs ..like IE for ftp and 1.8.1.2 for http/https the settings for other default programs (in this case IE) will be not changed during a side by side installation

are there other steps to verify fix this bug report ?
(In reply to comment #23)
> i can verify that:
> 
> -> a side by side installation works fine here with 1.8.1.2 and trunk
> -> i can verify comment #8 - when different apps have are also default programs
> ..like IE for ftp and 1.8.1.2 for http/https the settings for other default
> programs (in this case IE) will be not changed during a side by side
> installation
> 
> are there other steps to verify fix this bug report ?
That's all there is to this and thanks for the work you have been doing verifying all of these bugs.
 

hi robert, thanks for the quick reply

verify fixed for 1.8.1.2 using Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.2pre) Gecko/2007020804 BonEcho/2.0.0.2pre - see comment#23 for the testing steps if done

Updated

12 years ago
Flags: blocking-firefox3?

Comment 26

12 years ago
FWIW-Windows 2000 is also affected by this bug like Windows XP. During today's update of Minefield, the update process changed my default browser from Firefox 2.0.0.4 to Minefield.

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a7pre) Gecko/2007071205 Minefield/3.0a7pre ID:2007071205

Comment 27

12 years ago
Minefield still sets as default browser when there is already installed firefox. This happens on installation or update everytime.
See comment #21 and bug 353814
Whiteboard: See comment #21 and bug 353814 for info
Depends on: 370571
Target Milestone: Firefox 2 → Firefox 3 M9
This will improve quite a lot with the patch in bug 370571
You need to log in before you can comment on or make changes to this bug.