Database version warning doesn't refer to Lightning/Calendar

VERIFIED FIXED in Lightning 0.5

Status

Calendar
Provider: Local Storage
VERIFIED FIXED
12 years ago
10 years ago

People

(Reporter: Jay Rossiter, Assigned: Matthew (lilmatt) Willis)

Tracking

Lightning 0.3.1
Lightning 0.5

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla-1.8 0.3.1pre 2007012705

Starting from build 2007012705 Thunderbird issues a warning on startup saying:

"The data in your profile was updated by a newer version of Thunderbird, and continuing will probably cause the information to be lost or corrupted. Thunderbird will now quit."

The dialog can be bypassed by pressing escape.

This isn't a Thunderbird issue, as reverting to the previous day's version of Lightning resolves the issue.  The issue continues through at least today's build (2007020803).

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

12 years ago
Created attachment 254501 [details]
Screenshot of error dialog
(Assignee)

Comment 2

12 years ago
Ya, we need to make it say "Your calendar data was..." so it's more clear.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-calendar0.5+
OS: Windows XP → All
Hardware: PC → All
Target Milestone: --- → Lightning 0.5
Version: unspecified → Lightning 0.3.1
(Reporter)

Comment 3

12 years ago
I'm confused.  Does this mean that the -latest nightlies have regressed from 0.4a1 to 0.3.1pre?  If so, what does that mean, and where did the 0.4 builds go?
(Assignee)

Comment 4

12 years ago
Yes. We have a limited set of tinderboxes to build _and_ release from, so in order to get the 0.3.1 maintenance release complete _before_ the US Daylight Savings Time changes come into effect, we had to switch the Lightning branch tinderbox to build 0.3.1.

As soon as we ship 0.3.1, we'll return the tinderbox to building 0.4a1/0.5pre
(In reply to comment #2)
> Ya, we need to make it say "Your calendar data was..." so it's more clear.

That's exactly what I meant in Bug 357458 Comment #17.
Updating summary and severity since the message is shown on purpose but misleading.
Severity: critical → normal
Component: General → Provider: Local Storage
QA Contact: general → storage-provider
Summary: Thunderbird data integrity warning starting from build 2007012705 → Database version warning doesn't refer to Lightning/Calendar
Duplicate of this bug: 371106
(Assignee)

Comment 8

12 years ago
Created attachment 256863 [details] [diff] [review]
Adds "calendar" to the text.  Changed the entity name to force l10n updates.
Assignee: nobody → lilmatt
Status: NEW → ASSIGNED
Attachment #256863 - Flags: ui-review?(mvl)
Attachment #256863 - Flags: second-review?(mvl)
Attachment #256863 - Flags: first-review?(ctalbert.moz)
(Assignee)

Updated

12 years ago
Whiteboard: [patch in hand][review needed ctalbert mvl][ui-review needed mvl]
Comment on attachment 256863 [details] [diff] [review]
Adds "calendar" to the text.  Changed the entity name to force l10n updates.

>-tooNewSchemaErrorText=The data in your profile was updated by a newer version of %1$S, and continuing will probably cause the information to be lost or corrupted. %1$S will now quit.
>+tooNewSchemaErrorBody=The calendar data in your profile was updated by a newer version of %1$S, and continuing will probably cause the information to be lost or corrupted. %1$S will now quit.

While this is indeed an improvement, it's not technically correct. If you only downgrade lghtning, but keep on using the same thunderbird, the message would blame thunderbird for changing the data. Which is wrong.
Would it be hard to really fix this, by saying what really changed the calendar data?

Comment 10

12 years ago
Comment on attachment 256863 [details] [diff] [review]
Adds "calendar" to the text.  Changed the entity name to force l10n updates.

r=clint
Attachment #256863 - Flags: first-review?(ctalbert.moz) → first-review+

Comment 11

12 years ago
Surely it's also wrong for Lightning to force Thunderbird to quit...
In the case of the standalone calendar application it may make sense. In the case of an extension to a mail application, it feels unfair - all that other data in my profile being denied to me...
Is it not possible to cause this to disable the extension until its cleared up rather than quitting the application? If it did that, then you could remove the calendars and re-add them from within Thunderbird...
(Assignee)

Comment 12

12 years ago
Created attachment 257359 [details] [diff] [review]
Addresses mvl's comments

This uses the app name to be more descriptive.  Screenshot forthcoming.
Attachment #256863 - Attachment is obsolete: true
Attachment #257359 - Flags: second-review?(mvl)
Attachment #257359 - Flags: first-review?(ctalbert.moz)
Attachment #256863 - Flags: ui-review?(mvl)
Attachment #256863 - Flags: second-review?(mvl)
(Assignee)

Comment 13

12 years ago
Created attachment 257360 [details]
Screenshot of above
Attachment #257360 - Flags: ui-review?(mvl)
Comment on attachment 257360 [details]
Screenshot of above

ui-review=mvl
Attachment #257360 - Flags: ui-review?(mvl) → ui-review+

Comment 15

11 years ago
I think Davids comment 11 is very reasonable. How can one update Lightning to the most recent version if Thunderbird doesn't start. I know, there is safe mode, but this needs action from the user.
The comment is right, but not for this bug. This bug is about cleaning up the message. There is no functionality change. Please file a new bug on the exit issue.

Comment 17

11 years ago
Comment on attachment 257359 [details] [diff] [review]
Addresses mvl's comments

This looks like a better approach. r=ctalbert
Attachment #257359 - Flags: first-review?(ctalbert.moz) → first-review+
(Assignee)

Comment 18

11 years ago
(In reply to comment #16)
> Please file a new bug on the exit issue.

bug 372868 has been filed for that
(Assignee)

Updated

11 years ago
Whiteboard: [patch in hand][review needed ctalbert mvl][ui-review needed mvl] → [patch in hand][review needed mvl][ui-review needed mvl]
Whiteboard: [patch in hand][review needed mvl][ui-review needed mvl] → [patch in hand][review needed mvl]
Comment on attachment 257359 [details] [diff] [review]
Addresses mvl's comments

r2=mvl
Attachment #257359 - Flags: second-review?(mvl) → second-review+
(Assignee)

Comment 20

11 years ago
Patch checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Whiteboard: [patch in hand][review needed mvl]
VERIFIED with Tb 2.0.0.x on WindowsXP when writing patch for bug 372868.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Flags: blocking-calendar0.5+
You need to log in before you can comment on or make changes to this bug.