Minimize button stops working after loading Java applet (JEP 0.9.6, Carbon-only, Tiger and above)

RESOLVED FIXED

Status

Plugins Graveyard
Java (Java Embedding Plugin)
--
major
RESOLVED FIXED
12 years ago
2 years ago

People

(Reporter: smichaud, Assigned: smichaud)

Tracking

({fixed1.8.0.12, fixed1.8.1.4, regression})

unspecified
PowerPC
Mac OS X
fixed1.8.0.12, fixed1.8.1.4, regression
Bug Flags:
blocking1.8.1.4 -
wanted1.8.1.x +
blocking1.8.0.12 -
wanted1.8.0.x +

Details

Attachments

(1 attachment)

(Assignee)

Description

12 years ago
In all Carbon-based browsers (Firefox and Seamonkey) that bundle JEP
0.9.6, the minimize button (aka the collapse button) stops working in
a browser window (on OS X 10.4.X and above) after at least one Java
applet has been loaded in it.

This doesn't happen with earlier versions of the JEP.

This doesn't happen with Cocoa-based browsers (i.e. Camino).

This doesn't happen on OS X 10.3.X and 10.2.8.

I already have a 2-3 line fix for this problem, which I'll post in my
next message.  If fixing this is urgent enough (and I think it
probably is), I can release a new JEP "nightly" over the weekend that
contains nothing but this fix.  I'll call it JEP 0.9.6+a and post it
on my SourceForge site (http://javaplugin.sourceforge.net/).  The plan
would be to bundle it with Firefox 2.0.0.2 (and Firefox 1.5.0.10 and
so forth).

I don't think it's an option to revert back to JEP 0.9.5+g+2 -- 0.9.6
contains too many important fixes (see bug 364158).

I'm really embarrassed that I missed this ... though it makes me feel
better that everyone else seems to have missed it too.  I guess I've
become an orthodox Mac user -- I use "hide" much more often than I use
"minimize".
I think it might be too late for 1.8.1.2/1.8.0.10, but requesting blocking anyway.
Flags: blocking1.8.1.3?
Flags: blocking1.8.1.2?
Flags: blocking1.8.0.11?
Flags: blocking1.8.0.10?
(Assignee)

Comment 2

12 years ago
Created attachment 254561 [details] [diff] [review]
Fix that would be implemented in JEP 0.9.6+a

To fix this problem I had to change the workaround for a different
problem.  That workaround is old (it was present in earlier versions
of the JEP), and used to work just fine.  But it was (partially)
broken when I stopped using Apple's buggy Carbon event handlers to
translate Carbon events to Cocoa events.

Now I've found another (better) way to solve the (old) problem (one
that wouldn't have worked if I were still using Apple's handlers).
(Assignee)

Comment 3

12 years ago
I'm going to postpone creating a JEP 0.9.6+a (one that contains the
fix in attachment 254561 [details] [diff] [review]) until Mozilla.org decides to block Firefox
2.0.0.2 and 1.5.0.10 for a fix to this problem.

If I don't do a JEP 0.9.6+a release now, I'll probably do one in
couple of weeks that also contains a fix for a very-seldom-encountered
crash bug (reported at
http://sourceforge.net/tracker/index.php?func=detail&aid=1638030&group_id=107955&atid=649116)
and a workaround for an Apple bug that (to a large extent) breaks Java
applet garbage-collection in Java 6.0 and on Leopard.

Comment 4

12 years ago
Sorry, it is a bit late for 1.8.1.2/1.8.0.10, but let's try to get this ready for next time.  
Flags: blocking1.8.1.2?
Flags: blocking1.8.0.10?

Updated

12 years ago
Duplicate of this bug: 368495

Comment 6

12 years ago
I was going to file a bug, but I am not sure if this issue is relative to the problem.  I have noticed with the latest release of firefox, and I admit I haven't noticed whether leads to it, but the minimize button initially works, then just the right very outer circle can be clicked to minimize.  I didn't have this problem in the previous release, or at least I didn't notice it.  I am using a new Mac Pro, with the latest patches and OS X.
(Assignee)

Comment 7

12 years ago
> then just the right very outer circle can be clicked to minimize

I don't understand what you mean by this.
Maybe I live in a different world, but why is the inability to minimize an app an "urgent" issue or a "blocker"? Especially if you guys didn't even notice for a while. Can't we just wait until the next time we need a new JEP for a more critical issue?
Assignee: nobody → smichaud
Severity: major → minor
Flags: wanted1.8.1.x+
Flags: wanted1.8.0.x+
Flags: blocking1.8.1.4?
Flags: blocking1.8.1.4-
Flags: blocking1.8.0.12?
Flags: blocking1.8.0.12-

Updated

12 years ago
Severity: minor → major
Flags: blocking1.8.1.4?
Flags: blocking1.8.1.4-
Flags: blocking1.8.0.12?
Flags: blocking1.8.0.12-
Flags: blocking1.8.1.4?
Flags: blocking1.8.1.4-
Flags: blocking1.8.0.12?
Flags: blocking1.8.0.12-
Duplicate of this bug: 375739
(Assignee)

Comment 10

11 years ago
I've just released a new version (0.9.6.1) of the Java Embedding
Plugin that fixes this problem.  For more information see bug 376395.
(Assignee)

Updated

11 years ago
Depends on: 376395
Since bug 376395 landed, this should be FIXED, right?
Component: Plug-ins → Java Embedding Plugin
QA Contact: plugins → java.jep
(Assignee)

Comment 12

11 years ago
Yes.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Assignee)

Updated

11 years ago
Duplicate of this bug: 378943
fixed on branch by bug 376395
Keywords: fixed1.8.0.12, fixed1.8.1.4

Updated

8 years ago
Component: Java Embedding Plugin → Java (Java Embedding Plugin)
Product: Core → Plugins
Version: Trunk → unspecified
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.