Count of unread news posts is very often wrong

RESOLVED DUPLICATE of bug 79130

Status

Thunderbird
Mail Window Front End
--
major
RESOLVED DUPLICATE of bug 79130
12 years ago
8 years ago

People

(Reporter: walter, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a3pre) Gecko/20070212 Minefield/3.0a3pre
Build Identifier: trunk (very old bug)

(Note:  this applies only to newsgroups, not to mail.)

When I click on the twisty for a news server (to display all
of my subscribed groups) I can see the 'unread article'
count update as I watch.

The problem is that these updated counts are very often (but
not always) wildly wrong.

Then, when I click on a group to read it, I can see the
counts update a second time, this time correctly.

Alas, whenever the original count turns out to be wrong, any
article I select refuses to appear in the preview window.

I can see from watching my network traffic that no bytes at
all are sent to the news server, so it's no surprise that 
the server doesn't send the selected article.

I can correct this situation by double-clicking an article,
which opens in a separate window as expected.  Then I can
go back to the header pane and all works properly after 
that.


Reproducible: Sometimes

Steps to Reproduce:
1.
2.
3.



This bug appeared in Thunderbird trunk many moons ago.  I
didn't report it back then because I figured that someone
would fix it soon since it's such an obvious and annoying
problem.  I'd be surprised if this isn't a duplicate, but
I looked and didn't see anything similar.

Comment 1

11 years ago
Same here in Trunk for 3.0.
Adds one to messages count every 30 seconds or so.
Flags: blocking-thunderbird3?

Comment 2

11 years ago
(In reply to comment #1)
> Same here in Trunk for 3.0.
> Adds one to messages count every 30 seconds or so.
> 

Note that this happens for my global inbox.

Comment 3

11 years ago
I've seen this since the early NS 7 suite days.  The .rc file for news servers is not always correctly updated, so inaccurate lists of read/unread messages are displayed.  The folder pane will report X unread messages for a group, but no unread messages actually exist when you select the group to read.  It will not affect all newsgroups on a server.  Most will be correct, and one or two will have sticky wrong info, as though that line in the .rc file was being skipped.

I believe this only bites if you do everything online, downloading only headers, then downloading actual message bodies as you read them.  If you maintain a local message store for offline use, I believe the counts in the .rc file will be accurate.
Summary looks to say same phenomenon as Bug 160963(and DUP bugs of it) which was closed as DUP of old(before Mozilla 1.0) Bug 79130.
Duping to  Bug 79130
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 79130
Flags: blocking-thunderbird3?
You need to log in before you can comment on or make changes to this bug.