Closed Bug 370540 Opened 13 years ago Closed 12 years ago

Java applets and Java sripts don't work

Categories

(Firefox :: Extension Compatibility, defect)

2.0 Branch
x86
Windows Vista
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 364390

People

(Reporter: a_dyhr, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

Have Vista business fresh installed (no upgrade from XP) and installed Firefox 2.0.0.1. After installing Java 6.0 SE, Java ONLY works with IE7 but not with FF. Options in FF are all checked. If test from sun (http://www.java.com/en/download/installed.jsp) is run I don't get positive verification with FF, but I do with IE7. Running any other Java applet bring up blank screen.

Thanks

Reproducible: Always

Steps to Reproduce:
1. Uninstall JAVA
2. Uninstall FF 2.0.0.1
3. Re-install FF 2.0.0.1
4. Re-install JAVA

Actual Results:  
same problem

Expected Results:  
JAVA applets should run as they do in IE7
Andreas, please see Bug 370358 (its maybe a dupe of this)

Can you try to download the latest jre-release http://java.sun.com/javase/6/webnotes/install/index.html

Maybe also with the current Release Candidate of Firefox 2.0.0.2 (http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2.0.0.2-candidates/rc2/firefox-2.0.0.2.en-US.win32.installer.exe)

Does this steps fix your problem ? 
In fact it is a different problem as in Bug 370358. My laptop (Dell Latitude 420) does not freeze, it just throws an error. When I'm running a virtual tour  (http://www.tourfactory.com/idx326125) I get the error 
"Cannot start Java Virtual Machine, it is either not found or currently disabled"
I have installed FF 2.0.0.2 as you suggested and am running Java version 1.6.0 (build 1.6.0-b 105)
Running the same virtual tour in IE7 works.
As additional info, I had run an update from XP to Vista, before doing a clean install of Vista. At that time Java was working fine. Since I had many other issues with the upgrade (not FF and Java) I had to do a clean install. Now everything else is running well but Java on FF.
As a simple work-around for now I am using IE-Tab extension. Java runs fine in IE-Tab.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Component: OS Integration → Extension Compatibility
Resolution: --- → DUPLICATE
Version: unspecified → 2.0 Branch
Duplicate of bug: 364390
You need to log in before you can comment on or make changes to this bug.