Last Comment Bug 364390 - Java SE 6.0's Java Console extension has maxVersion = 2.0 ("java disabled after Firefox 2 upgrade")
: Java SE 6.0's Java Console extension has maxVersion = 2.0 ("java disabled aft...
Status: RESOLVED WORKSFORME
:
Product: Firefox
Classification: Client Software
Component: Extension Compatibility (show other bugs)
: unspecified
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
http://bugs.sun.com/bugdatabase/view_...
: 364469 365648 370540 371477 379305 382588 382743 382757 382761 383028 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-19 13:36 PST by Florian Effenberger
Modified: 2014-07-18 09:02 PDT (History)
18 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
install.rdf from Java SE 6.0 (667 bytes, text/plain)
2006-12-19 15:52 PST, Florian Effenberger
no flags Details

Description Florian Effenberger 2006-12-19 13:36:59 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

Java SE 6.0 is wrongly detected as incompatible plugin since 2.0.0.1
Although it is marked as incompatible, Java just works fine

Reproducible: Always

Steps to Reproduce:
1. Install FF 2.0
2. Install Java SE 6.0
3. Upgrade to FF 2.0.0.1

Actual Results:  
Java SE 6.0 is wrongly detected as incompatible plugin

Expected Results:  
Java SE 6.0 should be compatible
Comment 1 Simon Bünzli 2006-12-19 13:52:42 PST
That's rather a job for the folks over at Sun, since they explicitly state that the Java Console is only compatible until Firefox 2.0 (instead of Firefox 2.0.0.*). I guess somebody should tell them...
Comment 2 Florian Effenberger 2006-12-19 14:03:19 PST
Thanks for the feedback! Do you have contacts to the Sun Java team? I try to forward it, but I can't promise.

Is the check of extensions via web? If so, it just has to be changed on your server to prevent from users being confused by the warning.
Comment 3 Simon Bünzli 2006-12-19 14:47:37 PST
AFAICT the check was purely locally. To make sure, please locate your Firefox installation (probably "C:\Program Files\Mozilla Firefox"), go to the "extensions" subfolder and there the subfolder not starting with "{972ce..." (nor "inspector@...").

Within that folder, you'll find a file install.rdf which contains a line saying maxVersion 2.0 and you should not find any line saying updateURL (which would indicate a place where Firefox can do the check online). If that's the case, a bug would probably be in order... http://bugs.sun.com/services/bugreport/

(Unfortunately, I've already removed that intrusive extension of theirs from my hard disk, so I can't do that check myself.)
Comment 4 Florian Effenberger 2006-12-19 15:51:35 PST
You are right, I have attached my file to this issue.

What needs to be done in order to fix that bug?
What exactly has to be modified in the file?

Is there a Firefox option for corporate deployment telling FF to ignore checking this extension, e.g. by using prefs.js, user.js or override.ini?

I want to start deploying the new version soon, that's why I ask :-)
Comment 5 Florian Effenberger 2006-12-19 15:52:33 PST
Created attachment 249171 [details]
install.rdf from Java SE 6.0
Comment 6 Simon Bünzli 2006-12-19 16:40:56 PST
(In reply to comment #4)
> What exactly has to be modified in the file?

You'd have to replace the 2.0 with 2.0.0.* in the maxVersion line.

> Is there a Firefox option for corporate deployment telling FF to ignore
> checking this extension, e.g. by using prefs.js, user.js or override.ini?

Not AFAICT. OTOH since that extension is installed into Firefox's installation directory, you're probably able to either adjust the extension's install.rdf as mentioned above or to remove it during the deployment so that your users don't get the incompatibility warning.
Comment 7 Florian Effenberger 2006-12-20 02:18:20 PST
Thanks Simon, will test that!
Comment 8 Florian Effenberger 2006-12-20 03:22:03 PST
In my deployment, I just copied a modified install.rdf file. This seems to work.
Comment 9 Simon Bünzli 2006-12-20 07:36:18 PST
*** Bug 364469 has been marked as a duplicate of this bug. ***
Comment 10 aghper 2006-12-20 08:58:39 PST
(In reply to comment #9)
> *** Bug 364469 has been marked as a duplicate of this bug. ***
> 
oops my mistake I did search just to see if someone else had the same problem I did not see.sorry.what this means now,I was able to visit pages which uses java and no problem?do I uninstall java and install old version?
Comment 11 Simon Bünzli 2006-12-20 13:42:53 PST
(In reply to comment #10)
> do I uninstall java and install old version?

No need to do that, Java is working fine. What's marked as incompatible and disabled is only the extension shipped with Java 6 which adds a menu item "Java Console" to the Tools menu.

So unless you are a developer and use the Java Console on a regular basis, this shouldn't affect you at all.
Comment 12 aghper 2006-12-20 18:28:41 PST
(In reply to comment #11)
> (In reply to comment #10)
> > do I uninstall java and install old version?
> 
> No need to do that, Java is working fine. What's marked as incompatible and
> disabled is only the extension shipped with Java 6 which adds a menu item "Java
> Console" to the Tools menu.
> 
> So unless you are a developer and use the Java Console on a regular basis, this
> shouldn't affect you at all.
> 

thank you very much for taking the time and answering my question.
Comment 13 Carsten Book [:Tomcat] 2007-01-02 07:12:38 PST
*** Bug 365648 has been marked as a duplicate of this bug. ***
Comment 14 Robert Strong [:rstrong] (use needinfo to contact me) 2007-03-09 21:11:27 PST
*** Bug 371477 has been marked as a duplicate of this bug. ***
Comment 15 Samuel Sidler (old account; do not CC) 2007-04-30 20:19:48 PDT
*** Bug 379305 has been marked as a duplicate of this bug. ***
Comment 16 Alfred Peng 2007-05-15 00:13:20 PDT
Danielle, could you please take a look at this bug?
Comment 17 Florian Effenberger 2007-05-15 01:44:48 PDT
Maybe fixed with J2SE 6.0 Update 1
Comment 18 danielle.pham 2007-05-15 21:18:28 PDT
This has been fixed in 6.0 update 2.
Comment 19 danielle.pham 2007-05-15 21:19:34 PDT
(See Sun bug id 6506635)
Comment 20 Simon Bünzli 2007-05-31 06:51:12 PDT
*** Bug 382588 has been marked as a duplicate of this bug. ***
Comment 21 Kevin Brosnan 2007-05-31 19:13:07 PDT
*** Bug 382743 has been marked as a duplicate of this bug. ***
Comment 22 Samuel Sidler (old account; do not CC) 2007-05-31 21:48:17 PDT
*** Bug 382757 has been marked as a duplicate of this bug. ***
Comment 23 Phil Ringnalda (:philor) 2007-05-31 22:08:38 PDT
*** Bug 382761 has been marked as a duplicate of this bug. ***
Comment 24 christian 2007-05-31 23:12:07 PDT
hi, i have the same problem with java, when the firefox update finished, i had a message saying that java isn t compatible. so i went in "C:\Program Files\Mozilla Firefox"), go to the
"extensions" subfolder and there the subfolder not starting with "{972ce...", i opened the rdf file with a word pad, but no "20.0" to change in "2.0.0*"
thx
Comment 25 christian 2007-05-31 23:26:27 PDT
hi, i have the same problem with java, when the firefox update finished, i had a message saying that java isn t compatible. so i went in "C:\Program Files\Mozilla Firefox"), go to the
"extensions" subfolder and there the subfolder not starting with "{972ce...", i opened the rdf file with a word pad, but no "20.0" to change in "2.0.0*"
thx
Comment 26 John O'Duinn [:joduinn] (please use "needinfo?" flag) 2007-06-01 01:47:56 PDT
I was able to reproduce this problem on my WinXP machine when FF auto-updated from FF2003 -> FF2004... and in the process disabled my JavaConsole6.0.01. 

There was a claim above that this J2SE6.0.01 compatibility problem was fixed in J2SE6update2. However, I couldnt find J2SE6.0.02 on the java.sun.com site. As far as I can tell, J2SE6.0.02 is not yet available. Instead I found a nightly build of J2SE6u2 on http://download.java.net/jdk6/binaries/jdk-6u2-ea-bin-b02-windows-i586-p-12_apr_2007.exe. 

Installing that did the trick for me, and I now have a working Java Console using a nighty build of J2SE6.0.02 running with FF2.0.0.4. 

Hope that helps...
Comment 27 danielle.pham 2007-06-01 14:13:29 PDT
Everyone,
As mentioned in earlier post on May/15, this problem has been fixed in 6.0u2 (Sun bug ID: 6506635)

6u1 is currently still the official latest update on java.com.
However, in the interim waiting for 6u2 official, please refer to Johon O'Duinn post above for link to download nightly of 6u2, to overcome this problem in your testing.
http://download.java.net/jdk6/binaries/jdk-6u2-ea-bin-b02-windows-i586-p-12_apr_2007.exe
Comment 28 Tuukka Tolvanen (sp3000) 2007-06-03 07:42:27 PDT
*** Bug 383028 has been marked as a duplicate of this bug. ***
Comment 29 Anna Welsford 2007-06-05 00:30:54 PDT
Just to let you know that this does NOT work correctly. I have an application running on my computer called Quotestream and this does NOT work in firefox since the new update, works in IE fine but firefox spits its dunny out over it.

To give you a bit of background...its a streaming data tool...for stock prices...the streaming prices are not coming through nor is the level 2 information (market makers order books) but other parts are streaming fine.
Comment 30 danielle.pham 2007-06-05 11:34:21 PDT
Hi Anna,
This bug is on Java Console extension only.
If you think problem is Sun Java related only, please go to http://bugs.sun.com/bugdatabase/index.jsp to submit a bug.
Please be sure to provide:
- OS version, JRE version, FF version.
- Copy of testcase or URL where the problem seen with your streaming data tool can be reproduced.
- Level 5 Java traces (from Java Console).
Comment 31 (mostly gone) XtC4UaLL [:xtc4uall] 2007-06-26 16:11:45 PDT
*** Bug 370540 has been marked as a duplicate of this bug. ***
Comment 32 Simon Bünzli 2007-07-06 06:03:47 PDT
This has been fixed for Java SE 6.0 Update 2 which has been recently released. maxVersion has now been set to 5.0+ which should be fine for the years to come (from a user's POV anyway).

Note You need to log in before you can comment on or make changes to this bug.