TB slow or doesn't respond while loading large HTML message, with external images

RESOLVED DUPLICATE of bug 379828

Status

Thunderbird
Mail Window Front End
--
major
RESOLVED DUPLICATE of bug 379828
11 years ago
10 years ago

People

(Reporter: Tim K, Unassigned)

Tracking

({perf, regression, testcase})

perf, regression, testcase

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: version 2 beta 2 (20070116)


I get a daily HTML newsletter (dealnews.com) for which I set TB to allow loading remote images automatically for this sender.

In TB 1.5 while the message was loading (it did take a little bit) I could still scroll up and down in the message window, using the mouse wheel.

In TB 2 beta 2 the entire TB hangs, it doesn't respond at all until the entire message is loaded.

I use a SOCKS proxy for outgoing connections, if that makes a difference.

This seems to be a regression from TB 1.5

Reproducible: Always

Steps to Reproduce:
1. Get a large HTML message (e.g. dealnews.com newsletter)
2. Click on the message
3. While the message is loading, TB2 hangs, it doesn't respond to the mouse wheel.




Regression from TB 1.5

Comment 1

11 years ago
Could you attach a test message (save as .eml). 
(Reporter)

Comment 2

11 years ago
Created attachment 255334 [details]
sample HTML email on which TB hangs for me

Here's the message attached, but if I open it from my desktop it's fast and it doesn't load any of the images ... It may need to be moved into an (IMAP) Inbox to see the problem.

If not, you could just sign up for the dealnews.com daily newsletter - don't worry, you won't get spammed and you can get off their mailing list. Of course, you could also use some sort of a disposable email address too, but one that doesn't mess with the HTML ...

Comment 3

11 years ago
-> NEW on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.2pre) Gecko/20070217 Thunderbird/2.0pre ID:2007021703

Forwarded the attached mail to my imap account. Thunderbird doesn't hang, but e.g. trying to scroll the folder pane doesn't really work while the msg is loading. Thunderbird is very sluggish and doesn't respond very well.

Don't see this with a recent 1.5.0.x nightly.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Windows XP → All
Hardware: PC → All
Summary: TB hangs while loading large HTML message, with external images → TB dosen't respond while loading large HTML message, with external images
Version: unspecified → 2.0
(Reporter)

Comment 4

11 years ago
OK, I'm glad someone else can confirm the regression from 1.5.0.x

Hopefully we will see a fix for this in time for TB2 final.

Comment 5

11 years ago
attachment 255334 [details] is an excellent testcase.
the images load serially. could this be part of the problem?

plus maybe reflow?

probable duplicates:
bug 380713
bug 379828 - in this bug, per reporter disabling phishing isn't a great improvement

bug 369345 might be related, but it's different in that reporter sees problem for both html and what he calls "plain text"
Assignee: mscott → nobody
Component: General → Mail Window Front End
Keywords: perf, testcase
QA Contact: general → front-end
Summary: TB dosen't respond while loading large HTML message, with external images → TB slow or doesn't respond while loading large HTML message, with external images

Updated

10 years ago
Duplicate of this bug: 380713
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 379828
You need to log in before you can comment on or make changes to this bug.