Someone has taken da@dictionaries.addons.mozilla.org, but no extension exists

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Dictionaries
RESOLVED FIXED
11 years ago
2 years ago

People

(Reporter: hansen, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a3pre) Gecko/20070217 Minefield/3.0a3pre
Build Identifier: 

Someone has taken da@dictionaries.addons.mozilla.org, so I can't release the "official" Danish dictionary under that name.

At the moment I use danish@dictionaries.addons.mozilla.org, but that creates problems several places.
For instance; https://addons.mozilla.org/firefox/dictionaries/?lang=da

Could someone help me by giving me the rights to "da"-dictionary? Then I could upload the official Danish dictionary.
And perhaps a solution for the "danish"-dictionary - should it be removed or should I continue to maintain that as well?

The current Danish dictionary is at https://addons.mozilla.org/extensions/3596/

Reproducible: Always

Comment 1

11 years ago
confirming. I see this problem too.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

11 years ago
Which extension is the one with da@dictionaries...., and who'd be 'someone'? And what's the difference between that dictionary and the one that you would like to publish?
(Reporter)

Comment 3

11 years ago
I have no idea. I'm just prompted with an error, that someone already has uploaded something with extension ID da@dictionary...

My extension (3596) is the official Danish dictionary - always up to date and used by thousands of users.

I'm the maintainer of the dictionary for MozillaDanmark and also the translator of Thunderbird, so I would love to get this fixed before 2.0.

Comment 4

11 years ago
http://benjamin.smedbergs.us/dictionary-packager/ generates an extension with id "da@dictionaries.addons.mozilla.org". That id is used by somone else, AFAIK that extension has never been approved om AMO. Therefore we use an unofficial id for the Danish dictionary "danish@dictionaries.addons.mozilla.org". There are two small problems with that:

1: Benjamin's tool mentioned above creates a dictionary with another id than the one we use.
2: The dictionary is not displayed correctly on https://addons.mozilla.org/firefox/dictionaries/?lang=da . Actual: "danish | danish | Install (476 KB)", expected: "Danish | Dansk (da) | Install (476 KB)"

"Someone" is propably hansen himself. As I remember, hansen complained about AMO behaved strange first time he tried to upload the extension. I think the extension with id da@dict... is stuck somewhere in a cavity of AMO.

I think we should keep using the id we use now. Otherwise automatic update of the dictionary would stop working.
(Reporter)

Comment 5

11 years ago
No.

I want da@dict - and I'll maintain danish@dict too. That would be the best solution.

Comment 6

11 years ago
Why? The only problem I can find in having the wrong id is the cosmetic problem at AMO, which can be fixed with one line of JavaScript. Why maintain two extensions?
(Reporter)

Comment 7

11 years ago
If we only keep the danish@dict, then we have to make redirects from da=>danish, since both Firefox and Thunderbird links to da.

That's fine by me - but I don't know how many people that would involve and it would be a hack.

Comment 8

11 years ago
Created attachment 258104 [details] [diff] [review]
Display Danish dictionary correctly in remora

Corrects "danish" to "da", added above the correction for "nb-NO_nn-NO" to "nb-NO" and "nn-NO".

Solves two problems on the dictionaries page in remora:
1: Danish dictionary is displayed in the top of the page instead of the English one
2: The line with the Danish dictionary further down the page is displayed correctly

Comment 9

11 years ago
BTW, when JavaScript is off, all dictionary links in remora are 404 Not Found.

Comment 10

11 years ago
So, what option are we going for? Who is the decision makers? It would be nice to have the danish dictionary display correctly at the time of remora release.
hansen:  Judging by the email address, I'd say you already own da@dictionaries.addons.mozilla.org.  Have you tried logging in and updating it? (the email address is a gmail.com address)

(I realize this doesn't answer the danish vs. da question)
(Reporter)

Comment 12

11 years ago
Okay - that's a bit strange, since I don't own a Gmail-account.

Could you post the mail, so we could contact the person.
I sent them an email.  I don't want to post their address publicly without them knowing.  If they are unresponsive, we can start looking at other options.
(Reporter)

Comment 14

11 years ago
The owner of da@... replied:
> Hi there, I'm sorry, but I haven't got the faintest idea of, what You
> guys are talking about. ???? AMO - WHAT??? da dictionairies WHAT ??? 
> I should be the owner of WHAT ??? I know what a keyboard is, and is
> capable of turning the computer off an on, and I am actually also
> able to maintain some continuity in updating programs and so on, but
> what I read in the thread, You gave a link to, is as if written for a
> Serbo-Croat - no way, I can help You out here. But feel free to use
> my e-mail-adress to ask all sorts of questions about what I have done
> or where I have "been" on the Mozilla site, and I will help out there
> as best I can. At least I know, where the log is, and can go back in
> time. Once a long time ago, I offered some help with translation
> english to danish, but it was never actual for Mozilla or G-mail to
> take me up on the offer. But I never downloaded anything or heard
> anything about it, so I just assumed, my help was not needed. With
> regards, and sorry, if I didn't write in perfect english - remember,
> I am a pastry ;-D I'm Danish!!! Tina

Comment 15

11 years ago
(From bug 380305)

AMO now handles the special Danish extension id (see http://remora.stage.mozilla.com/da/thunderbird/browse/type:3 ). I think this bug could be closed?
(Reporter)

Comment 16

11 years ago
As to comment #15
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.