Last Comment Bug 371734 - include desktop entry file
: include desktop entry file
Status: RESOLVED DUPLICATE of bug 296568
:
Product: Thunderbird
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Linux
: -- enhancement (vote)
: ---
Assigned To: Scott MacGregor
:
:
Mentors:
http://standards.freedesktop.org/desk...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-26 05:58 PST by Danny Milosavljevic
Modified: 2013-08-12 21:30 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Example desktop file for Thunderbird (1.11 KB, text/plain)
2007-11-16 06:26 PST, Matěj Cepl
no flags Details

Description Danny Milosavljevic 2007-02-26 05:58:32 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.9) Gecko/20070118 Red Hat/1.5.0.9-10.el5 Firefox/1.5.0.9 pango-text
Build Identifier: version 1.5.0.9 (20061206)

You might want to include a file "thunderbird.desktop" like this:

--------------------------------------------------
[Desktop Entry]
Name=Thunderbird Email
Comment=Lightweight Mozilla-based mail client
Exec=thunderbird %f
Icon=thunderbird.png
Terminal=false
Type=Application
StartupNotify=false
Categories=Application;Network;
MimeType=application/mbox;message/rfc822;
--------------------------------------------------
(install it to "/usr/share/applications/")

details see http://standards.freedesktop.org/desktop-entry-spec/latest/

This enables better desktop integration. 


Reproducible: Always
Comment 1 Danny Milosavljevic 2007-02-26 06:14:32 PST
or into "${XDG_DATA_HOME}/applications/", in the user's home.

Comment 2 Magnus Melin 2007-02-26 11:40:17 PST
Builds from mozilla.org do not include any linux installer...
Comment 3 Danny Milosavljevic 2007-02-28 01:59:20 PST
thunderbird could copy it into "${XDG_DATA_HOME}/applications/" on first launch... (not sure if that would help, though) 
Comment 4 Matěj Cepl 2007-11-16 06:26:41 PST
Created attachment 288996 [details]
Example desktop file for Thunderbird

This file is currently from Ubuntu http://archive.ubuntu.com/ubuntu/pool/main/f/firefox/firefox_2.0.0.8+2nobinonly-0ubuntu3.diff.gz
but will be in Fedora as well (https://bugzilla.redhat.com/show_bug.cgi?id=384711)
Comment 6 Dwayne Bailey 2008-06-18 02:45:02 PDT

*** This bug has been marked as a duplicate of bug 296568 ***
Comment 7 Filipus Klutiero 2013-08-12 21:30:51 PDT
#296568 is about Firefox. This one is about Thunderbird.

Note You need to log in before you can comment on or make changes to this bug.