Closed Bug 372023 Opened 13 years ago Closed 8 years ago

Improve the UI for tagging bugs

Categories

(Bugzilla :: Creating/Changing Bugs, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
Bugzilla 4.4

People

(Reporter: mkanat, Assigned: LpSolit)

References

(Depends on 2 open bugs, Blocks 1 open bug)

Details

(Keywords: meta, Whiteboard: [roadmap: 4.0])

Right now, tags appear somewhat awkwardly in the footer on every page.

Instead, tags should work like blog tags do--they should be a comma-separated list of "personal keywords" that you can put onto a bug. We can display the list of choices in an AJAX-like fashion if we really want to show people their current tags.

If they type in a tag that they haven't used before, that just creates a new saved search.

This would make people use and love tags.
Duplicate of this bug: 74258
Depends on: 95722
Depends on: 365743
Duplicate of this bug: 344432
Duplicate of this bug: 377358
Adding some more bugs as blocking this one. Maybe we will redesign the tagging system to not appear in the footer anymore. We will see.
Depends on: 365124, 365127
Keywords: meta
Assignee: create-and-change → LpSolit
Target Milestone: --- → Bugzilla 3.2
Target Milestone: Bugzilla 3.2 → Bugzilla 4.0
Whiteboard: [roadmap: 4.0]
Assignee: LpSolit → guy.pyrzak
Depends on: 365099, 369139
Priority: -- → P2
Blocks: 482207
pyrzak's students' research indicates that tags are currently a very severe UI problem.
Blocks: bz-hci2008
Depends on: 474399
Depends on: 505079
Duplicate of this bug: 534099
Depends on: 616185
Depends on: 616191
Depends on: 616192
Depends on: 616336
Depends on: 637648
Everything that has been asked for in comment 0 has now been implemented, mostly by bug 616191. The remaining open bugs are smaller improvements, and so I'm marking this bug as fixed. This of course doesn't mean further improvements are forbidden or shouldn't be suggested. :)
Assignee: guy.pyrzak → LpSolit
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.