download/update/restart switch default browser settings

RESOLVED DUPLICATE of bug 353814

Status

()

Firefox
Shell Integration
--
major
RESOLVED DUPLICATE of bug 353814
11 years ago
11 years ago

People

(Reporter: Biju, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
I have both
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a3pre) Gecko/20070313 Minefield/3.0a3p
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3pre) Gecko/20070309 BonEcho/2.0.0.3pre

I want to keep BonEcho as my default browser.
But Minefield after download/update/restart switch default browser settings, to make itself.
And reverse also happens for BonEcho.

Expected Result: default browser settings should not be changed without user consent.

Updated

11 years ago
Component: Software Update → OS Integration
QA Contact: software.update → os.integration
I run various trunk builds and branch builds all the time, and this has never happened to me. Is your profile set to prompt you at startup if it isn't the default?
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> Is your profile set to prompt you at startup if it isn't the default?

Yes, 
when start firefox 2/3 by clicking firefox.exe/shortcut_to_it 
I see this prompt. 
But not when I do download/update/(auto/manual later)-restart.
Dupe of bug

See bug 369314 comment #5 for an explanation as to why this is happening
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 353814
You need to log in before you can comment on or make changes to this bug.