Compatibility only shows current app

RESOLVED FIXED in Q1 2011

Status

addons.mozilla.org Graveyard
Public Pages
P4
normal
RESOLVED FIXED
11 years ago
2 years ago

People

(Reporter: fligtar, Unassigned)

Tracking

Dependency tree / graph

Details

(Reporter)

Description

11 years ago
http://preview.addons.mozilla.org/en-US/firefox/addon/219
http://preview.addons.mozilla.org/en-US/thunderbird/addon/219
http://preview.addons.mozilla.org/en-US/seamonkey/addon/219

The above add-on is compatible with Firefox, Thunderbird, and SeaMonkey, but in order to find that out, you'd need to switch to each application area.

Comment 1

11 years ago
That's intentional; see the IRC discussions when the feature was implemented.

Doesn't mean we can't change it, just wanted to mention.
(Reporter)

Comment 2

11 years ago
I recalled the discussions ending in us deciding to have the other info in a hidden div with something like "Other compatible applications...". Other applications is a huge part of the compatibility info and needs to show up somehow.
For info I ended up resolving a bug as invalid because it appeared that the extension the user was talking about shouldn't have been compatible with the app they were trying to use.

Additionally I barely even realised that you could browse extensions by different apps, the menu is barely visible on my screen
Severity: major → normal
Target Milestone: --- → 3.x (triaged)

Comment 4

10 years ago
Was anything ever concretely decided one way or the other on this?  Bringing it up again as the ranges were removed and brought back in bug 425539 and will be put back live again soon.

I think this is valid info to be listed.  For example, a few extensions are compatible with both a browser and another non-browser app.  (i.e. AdBlock Plus supports Firefox and Thunderbird, not to mention half a dozen others)  Without listing them all users don't actually know this while browsing in Firefox.

Comment 5

10 years ago
I suggest we display a complete compatibility list on the "all versions" page. On the details page, 

Works with:
  * Firefox 3.0
  * and others...

would work for me, possibly linking "and others" to the current version on the all versions page.
Depends on: 425539
Version: 3.0 → 3.2
It would be nice to have an "Other applications..." link to a hidden div as suggested in comment #2 and show the compatibility ranges for the current version of all other applications upon clicking next to See All Versions link.

That is, if you can gather all the compatibility ranges, otherwise I'd just show the other applications Icon and/or name and switch to the other url on clicking it...

Are the IRC discussion logs from comment #1 public? If so, where can I find them? If not, can someone with access to thes logs attach them here?

Comment 7

10 years ago
The way I see it, one of the points of this is to make it easily known what supports what.  I don't think burying it in the versions page is a good idea.  The best way to handle the possibility of this list getting too long is to show Firefox, Thunderbird, and Seamonkey directly in the list and then use the DIV idea for any others.  (i.e. Netscape, Flock, Songbird, Midbrowser, eMusic Remote, Toolkit, or any other obscure thing you can add to install.rdf)  This way the public page makes it clearly known who can run this add-on, whilst not cluttering things up with their collection of miscellaneous (partially) supported applications.

Updated

10 years ago
Duplicate of this bug: 342968
Severity: normal → enhancement
Priority: -- → P4
Whiteboard: [ddn]
(Reporter)

Comment 9

8 years ago
I like the idea of adding an ", others" link in the metadata table and clicking it replaces that link with the list of other compatible apps and versions. We would only list supported applications on the site, as we started ignoring other apps from install.rdf long ago.

And for the record, I consider this a bug, not an enhancement, as AMO used to prominently show this information next to the install buttons and it was left out of Remora's first design and never added back the last 3 years.
Severity: enhancement → normal
Whiteboard: [ddn]

Comment 10

8 years ago
This has been partially fixed. All AMO supported applications' ranges are now listed for each version on the all versions page as well as for the current version down next to the release notes on the main addon details page. It would however be nice to show this info more prominently up top as discussed.
(Reporter)

Comment 11

7 years ago
Though this is fixed enough in our current details page, I'm not sure that our new details page designs take this into account. cc'ing chowse for us to make sure we add something like this in the new designs.
Target Milestone: 4.x (triaged) → Q1 2011
(In reply to comment #11)
> Though this is fixed enough in our current details page, I'm not sure that our
> new details page designs take this into account. cc'ing chowse for us to make
> sure we add something like this in the new designs.

Why are we keeping it open if it's fixed?  I'll add a dependency on the new design bug, but it sounds like this should be closed.
Depends on: 624584
As per comment #11, we include compatibility info in release notes, which are visibile on the main page. This is where they'll continue to be in the redesign. I don't plan to make them any more prominent for Firefox add-ons.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.