Closed Bug 425539 Opened 14 years ago Closed 14 years ago

Bring back the compatibility ranges

Categories

(addons.mozilla.org Graveyard :: Public Pages, defect)

defect
Not set
blocker

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: aryx, Assigned: laura)

References

Details

(Keywords: regression)

Attachments

(1 file)

Please bring back the compatibility ranges. They are useful information, i.e. how long an add-on isn't maintained anymore or if it will probably work in another Gecko app with the same Gecko version (i.e. Flock).
Also, how am I supposed to find out which of my extensions already support FF3, without actually installing FF3?
This seems particularly important with the upcoming transition to FF3. End-users may not use FF3 unless their add-ons are compatible, and there's no simple way to find out.
It seems it's intentional: AMO automatically detects your version of FF and displays information based on that:

http://blog.mozilla.com/basil/2008/03/26/availability-of-new-addons.mozilla.org-amo-site/

A cool feature that reduces complexity for end users, but it doesn't serve an important scenario: FF2 users want to know if an add-on is compatible with FF3 *before* they upgrade -- i.e., while they're still using FF2.

Maybe AMO can do both? -- Keep the current version sniffing and display, and simply add a list of compatible versions. Even if it's under Advanced (though many non-advanced users will want this info too).
(In reply to comment #3)
> Maybe AMO can do both? -- Keep the current version sniffing and display, and
> simply add a list of compatible versions. Even if it's under Advanced (though
> many non-advanced users will want this info too).

Yes, this sounds like a good idea to me. Madhava, what place do you think this should be in on the details page? Maybe right above the install button (and there, only the compatiblity range for the current app will be shown)? Also, on the version history page, should we show the ranges for all compatible apps, right above the individual install buttons?
For extensions that work for non-browser products, like Thunderbird, the version info is a must because you can't sniff the version.  So I think that this should be resurrected in someplace easily visible, and not hidden away somewhere like in advanced (at least, not for any extensions that are marked as compatible w/ a non-browser product).
Now that, as in bug 425477, we're increasing the prominence of the "See All Versions >" link, I wonder if it would make sense to add the compatibility range of the current version along side it.  Something like "This version compatible with APPNAME x.xx - x.xx." and then the link on the next line.  Thoughts?

In the case of non-browser apps, we should probably show the compatibility range up near the "Add to [APP]" button, really.  Perhaps as a new paragraph following the short description (i.e. with a blank line separating the two).  "Compatible with APPNAME versions x.xx - x.xx."
Yes, Madhava, this has been a consistently requested piece of data on the add-on details page. Your solution works well. Requesting to target this for v3.4
Target Milestone: --- → 3.4
I like both suggestions, Madhava. For non-browser apps, having it by the download button is important. However, do we need to add it everywhere (hard due to the space it'd take) or only on the details page?

For browser apps, I believe above the "see all" link is good because it makes a logical connection between *this* version (compatible with x.xx-x.xx) and all versions, which may be compatible with others.

On the "all versions" page, I suggest we display all compatiblities for each version, no matter what app page you are currently on. What do you think about that? (Marking this blocking the design of the version history page, bug 420332).
Blocks: 420332
Target Milestone: 3.4 → ---
Target Milestone: --- → 3.4
Severity: normal → blocker
Blocks: 425477
Blocks: 425382
Duplicate of this bug: 429035
Please see https://bugzilla.mozilla.org/attachment.cgi?id=314656 for an example of how to add the app compat ranges to the details page. Also need it on the version details page as well.
Assignee: nobody → laura
Target Milestone: 3.4 → 3.4.1
Comment on attachment 317607 [details] [diff] [review]
Patch to add back the version range on the main addon page.

Looks good to me; could be prettier, but it works like this. Plain and simple.

Can you add something to the "all versions" page too?
Attachment #317607 - Flags: review?(fwenzel) → review+
Patch committed in r12506.
Status: NEW → RESOLVED
Closed: 14 years ago
Keywords: push-needed
Resolution: --- → FIXED
I can't verify it on either that extension or on https://preview.addons.mozilla.org/en-US/firefox/addon/32. I'm not seeing the compatibility range on the main extension page yet.
(In reply to comment #15)
> I can't verify it on either that extension or on
> https://preview.addons.mozilla.org/en-US/firefox/addon/32. I'm not seeing the
> compatibility range on the main extension page yet.
> 

JM Hardin: I see it on both of those extensions.  It's under the long description under heading "Works with:" and above "See all versions".  Try clearing your cache?
Gah, that's where they're putting it? I was looking near the button that I couldn't click. I still feel I'm having to hunt for important info but I'll assume it's just me and simply use a site I feel is more user friendly when looking for extensions.
JM: yep, that's where I put it, as per design mocks.  Thanks for the feedback - will discuss it with team.
Keywords: push-needed
Blocks: 374890
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.