Closed Bug 375089 Opened 13 years ago Closed 13 years ago

SeaMonkey extensions and themes pages talk about "Firefox"

Categories

(addons.mozilla.org Graveyard :: Public Pages, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: kairo, Unassigned)

References

()

Details

The descriptions displayed on top of the content areas of the SeaMonkey extensions and themes overview pages https://preview.addons.mozilla.org/en-US/seamonkey/browse/type:1 and https://preview.addons.mozilla.org/en-US/seamonkey/browse/type:2 talk about Firefox instead of SeaMonkey as the application customized by those add-ons.

Those should be fixed to correctly feature SeaMonkey there.

If I know what to do, I can possibly help there. Are those blurbs in SVN or somewhere else? For what I see, it's a simple matter of replacing "Firefox" with "SeaMonkey" in those blurbs.
Duplicate of this bug: 374924
No, unfortunately the category descriptions are in the database. So /app/views/addons/browse_categories.thtml needs to be changed:

<p<?=$type['Translation']['description']['locale_html']?>>
  <?=sprintf($type['Translation']['description']['string'], APP_PRETTYNAME)?>
</p>

And same in /app/views/addons/browse_types.thtml, sprintf needs to be added:

<p><?=sprintf($type['Translation']['description']['string'], APP_PRETTYNAME)?></p>

And after that the descriptions in the database needs to be changed for all languages, replace occurrences of "Firefox" by "%1$s".
This should do the trick:

UPDATE translations SET localized_string = REPLACE(localized_string, "Firefox", "%1$s") WHERE (SELECT addontypes.id FROM addontypes WHERE description = translations.id)

Worked in my local MySQL 5.0 (I think AMO uses the same version).
Wladimir: Yes, this looks reasonable, thanks. We'll have this run on production.
Extensions are small add&#45;ons that add new functionality to &#37;1$s, from a simple toolbar button to a completely new feature. They allow you to customize &#37;1$s to fit your own needs and preferences, while letting us keep &#37;1$s itself light and lean.

HTML entities strike again.
I cry.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.