Changelog page missing most recent version information

RESOLVED FIXED in 4.x (triaged)

Status

--
minor
RESOLVED FIXED
12 years ago
3 years ago

People

(Reporter: dveditz, Unassigned)

Tracking

unspecified
4.x (triaged)

Details

(Reporter)

Description

12 years ago
The Changelog information is mixed up with the "get old versions" functionality, and as a result the most relevant changelog information -- that for the current release! -- is missing.

If the information is there somewhere then please morph this bug into one about making that information much much more obvious and easy to find.
(Reporter)

Updated

12 years ago
Blocks: 375537
I was confused too when I saw that the Version History page no longer shows the current version. 

But it seems to be as intended, according to bug #371782, and is consistent with the phrasing used on this page and for the link to get to there.
(Reporter)

Comment 2

12 years ago
It may make sense to have an advertised "old versions" page have only previous versions, but the page was actually doing double-duty as the only place to get the changelog. Bug 371782 changed the content to match the link text, but maybe it should have changed the link text to match the content.

If we want to resolve this by creating a separate "change history" page (and adding a link to get there) that'd be fine by me.
Severity: normal → minor
Target Milestone: --- → 3.x (triaged)
I believe we can mark this fixed: The version history page has been displaying every version (also the newest) including the respective changelogs for a long time now.

The link text was also adjusted to match the content ;)
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.