Manually marking a message as junk also marks it as read

RESOLVED DUPLICATE of bug 352428

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 352428
11 years ago
10 years ago

People

(Reporter: Tom Conder, Unassigned)

Tracking

(Depends on: 1 bug)

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: version 1.5.0.10 (20070221)

Whenever you mark a message as junk using right-click, it also marked as read even though it hasn't been read.

Reproducible: Always

Steps to Reproduce:
1. Right-click on mail item and Mark > As Junk
2. See that while it is marked as junk it is also marked as read

Actual Results:  
The message is marked as junk AND as read

Expected Results:  
The message should simply be marked as junk. It's read/unread status should not change.

The application used to behave correctly many releases ago.
i guess this is changed in Thunderbird 2. You can find the RC of thunderbird 2 here http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/2.0.0.0rc1/ if you want to try out that.
(Reporter)

Comment 2

11 years ago
Negative. Thunderbird 2 RC 1 exhibits this behavior too.

Updated

11 years ago
URL: n/a
(Reporter)

Updated

11 years ago
Summary: Marking a message as junk marks it as read → Marking a message as junk also marks it as read
Version: unspecified → 2.0
(Reporter)

Updated

11 years ago
Summary: Marking a message as junk also marks it as read → Manually marking a message as junk also marks it as read

Comment 3

11 years ago
The mark-as-read behaviour is governed by two preferences:

mail.spam.markAsReadOnSpam (default: false) controls whether messages filtered as junk automatically will be marked as read.

mailnews.ui.junk.manualMarkAsJunkMarksRead (default: true) controls whether messages set as junk manually (click, context menu) will be marked as read.
(Reporter)

Comment 4

11 years ago
In Thunderbird 2 I wasn't able to find the preference: mail.spam.markAsReadOnSpam

I did find these:

1) mail.server.default.markAsReadOnSpam defaults to false
2) mailnews.ui.junk.firstuse defaults to true

I set the #1 value to false and the #2 value to false. There was no change. That is, Thunderbird still marked the messages as read when I manually set it to junk using right-click. 

Email is on an IMAP server. Make a difference?

Comment 5

11 years ago
> In Thunderbird 2 I wasn't able to find the preference:
> mail.spam.markAsReadOnSpam

This pref can be set in the UI on the privacy tab ("[ ] Mark messages determined to be Junk as read"). If your config editor does not show one of the prefs I mentioned, you have to create it with type "boolean".

> 1) mail.server.default.markAsReadOnSpam defaults to false

That's an old TB 1.5 setting which is not used anymore. TB 2 should have converted it into mail.spam.markAsReadOnSpam, though...

> 2) mailnews.ui.junk.firstuse defaults to true

This pref is irrelevant here.

> Email is on an IMAP server. Make a difference?

No. 

[Xref: bug 377920]

Comment 6

11 years ago
Tom, what is your status after reviewing comment 5?

Comment 7

10 years ago
This may be a common case of being misguided by the "split in two" options of junk, in "acc settings" and in "options/privacy". 
Bug 352428
Assignee: mscott → nobody
Component: General → Mail Window Front End
Depends on: 352428
QA Contact: general → front-end

Comment 8

10 years ago
may as well dupe
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 352428
You need to log in before you can comment on or make changes to this bug.