Last Comment Bug 376931 - output mediatype patch won't work on branches
: output mediatype patch won't work on branches
Status: RESOLVED FIXED
: fixed1.8.0.12, fixed1.8.1.4
Product: Core Graveyard
Classification: Graveyard
Component: XForms (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: ---
Assigned To: aaronr
: Stephen Pride
Mentors:
https://bugzilla.mozilla.org/attachme...
Depends on:
Blocks: 353738
  Show dependency treegraph
 
Reported: 2007-04-09 12:39 PDT by aaronr
Modified: 2016-07-15 14:46 PDT (History)
1 user (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch (4.31 KB, patch)
2007-04-09 12:39 PDT, aaronr
doronr: review+
Details | Diff | Splinter Review
patch2 (4.31 KB, patch)
2007-04-09 14:12 PDT, aaronr
surkov.alexander: review+
Details | Diff | Splinter Review

Description aaronr 2007-04-09 12:39:54 PDT
Created attachment 261039 [details] [diff] [review]
patch

The current code we have to implement output mediatype in the trunk won't work on the branches.  Per comment in bug 376817, we probably shouldn't change the anonymous content's DOM while the XBL is attaching which is what we are currently doing for output with mediatype.

Testcase to verify the fix is listed in URL and here: https://bugzilla.mozilla.org/attachment.cgi?id=232362

This patch uses a setTimeout call to set the value of the underlying anonymous content.
Comment 1 Doron Rosenberg (IBM) 2007-04-09 14:06:12 PDT
Comment on attachment 261039 [details] [diff] [review]
patch

>+              // FF 1.5 or FF 2.  Wo we'll wait a tick before changing it here.

s/Wo/So when you check in please :)
Comment 2 aaronr 2007-04-09 14:12:27 PDT
Created attachment 261054 [details] [diff] [review]
patch2

fixes Doron's nit
Comment 3 aaronr 2007-04-10 16:35:34 PDT
checked into trunk
Comment 4 aaronr 2007-04-23 16:41:07 PDT
checked into 1.8 branch on 2007-04-12
checked into 1.8.0 branch on 2007-04-16

Note You need to log in before you can comment on or make changes to this bug.