All users were logged out of Bugzilla on October 13th, 2018

Thunderbird 2.0 loses mails upon moving to folders

VERIFIED DUPLICATE of bug 368112

Status

--
critical
VERIFIED DUPLICATE of bug 368112
12 years ago
12 years ago

People

(Reporter: btwl03, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Version 2.0.0.0 (20070326)

Today I had twice the problem that TB 2.0 lost a mail upon moving it
to a folder. The mails simply disappeared from the target folder because
they were lost from the index file. In every case the recreation of the index
made them reappear. But moving the mail to a new target folder reproduced the
problem. Deleting the .msf file and recreating it wouldn't fix the problem. In both cases a mail from GMX.DE with an attachment was involved. After the
mail was lost, it was invisible and couldn't be reached with any search action.

Reproducible: Always

Steps to Reproduce:
1. Mark and move a mail from GMX.de with attachment.
2. Open the target folder to check if the mail is lost.
3. Reindex the target folder to make the mail reappear again.



Don't compress the target folder or you will finally lose the mail!
Fix landed on branch 2 days ago.

Builds from here should have the fix:
<http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-mozilla1.8/>
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 368112
Status: RESOLVED → VERIFIED
(Reporter)

Comment 2

12 years ago
> Fix landed on branch 2 days ago.

Affirmative. Bug fixed.
You need to log in before you can comment on or make changes to this bug.