Closed Bug 368112 Opened 14 years ago Closed 14 years ago

Messages lost when multiple messages moved between local mail folders (not only move/drag&drop but also copy/thru menu)

Categories

(MailNews Core :: Backend, defect)

defect
Not set
critical

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: rich.nott, Assigned: Bienvenu)

References

Details

(Keywords: conversion, dataloss, verified1.8.1.4)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: version 2 beta 2 (20070116)

After selecting several (5+) messages to move from my inbox to a personal folder, I have dragged those messages to the destination folder.  Thunderbird acts as if it is moving the messages (progress bar pulses briefly).  The messages disappear from the inbox.  However, upon opening the destination folder, the messages are not there, nor can they be found using search.  

I have experienced this in several circumstances including moving messages from inbox to a personal folder and moving messages between two personal folders.  It only occurs when moving multiple messages.  

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



I cannot guarantee that it happens everytime, as noted above, but after a couple of repeated events of this bug, I have stopped moving multiple for obvious reasons.

I'm surprised to see that this bug has not yet been reported (that I could find), which suggests something about my own setup is likely to blame.  Any indication as to potential causes of this behaviour (or how I might get my data back) would be very much appreciated.
are these imap or local folders? Have you been running TB for a while before this happens, or does it happen after startup?

You can try doing a Rebuild Index from the folder property dialog of the destination folder...
(In reply to comment #1)
> are these imap or local folders? Have you been running TB for a while before
> this happens, or does it happen after startup?
> 
> You can try doing a Rebuild Index from the folder property dialog of the
> destination folder...
> 

These are all local folders.  
Typically, I've had TB running for a while - cannot confirm at this time if this issue also occurs immediately after start-up.

Rebuilding index does appear to have recovered the lost files, at least in my test case.  I will re-comment if it doesn't fix it in the other directories in which I can recall this having occurred.  Thanks for the tip!
This bug is reproducible (but not 100% of the time) in Thunderbird Beta 2 as well. It also happens if messages are copied as well as if they are moved.

The Rebuild Index option fixes it. Suggestion: can Rebuild Index be transparently run after any move or copy?
More information about what I found: I had a folder called "Orders" with just over 3000 messages. I created subfolders called "2006" and "2007" under which were created further subfolders (one for each month called "01", "02" .. "12"). In the original folder I sorted the messages by date and highlighted and moved blocks of one month into the appropriate subfolder.

In all cases apart from one (2006/02 where there were only 20 email messages) the resultant view of each subfolder displayed between 30 and 35 messages even though, for some months, several hundred messages had been moved.

Until I read this bug thread I thought those messages had been lost forever (except from my backup, of course ;-))
I've had a few users in #thunderbird with (I believe) the same issue, as well as at the forums here http://forums.mozillazine.org/viewtopic.php?t=541234, all using Thunderbird 2.

It looks like it's simply the .msf files can't handle a mass move. So far confirmation is that the messages get moved over, and deleting the corresponding .msf files make the mail reappear. All pop messages.  One user was trying to migrate from OE and even with my help was on the verge of deciding to stay with OE until this was fixed - he imported his OE messages, and they ended up in local folders, as he was moving them to the corresponding folders for the account specific folders he encountered this bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: conversion
This is a dup of a bug filed against 1.5, which I was never able to reproduce.  It only affects drag drop, apparently; using the move/copy menu works fine. So I don't think it really has to do with the .msf file, but something about drag drop is doing something weird and interrupting us before we can add the headers to the .msf file.

In some related bug, someone pointed out that one way to reproduce this is to try to move/copy large messages with drag drop. I was able to reproduce this just now, copying my largest messages (all over 1MB) using drag drop. It might also be a release vs. debug issue, though I hope not...
I think David and I were trying to help track down a similar issue for Jason at one point on the Mac.
(In reply to comment #6)
> It only affects drag drop, apparently; using the move/copy menu works fine. So

I can reproduce the problem using the copy option, not only with the drag and drop. 
What's going on is that someone is closing the destination db out from under the move copy code, so we can't add the headers for the messages copied...I've verified that with an assertion. I'll find out who's closing the db, at least in the case I can reproduce - in general, you shouldn't be closing db's you didn't open. And I'll try to figure out how to recover in general from this happening...
There's some js code closing the destination folder db - I suspect that it's code that's invoked when you move the mouse over the destination folder, which is why at least one reporter said this happens with drag drop...for 2.0, it could be code  that notices there's no new mail for the new mail tooltip - I'm not sure. 

I could just make the msg move code re-open the db - the worrisome thing there is you won't want to re-open the db if we're in the middle of reparsing the folder...

I could cache the open db in the copystate for the move/copy operation...I might try that.
Attached patch proposed fixSplinter Review
This makes the copy state cache the db - I had to override OnAnnouncerGoingAway so that if the db gets forced closed for some reason, we won't hold onto a dangling db in the copy state...
Assignee: mscott → bienvenu
Status: NEW → ASSIGNED
Attachment #262465 - Flags: superreview?(mscott)
Comment on attachment 262465 [details] [diff] [review]
proposed fix

David, this seems like a good candidate for the next stability update for thunderbird if it tests out well on the trunk.
Attachment #262465 - Flags: superreview?(mscott) → superreview+
Nominating for the stability branch for Thunderbird. We'll want to keep an eye on this and see how it tests out on the trunk for folks.
Flags: blocking1.8.1.5?
yes, definitely, we'd want this for the first 2.0x release. I'll land it on the trunk tonight.
fix landed on trunk. If you can, please try a trunk build from tomorrow and see if the problem is fixed for you...
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Duplicate of this bug: 378466
Comment on attachment 262465 [details] [diff] [review]
proposed fix

I'd like to land this on the branch for the first TB 2.0.0.x release...
Attachment #262465 - Flags: approval1.8.1.5?
Hey, can a couple of you who see this problem briefly try out a trunk nightly to verify that the fix works for you?

http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-trunk/
How stable is trunk? I wouldn't feel confident pointing the users I'm helping to a trunk nightly, although a branch nightly would be a different story (unless trunk is pretty much branch at this point for you guys).
The trunk is usable, but I would not point users at it either, other than for the purpose of verifying that this bug is fixed. I hope to get this approved for the branch soon and then point people at the branch nightlies...
Comment on attachment 262465 [details] [diff] [review]
proposed fix

actually, I meant 1.8.1.4 - so I can land this soon.
Attachment #262465 - Flags: approval1.8.1.5? → approval1.8.1.4?
Blocks: 378635
Duplicate of this bug: 369348
Comment on attachment 262465 [details] [diff] [review]
proposed fix

approved for 1.8.1.4, a=dveditz for release-drivers
Attachment #262465 - Flags: approval1.8.1.4? → approval1.8.1.4+
OK, landed on the 2.0 branch - please try tomorrow's 2.0 branch build to see if it's fixed for you...
Keywords: fixed1.8.1.4
Duplicate of this bug: 378838
Duplicate of this bug: 355591
Duplicate of this bug: 378864
verified with TB 2.0.0.4pre  2007042603, following test case of bug 323866 comment 3 (https://bugzilla.mozilla.org/show_bug.cgi?id=323866#c3)
Duplicate of this bug: 379340
Duplicate of this bug: 379447
Duplicate of this bug: 379457
Duplicate of this bug: 379575
Duplicate of this bug: 379816
Is there one possibility to get back the lost mails?
Rebuilding index now doesn't recover the lost files, maybe because I closed TB after the loss of my mails.
(I reported the same problem as Bug 379816.)
(In reply to comment #34)
> Is there one possibility to get back the lost mails?
> Rebuilding index now doesn't recover the lost files, maybe because I closed TB
> after the loss of my mails.
> 

If you compacted the source mail folder (right click on the folder -> Compact) or if you used auto compaction (options -> advanced -> network & disk space -> Compact folders ...), then they are lost.

Otherwise:
1. Close Thunderbird
2. Open the source folder file with a text editor (e.g., Inbox, not Inbox.msf).
3. Search for the messages that got lost
4. Change the number in he X-Mozilla-Status lines to zero:
   "X-Mozilla-Status: 0000"
5. Save the file
6. The next time you open Thunderbird the messages should appear in the source folder.
(In reply to comment #34)
> Is there one possibility to get back the lost mails?
> Rebuilding index now doesn't recover the lost files, maybe because I closed TB
> after the loss of my mails.
> 

Not trying to give contradicting advice here but in my case removing the .msf files did the trick. When you do this, after closing TB, and restart TB again, TB will automatically rebuild the message index including the lost messages. No need to edit any file manually.
Thanks a lot, but nothing works because I used auto compaction.
David, is this really only windows?  (other OSes report problems, like bug 357159)
Keywords: dataloss
no, all
OS: Windows XP → All
Hardware: PC → All
v.fixed with version 2.0.0.4pre (20070504) since I have not been able to lose any messages and based on comment #28.
Duplicate of this bug: 380518
Summary: Messages lost when multiple messages moved between folders → Messages lost when multiple messages moved between local folders
(In reply to comment #6)
> It only affects drag drop, apparently; using the move/copy menu works fine.
Adding "drag&drop" in summary for ease of search when DUPing unwanted bugs.
Summary: Messages lost when multiple messages moved between local folders → Messages lost when multiple messages moved between local folders (By drag&drop, Not thru move menu)
Oh, I missed comment #8. Modifying summary.

By the way, I saw some victims at forums(thread like comment #0 & comment #1) after release of Tb 2.0. Ship Tb 2.0.0.x or 2.0.x with this bug fixed ASAP, please.
Summary: Messages lost when multiple messages moved between local folders (By drag&drop, Not thru move menu) → Messages lost when multiple messages moved between local folders (not only move/drag&drop but also copy/thru menu)
Duplicate of this bug: 380880
It's really annoying having this bug in the 2.0 release.
It's a dataloss when doing first class action.
Does anyone really test thunderbird before it's released?
I can reproduce this bug when moving just one file from inbox to another local folder.
Component: Mail Window Front End → MailNews: Backend
Flags: blocking1.8.1.5?
Product: Thunderbird → Core
Version: unspecified → Trunk
QA Contact: front-end → backend
Duplicate of this bug: 380626
Duplicate of this bug: 380884
Duplicate of this bug: 356043
Duplicate of this bug: 381316
My bug (Bug 381316) was about moving a single (but large) e-mail. It happens always when I move a message from my Received POP3 local folders to any other folder in local folders (I can't test moving through accounts because I only have one conenected to local folders).

After rebuilding I moved a message to some other folder, then moved it again and it was there, but when I moved it twice (always to some other folder) it disappeared again.

Oh. By Large e-mails I mena e-mails with attachements larger then about 5MB.
(In reply to comment #46)
> It's really annoying having this bug in the 2.0 release.
> It's a dataloss when doing first class action.
> Does anyone really test thunderbird before it's released?
> I can reproduce this bug when moving just one file from inbox to another local
> folder.
> 


(In reply to comment #51)
> My bug (Bug 381316) was about moving a single (but large) e-mail. It happens
> always when I move a message from my Received POP3 local folders to any other
> folder in local folders (I can't test moving through accounts because I only
> have one conenected to local folders).
> 
> After rebuilding I moved a message to some other folder, then moved it again
> and it was there, but when I moved it twice (always to some other folder) it
> disappeared again.
> 
> Oh. By Large e-mails I mena e-mails with attachements larger then about 5MB.
> 


--> maybe you don't see it, but the keyword "verified1.8.1.4" and the status Status: RESOLVED FIXED  means this bug is fixed and will be available in TB 2.0.0.4, aka the first update after the 2.0.0.0 release (to match number of firefox) ...
So, if you are hurry to have a fix, use a nighlty build of TB on the branch 1.8.x
here: ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-mozilla1.8
Duplicate of this bug: 382882
Duplicate of this bug: 383072
Duplicate of this bug: 322524
Duplicate of this bug: 383675
Can you please explain what "local" means here? If my mail arrives to the dedicated account and I don't use "Local Folders" - am I safe?

In my Thunderbird's profile:
/Mail/example.com/ <- my e-mail is here
/Mail/Local Folders/ <- not here

I upgraded to 2.0.0.4 and did not notice anything bad before - but I might have missed something.
(In reply to comment #57)
> Can you please explain what "local" means here? If my mail arrives to the
> dedicated account and I don't use "Local Folders" - am I safe?

"local folders" in bug summary is "locally created mail folders"(=not IMAP folder on IMAP server), and it includes folder of POP3 account and folder of pseudo account named "Local Folders".
Changing summary to "local mail folders" to avoid confusion.
 
Summary: Messages lost when multiple messages moved between local folders (not only move/drag&drop but also copy/thru menu) → Messages lost when multiple messages moved between local mail folders (not only move/drag&drop but also copy/thru menu)
Duplicate of this bug: 364504
(In reply to comment #57)
> Can you please explain what "local" means here? If my mail arrives to the
> dedicated account and I don't use "Local Folders" - am I safe?

If you want to check just send yourself an e-mail containing some big attachment (5MB to be sure, but this happened with smaller ones). Leave it as unread and then move around folders. If it won't get lost then you are safe, but AFAIK 2.0.0.4 fixed this issue.

BTW: Thanks to the test team for speeding things up :).
As mentioned in my bug 364504 which was previously duped to this one, a user has seen this bug with version 2.0.0.4. So it could not be definitely fixed. I ask for more information.
(In reply to comment #61)
> As mentioned in my bug 364504 which was previously duped to this one, a user
> has seen this bug with version 2.0.0.4. So it could not be definitely fixed. I
> ask for more information.

I've just tested this with more then 5MB attachment (moved this a lot with drag&drop) and it was never lost. Then I did the same with 10 files with big document attached to each (~250KB) and still wasn't able to reproduce this in 2.0.0.4 (Win XP Pro, 1GB RAM, ~1.5GHz).
Duplicate of this bug: 385568
Just a follow-up, because it really, really sucks that this was shipped in 2.0.0.0 as a known issue without a notice (on all versions) about the risk.  Data loss is a big deal.  I was able to find my critical blanked-out e-mail embedded in a reply, but my sympathy to people in the "if you compacted the folder" (isn't this default or at least encouraged?) you're screwed category.
version 2.0.0.4 (20070604)

Using the gmailUI shortcuts for moving messages to the archive, and then undoing through the menu system (after all visible signs of processing, the spinning wheel in upper left corner in particicular, had stopped) resulted in e-mail being corrupted.

Two e-mails next to each other took on the name of the sender of the e-mail that had been sent to the local archive folder and undone, and took on the body of the other e-mail.

Again, lost data is bad.  Here's hoping 2.0.0.5 ...
Duplicate of this bug: 384386
Hello,

I'm running TB version 2.0.0.6, using IMAP, and I am having a problem which looks like this one.

Thunderbird notifies me about recently received mail, my message filters move the mail to their respectful destinations, the mailbox names are displayed in bold and the number in parenthesis next to the mailbox name denotes an accurate amount of new messages.  However, when I select the mailbox to view its contents, the new messages do not appear in the list.

It is possible to recover the mail by rebuilding the index of the mailbox.  Naturally, I would like to avoid having to do that every time.  The problem is intermittent.  I stated noticing it two weeks ago.

Thank You,
huit
hi
i managed to lose some mail last week. I dragged a couple of messages from my imap inbox to a local folder and they diappeared. tried logging into webmail to check inbox. tried dragging back the messages to the inbox. have tried deleting hte .msf files, and going through and chaning the x status to 0000. I havent compacte d the folders and they still sit there in thunderbird as blank messages. the inbox file is too big to text edit in word pad so am about to try and check thru the inbox for the body of the emails using firefox. I did manage to find a couple of long lost messages in abnother folder using text edit, but couldnt get them to resurrect as messages.
I am not a programmer so its all a bit scary to be playing around inside the folders. I do think that a warning somewhere to use copy rather than drag drop would be useful, as its v annoying to lose important work docs and invoices...
constance - What version of Thunderbird are you using, as this is supposed to have been fixed for a while.

As for getting the mail back if you're using Thunderbird 2 you need to change the other x status, I know there are instructions already on forums.mozillazine.org but feel free to start your own thread there, if you need more help.
hi
when you say change the other x status do you mean when I can see the four digit number twice ie on the second and fifth lines is has x status 0001 i should make both 0000?
I am using version 2.0.0.9 on a sony vaio using windows XP home 5.1
I havent tried to duplicate the error again
I have spent some time going thru changing the x status but notice that sometimes there is just a header showing the From line, then the two lines showing the X status and then no list of headers or body of message. 
Presumably the message is still in my Iamap in box. I tried looking through the offline version of the imap inbox but as I hadnt compacted it for ages it was 800M (oops!) so crashed anything that I tried to use as a text editor (fireofox just couldnt quite cope either). I have copied this offline folder and now compacted my inbox in case it happens again. I have sort of given up now on retrieving anything lost. But if you can tell me how to scan the huge text file that may be useful
Constance, please have a look at the following page. There you can find all information about the mozilla-status and x-mozilla-status:
http://www.eyrich-net.org/mozilla/X-Mozilla-Status.html?en

You can also use NoteTab Light to edit your huge inbox file:
http://www.notetab.com/ntl.php
I'm using Thunderbird 2.0.0.12 and having severe problems copying mail from local and POP3 folders to a new IMAP account and folders--I don't believe this bug is actually fixed.

I have experienced the problem when moving groups (> 1 message) but never individual messages. The problem happens no matter if I use drag and drop, or the copy/move commands on the menus.

(My mail server is run by dreamhost.com)

Uploading entire folders via the mbox to imap upload feature in IMAPSize doesn't seem to generate any messages with blank headers, but doesn't always get all messages uploaded (58 out of 82 in one test).

Could this be a bug in how Thunderbird is formatting its mbox files, instead of how it uploads them to IMAP folders, and the problem is that Thunderbird can deal with the problem when displaying messages locally?
(In reply to comment #72)
> I'm using Thunderbird 2.0.0.12
> (snip) copying mail from local and POP3 folders to a new IMAP account
> (snip) but doesn't always get all messages uploaded (58 out of 82 in one test).

To Peter K. Sheerin:  
Your problem sounds to be IMAP only problem, and sounds to be similar situation to Bug 424319 (problem when copy of POP3 mails to IMAP folder by message filter, an the problem is re-produced by manual move of several messages).
This bug is not for IMAP unique issue, although external phenomenon due to "something wrong in multiple mail copy/move" is common.
Read thru Bug 424319 and Get IMAP protocol log(with timestamp if you are MS Win user). And, if same problem as or similar problem to Bug 424319, and if Tb's fault is found by log, add comment to Bug 424319 with attaching protocol log, please. 
Seemingly, Bug 42319 has nothing to do with indexing issues resulting from moving multiple messages.  I have been experiencing the problem described by this bug, and Bug 379039, which could be a duplicate, up until some weeks ago.  Perhaps the last update included a fix.  Time will tell.
I meant Bug 424319 not 42319
(In reply to comment #75)
I meant Bug 423419 (sorry for my mis-type). Bug 423419 looks to be a variation of situation/phenomenon of Bug 379039. Thanks for pointing it.

No worries.  I agree.  I hope this gets fixed soon.  There seems to be many bugs with similar symptoms.

bug 385555
bug 391692
bug 379039
bug 306736
bug 328872
bug 216442

It seems like all have to do with the index (destination mailbox index) being fudged up during a move operation.  The move is often the result of a filter trigger (when checking for new mail).
Product: Core → MailNews Core
Recently I decided to split up a master folder containing subfolders by creating a new master folder and moving some of the subfolders to it. The next day (after closing Thunderbird and re-opening it), I found *all* the messages in all the subfolders in both master folders gone.
I tried "rebuilding" as the Thunderbird help suggests, but no effect. I tried deleting the .msf files, but no effect. I tried opening the subfolder file using a text editor but it just opened as empty.
I'm running Thunderbird 2.0.0.17 under Windows Vista.
Hi,

are people seeing blank emails when they do mass moves? I moved a large number of files from the host to a local drive, and now see a list of blank emails (no to/from information, subject, attachments or body) with a "Date" value equal to the time that the emails were transferred. This is a massive problem as I need to access the information contained within the emails, it was done using a drag and drop.

I have tried to rebuild the index, and it simply reproduces the problem, I have also looked at the files retained in the profile, they simply contain 
"
From - Sun Nov 29 22:22:12 2009
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00000000
"

repeated over and over again (with the date changing slightly, this is the time of the transfer). I havent deleted the .msf file, would this help?

These were Sent Items.

Is there *any* way of recovering this information?! I desperately need it.
Your problem seems different. This bug is about moving the messages between Thunderbird folders not hard-drive folders.

For information about moving profiles see:
http://www.mozilla.org/support/thunderbird/profile
Or:
http://kb.mozillazine.org/Moving_your_profile_folder

If you want to move specific folders try this:
http://kb.mozillazine.org/Importing_folders

Simply coping folders on your HDD is not a good idea and an problems that result from this are not bugs in TB.
I don't think this is fixed - I'm having the same problem in TB 3.0.

I am using TB3 on Vista Pro 32bit with SP2. The IMAP accounts are (1) Google Apps, and (2) a Cyrus server at fastmail.fm.

If I select a large number of e-mails from account #1 and copy them to account #2, some get silently dropped. The results are not consistent: the number of messages that get dropped changes each time (even when I am copying the same block of messages). There is no logic or consistency to the messages that get dropped.

The activity manager reports the correct number of messages as having been copied. There is no indication of any errors in the error console or the activity manager.
(In reply to comment #81)
> The IMAP accounts are (1) Google Apps, and (2) a Cyrus server at fastmail.fm.

As written in bug summary, this bug is for "move/copy/drag&drop between local mail folders", i.e. for most basic case. Read Comment #58, Comment #73, please.
Whoops.  Sorry.
This has certainly not been fixed. I can reproduce the bug every time when moving a collapsed thread of messages from one imap folder to another.  This is essentially moving multiple messages.
(In reply to comment #84)
> This has certainly not been fixed. I can reproduce the bug every time when
> moving a collapsed thread of messages from one imap folder to another.  This is
> essentially moving multiple messages.

Please raise a new bug including which specific version of Thunderbird you are using (available from Help -> About).

The subject of this bug clearly talks about *local* folders and so even if your case is related, it should still be handled in a separate bug. Comments on closed/resolved bugs may get missed.
Hi-
Does this bug show up when filters automatically move email from IMAP folders to local folders? 
I was recently forced to move from POP to IMAP. To be able to continue using and storing my emails locally, I have a setup where filters automatically move emails to local folders. The setup is a bit complicated. I have hundreds of filters some run upon reception of emails, others I run manually on more important emails. But the problem only shows up with two mailboxes that I use as an intermediate step for either very important emails (addressed to me, or cc:Ed to me, or otherwise filtered as important), and emails which fail all classification fall in the second mailbox.
I routinely (a dozen times a day, but not consistently), get into a situation where I find dozens of empty emails (no subject, no information, even with Ctrl-U), and these emails increase in number by the second, until I close thunderbird. I open it up in offline mode, delete the emails, then the operations continue correctly.
This is driving me crazy....  I can't explain this bug/problem. 
I am two steps from moving to Outlook (two steps because I tried it and hate it), but at least it doesn't have such bugs.
(In reply to Jake from comment #84)
> This has certainly not been fixed. I can reproduce the bug every time when
> moving a collapsed thread of messages from one imap folder to another.  This
> is essentially moving multiple messages.

(In reply to Mark Banner (:standard8) from comment #85)
> (In reply to comment #84)
> > This has certainly not been fixed. I can reproduce the bug every time when
> > moving a collapsed thread of messages from one imap folder to another.  This is
> > essentially moving multiple messages.
> 
> Please raise a new bug including which specific version of Thunderbird you
> are using (available from Help -> About).
> 
> The subject of this bug clearly talks about *local* folders and so even if
> your case is related, it should still be handled in a separate bug. Comments
> on closed/resolved bugs may get missed.

Jake, did you ever open a new bug? What was the outcome?

(cleaning out old emails)
(In reply to Worcester12345 from comment #87)
> Jake, did you ever open a new bug? What was the outcome?
> 
> (cleaning out old emails)

I did it was bug: 552928 which has now also been resolved.

Thanks

I can confirm that this is not fixed. I'm trying to help a user move a huge account, and I can't even reliably move a few hundred emails at a time. This is a MAJOR issue.

You need to log in before you can comment on or make changes to this bug.