Tools --> Options window opens with vertical size dependent on previous display

VERIFIED FIXED

Status

--
minor
VERIFIED FIXED
12 years ago
12 years ago

People

(Reporter: tholen, Assigned: mozilla)

Tracking

({verified1.8.1.5})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.8.1) Gecko/20061025 Firefox/2.0
Build Identifier: version 1.5 (20060113)

This problem is probably related to bug 368960, but I succeeded in noticing a pattern in the faulty behavior.  When you open the Tools --> Options window, the vertical size of that window depends on the amount of displayed material when that window was last closed.  The very first time the window is opened, the default size is insufficient to display fully the contents of the Display and Composition tabs.  For example, select the Attachments tab (which has the least amount of content) and then close the window.  Reopen it, and the vertical size of the window is sufficient to display the content of the Attachments tab, but insufficient to display the content of the Display or Composition tabs.  Select the Display tab (which has the most content) and then close the window.  Reopen it, and the vertical size of the window is now sufficient to display the content of every tab.

Reproducible: Always

Steps to Reproduce:
1.  Select Tools --> Options --> Attachments.
2.  Close window.
3.  Select Tools --> Options --> Display.
4.  Note how the window is too small in the vertical direction to display content.
Actual Results:  
Vertical size of the window is too small to show the "HTML Messages" portion of the Display tab.

Expected Results:  
Should show the HTML Messages portion of the tab.

This problem was first noticed in version 2.0 of Thunderbird, but I have since verified that it also occurs with version 1.5 (both OS/2 builds).
(Assignee)

Comment 1

12 years ago
Yes, this is quite a "popular" bug. Thanks David for opening the bug report.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

12 years ago
This does what all other toolkit apps do for OS/2: use the same window size for the options dialog as Windows (and the same title). The same patch works on branch and trunk.
Assignee: mscott → mozilla
Status: NEW → ASSIGNED
Attachment #263352 - Flags: superreview?(mscott)
Attachment #263352 - Flags: review?(mozilla)
Comment on attachment 263352 [details] [diff] [review]
Use fixed options window size

r=mkaply
I'll give the sr as well since this is OS/2 specific. Obviously we want this in the next Thunderbird 2 update?
Attachment #263352 - Flags: superreview?(mscott)
Attachment #263352 - Flags: superreview+
Attachment #263352 - Flags: review?(mozilla)
Attachment #263352 - Flags: review+

Comment 4

12 years ago
Comment on attachment 263352 [details] [diff] [review]
Use fixed options window size

per mkaply's last comment.
Attachment #263352 - Flags: approval1.8.1.5?
(Assignee)

Comment 5

12 years ago
OK, fix checked into trunk.

Yes, if nothing bad shows up in the tinderboxes now, we should definitely get it into branch, too. Pity that we just missed 1.8.1.4...
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Comment on attachment 263352 [details] [diff] [review]
Use fixed options window size

approved for 1.8.1.5, a=dveditz for release-drivers
Attachment #263352 - Flags: approval1.8.1.5? → approval1.8.1.5+
(Assignee)

Updated

12 years ago
Keywords: fixed1.8.1.5
(Assignee)

Comment 7

12 years ago
Verified as fixed with TB nightlies
   version 2.0.0.5pre (20070630)
for branch and
   version 3.0a1pre (20070629)
for trunk. While the window is now a bit large for some configurations at least it fits the content of all tabs, even for quite large font sizes.
Status: RESOLVED → VERIFIED
Keywords: fixed1.8.1.5 → verified1.8.1.5
You need to log in before you can comment on or make changes to this bug.