Rules don't work on incoming mail

RESOLVED DUPLICATE of bug 355537

Status

RESOLVED DUPLICATE of bug 355537
12 years ago
12 years ago

People

(Reporter: ezra, Assigned: mscott)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Versie 2.0.0.0 (20070326)

I've had this problem since I installed Thunderbird 2, never had any problems with it on 1.5.

I have a set of rules for my different mail accounts set in the Local Folder.
I set the rules to Label my mails based on the account keys.

But now I installed Thunderbird 2 and the rules don't work anymore when the mails come in. Only when I press the button manually to filter the folder.

Reproducible: Always

Steps to Reproduce:
1. Set a Rule in the Local Folders folder.
2. Download New Mail
3.
Actual Results:  
The Rules were not working.

Expected Results:  
The Rules should have labelled my mails when they were downloaded as they did in Thunderbird 1.5 and lower.
(Reporter)

Updated

12 years ago
Version: unspecified → 2.0
Exactly what filter criteria do you use? 
(Reporter)

Comment 2

12 years ago
If X-Account-Key = accountN then Label the Message with label Y, where N should be replaced by the corresponding number of the account and Y the label for that account.

And it works when I manually press the button to apply filters on the folder, but not when the emails are downloaded.
Ahh, bug 355537. Fixed in the nightly builds...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 355537
(Reporter)

Comment 4

12 years ago
Ah, good to hear, sorry about the duplicate, I searched but couldn't find anything about it. I'm using a localized build, so I didn't exactly know the name of the features.

Awaiting for the stable build :-)
You need to log in before you can comment on or make changes to this bug.