crash on startup on RedHat 8 with Gdk-WARNING **: gdkdrawable-x11.c:787 drawable is not a pixmap or window

VERIFIED DUPLICATE of bug 296298

Status

Core Graveyard
GFX: Gtk
--
critical
VERIFIED DUPLICATE of bug 296298
11 years ago
10 years ago

People

(Reporter: JskudMozilla, Unassigned)

Tracking

({crash})

1.8 Branch
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: http://mozilla.mirrors.easynews.com/mozilla/firefox/releases/2.0.0.3/linux-i686/en-US/firefox-2.0.0.3.tar.gz

New installation of Firefox-2.0.0.3 on a RedHat 8 linux box. Crashes on invocation, with this message (Gecko:25461): Gdk-WARNING **: gdkdrawable-x11.c:787 drawable is not a pixmap or window /opt/firefox/run-mozilla.sh: line 424: 25461 Segmentation fault

Reproducible: Always

Steps to Reproduce:
1. untar firefox into /opt
2. invoke /opt/firefox/firefox
3.
Actual Results:  
(Gecko:25461): Gdk-WARNING **: gdkdrawable-x11.c:787 drawable is not a pixmap or window /opt/firefox/run-mozilla.sh: line 424: 25461 Segmentation fault

Expected Results:  
wanted Firefox to come up

See also bug 324264 (same bug for firefox 1.5), 
and talkback TB 31 67 24 60 Y (crash feedback from firefox 2.0.0.1).

Again, this seems to be specific to RedHat 8 installations.  Due to customization, it is difficult for me to upgrade my box to a new release.
But the box is up to date.

FYI, firefox version 1.0 Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0, works just fine.

FYI, I also tried running this from a brand new user (so there were no data migration issues), and it still crashed.

Comment 1

11 years ago
TB31672460

Stack Signature	 libX11.so.6 + 0x1e8cd (0x405f28cd) 23dd4079
Product ID	Firefox2
Build ID	2006120814
Trigger Time	2007-04-30 06:35:17.0
Platform	LinuxIntel
Operating System	Linux 2.4.20-28.8
Module	libX11.so.6 + (0001e8cd)
URL visited	
User Comments	New installation of firefox-2.0.0.1 on a RedHat 8 linux box. Crashes on invocation, with this message (Gecko:25461): Gdk-WARNING **: gdkdrawable-x11.c:787 drawable is not a pixmap or window /opt/firefox/run-mozilla.sh: line 424: 25461 Segmentation fault
Since Last Crash	0 sec
Total Uptime	0 sec
Trigger Reason	SIGSEGV: Segmentation Fault: (signal 11)
Source File, Line No.	N/A
Stack Trace 	
libX11.so.6 + 0x1e8cd (0x405f28cd)
nsImageGTK::CreateOffscreenPixmap()
nsImageGTK::UpdateCachedImage()  [mozilla/gfx/src/gtk/nsImageGTK.cpp, line 458]
nsImageGTK::Optimize()  [mozilla/gfx/src/gtk/nsImageGTK.cpp, line 1932]
gfxImageFrame::SetMutable()  [mozilla/gfx/src/shared/gfxImageFrame.cpp, line 848]
imgContainerGIF::DecodingComplete()  [mozilla/modules/libpr0n/decoders/gif/imgContainerGIF.cpp, line 169]
nsGIFDecoder2::EndGIF()  [mozilla/modules/libpr0n/decoders/gif/nsGIFDecoder2.cpp, line 318]
gif_write()  [mozilla/modules/libpr0n/decoders/gif/GIF2.cpp, line 980]
nsGIFDecoder2::ProcessData()  [mozilla/modules/libpr0n/decoders/gif/nsGIFDecoder2.cpp, line 231]
ReadDataOut()  [mozilla/modules/libpr0n/decoders/gif/nsGIFDecoder2.cpp, line 173]
nsPipeInputStream::ReadSegments()  [mozilla/xpcom/io/nsPipe3.cpp, line 765]
nsGIFDecoder2::WriteFrom()  [mozilla/modules/libpr0n/decoders/gif/nsGIFDecoder2.cpp, line 255]
imgRequest::OnDataAvailable()  [mozilla/modules/libpr0n/src/imgRequest.cpp, line 899]
ProxyListener::OnDataAvailable()  [mozilla/modules/libpr0n/src/imgLoader.cpp, line 891]
nsJARChannel::OnDataAvailable()  [mozilla/modules/libjar/nsJARChannel.cpp, line 848]
nsInputStreamPump::OnStateTransfer()  [mozilla/netwerk/base/src/nsInputStreamPump.cpp, line 497]
nsInputStreamPump::OnInputStreamReady()  [mozilla/netwerk/base/src/nsInputStreamPump.cpp, line 398]
nsInputStreamReadyEvent::EventHandler()
PL_HandleEvent()  [mozilla/xpcom/threads/plevent.c, line 689]
PL_ProcessPendingEvents()  [mozilla/xpcom/threads/plevent.c, line 623]
nsEventQueueImpl::ProcessPendingEvents()  [mozilla/xpcom/threads/nsEventQueue.cpp, line 421]
event_processor_callback()  [mozilla/widget/src/gtk2/nsAppShell.cpp, line 67]
libglib-2.0.so.0 + 0x4542f (0x405ae42f)
libglib-2.0.so.0 + 0x23f65 (0x4058cf65)
libglib-2.0.so.0 + 0x24f98 (0x4058df98)
libglib-2.0.so.0 + 0x252ad (0x4058e2ad)
libglib-2.0.so.0 + 0x25a1f (0x4058ea1f)
libgtk-x11-2.0.so.0 + 0xd139f (0x402c639f)
nsAppShell::Run()  [mozilla/widget/src/gtk2/nsAppShell.cpp, line 141]
nsAppStartup::Run()  [mozilla/toolkit/components/startup/src/nsAppStartup.cpp, line 152]
XRE_main()  [mozilla/toolkit/xre/nsAppRunner.cpp, line 2446]
main()  [mozilla/browser/app/nsBrowserApp.cpp, line 62]
libc.so.6 + 0x15967 (0x42015967)
Status: UNCONFIRMED → NEW
Component: General → GFX: Gtk
Ever confirmed: true
Keywords: crash
Product: Firefox → Core
QA Contact: general → gtk
Version: unspecified → 1.8 Branch

Comment 2

11 years ago
Same stack as bug 187029.

Does the crash also occur with Firefox 3.0a4?
http://releases.mozilla.org/pub/mozilla.org/firefox/releases/granparadiso/alpha4/
(Reporter)

Comment 3

11 years ago
Yes, it fails in the same way with Firefox 3.0a4.
TB31721318Z should be there now.

Comment 4

11 years ago
Stack Signature	 _cairo_xlib_screen_from_visual() 50f212cf
Product ID	FirefoxTrunk
Build ID	2007042705
Trigger Time	2007-05-01 18:08:33.0
Platform	LinuxIntel
Operating System	Linux 2.4.20-28.8
Module	firefox-bin + (0078413c)
URL visited	
User Comments	initial invocation after install of Firefox 3.0.a4, with immediate crash (just like bug 379358). messages in console follow. (Gecko:30205): Gdk-WARNING **: gdkdrawable-x11.c:787 drawable is not a pixmap or window ./run-mozilla.sh: line 451: 379358
Since Last Crash	0 sec
Total Uptime	0 sec
Trigger Reason	SIGSEGV: Segmentation Fault: (signal 11)
Source File, Line No.	/builds/tinderbox/Fx-Mozilla1.9-Release/Linux_2.4.21-32.0.1.EL_Depend/mozilla/gfx/cairo/cairo/src/cairo-xlib-surface.c, line 1918
Stack Trace 	
_cairo_xlib_screen_from_visual()  [mozilla/gfx/cairo/cairo/src/cairo-xlib-surface.c, line 1918]
_moz_cairo_xlib_surface_create()  [mozilla/gfx/cairo/cairo/src/cairo-xlib-surface.c, line 1961]
gfxXlibSurface::gfxXlibSurface()  [mozilla/gfx/thebes/src/gfxXlibSurface.cpp, line 66]
nsWindow::GetThebesSurface()  [mozilla/widget/src/gtk2/nsWindow.cpp, line 53]
nsThebesDeviceContext::CreateRenderingContext()  [mozilla/gfx/src/thebes/nsThebesDeviceContext.cpp, line 979]
PresShell::CreateRenderingContext()  [mozilla/layout/base/nsPresShell.cpp, line 3497]
PresShell::InitialReflow()  [mozilla/layout/base/nsPresShell.cpp, line 2559]
... etc ...

Comment 5

11 years ago
Please run "xdpyinfo > file" in a shell and upload the file using the
"Add an attachment" link on the bug report. Thanks.
(Reporter)

Comment 6

11 years ago
Created attachment 263438 [details]
xdpyinfo for the failing display

As requested, here's the xdpyinfo output for the failing display.

Comment 7

11 years ago
System is RedHat 8, XFree86 version: 4.2.1
Error message gdkdrawable-x11.c:787 then crash... this is bug 296298 -
which is resolved wontfix.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 296298
(Reporter)

Comment 8

11 years ago
The requirements on the Firefox 2 download page, http://www.mozilla.com/en-US/firefox/system-requirements.html state

Linux kernel 2.2.14 (with glibc 2.3.2, XFree86-3.3.6, gtk+2.0, fontconfig/xft and libstdc++5)

I'm running

kernel 2.4.20
glibc-2.3.2
XFree86-4.2.1
gtk2-2.0.6
fontconfig-2.0
libstdc++-3.2

Admittedly, I inferred that requirement gtk+2.0 is met by pkg gtk2-2.0.6, and that requirement libstdc++5 is met by libstdc++-3.2.  If that's so, then the system meets the requirements.  But Firefox is not supported on such a Red Hat 8 system.  So, the system requirements for Firefox may need to be changed.

Comment 9

11 years ago
when a bug is resolved as a duplicate of another bug, you have to read the other bug to understand what's going on, in this case, bug 296298 comment 21 is probably sufficient.

> Admittedly, I inferred ... that requirement libstdc++5 is met by libstdc++-3.2.  

That was a bad inference, we explicitly moved the requirements because we do *not* support rh8. I'm sorry. (I don't like it any more than you do, but that's life.)

Your choices are:
1. try to find a firefox built for your platform (probably by some vendor that supports your platform - not mozilla.org)
2. try to build yourself
3. try to frankenupdate your platform
4. replace your platform
5. use something that does support your platform

again, i'm very sorry.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 10

11 years ago
> > Admittedly, I inferred ... that requirement libstdc++5 is met by libstdc++-3.2.  

> That was a bad inference, we explicitly moved the requirements ...

Thank you very much for the gentle followup.  I'm not sure that was a bad inference.  I'm not sure what libstdc++5 (as opposed to libstdc++-5) really is.  On my working RH9 box, I'm running libstdc++-3.2.2-5, and on my working CentOS4 box, I'm running libstdc++-3.4.6-3.1.  On my failing RH8 box, it's libstdc++-3.2-7.    Since there's no libstdc++5 installed on up to date and supported platforms, and they are using libstdc++-3.2 or better on both of them, that still seems like a reasonable inference.  

So, maybe the right question should be, what's the libstdc++5 requirement, really?

Again, thanks for an excellent tool, and generous support.  /Jskud
(Assignee)

Updated

10 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.