If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

thunderbird body/full text search is painfully slow

RESOLVED DUPLICATE of bug 383895

Status

MailNews Core
Search
--
minor
RESOLVED DUPLICATE of bug 383895
11 years ago
8 years ago

People

(Reporter: Daniel, Unassigned)

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: version 1.5.0.10 (20070221)

when two details for searching are entered (match ALL):
1) email address is xxx@xxx.com
2) body contains "phone"

it is soooo slow, even after 5(!!!) minutes, only few old emails are shown and still searching

Reproducible: Always

Steps to Reproduce:
1. open search
2. continue as in description (for known address)
3. sloooooow search
Actual Results:  
sloooow search

Expected Results:  
show emails that fit in few seconds (anything more than 20 seconds is unreasonable) - use indexing, if required!
(Reporter)

Updated

11 years ago
Version: unspecified → 1.5

Updated

10 years ago
Assignee: mscott → nobody
OS: Linux → All
Hardware: PC → All
Summary: thunderbird search is painfully slow → thunderbird body/full text search is painfully slow
Version: 1.5 → unspecified

Updated

10 years ago
Duplicate of this bug: 412804

Comment 2

10 years ago
seams similar to bug 312282 (same linux v1.5)
and related to bug 383895 which is tb v2
Component: General → Mail Window Front End
OS: All → Linux
QA Contact: general → front-end
Version: unspecified → 1.5
Component: Mail Window Front End → Search
Keywords: perf
Product: Thunderbird → MailNews Core
QA Contact: front-end → search
Version: 1.5 → unspecified

Comment 3

9 years ago
There's also bug 281073, but that might be specific to IMAP.
gloda, which provides for full-text search, will be exposed to the UI in a quick-search style manner in bug 474701.  However, gloda search when that bug is resolved will not do anything to speed up the existing search dialog.  (The semantics of those search rules don't map fully onto gloda, although I would expect that most common searches would map.  For example, this bug's example maps without problem.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 383895
You need to log in before you can comment on or make changes to this bug.