firefox intermittently freezes and becomes more often unresponsive (spinning beach ball) since the last update

RESOLVED DUPLICATE of bug 353962

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 353962
11 years ago
11 years ago

People

(Reporter: David Davis, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

It doesn't matter what web site I'm on, the problem is the same. At intermittent times, FireFox will just freeze. Links and buttons do not work. FireFox is unresponsive. Sometimes, it's just going reeeeeeaaaaaallllllll slow. But most of the time, it's locked up and I must force quit the program from OSX. This occurs regularly, sometimes blowing me out of an online task, test, or long letter/email etc. that is completely lost. Sometimes, when FireFox is reopened, I will click "restore session" but get an empty window....in other words, it doesn't take me back to EXACTLY what I was doing before it crashed. 

P.S. I got a good chuckle out of the "bad example" below....ha ha. You guys don't suck. FireFox is rad!

Reproducible: Sometimes

Steps to Reproduce:
1.Open FireFox
2.Perhaps two or three tabs
3.Surf the internet
Actual Results:  
It comes and it goes....it's not doing it at the moment, but did do it this morning, and will do it again before the day is through.

Expected Results:  
Not freeze. Work normally
I don't have a Mac so I can't test this, but as I can't imagine that everyone with Firefox 2.x on a Mac experiences these problems, please read this: http://kb.mozillazine.org/Firefox_hangs

Comment 2

11 years ago
> It doesn't matter what web site I'm on

Then that could mean a problem with your system; e.g. a defective memory chip.

> , the problem is the same. At
> intermittent times, FireFox will just freeze. Links and buttons do not work.

This kind of external signs suggest a very demanding task occuring. I experience links and buttons not working when starting up of Adobe Acrobat Reader, fetching of a .pdf file.

> FireFox is unresponsive. Sometimes, it's just going reeeeeeaaaaaallllllll slow.

Would you say your system resources are modest, average or above average in today's world? Can you give your cpu, RAM and video memory conditions? On your Mac, do you have a cpu monitor of some sort to see how the cpu behaves and which application(s) is(are) demanding so much cpu and using a lot of RAM? Do you notice virtual memory (disk swapping) occuring?

When that happens, for how long approx. was the Firefox application opened?

> But most of the time, it's locked up and I must force quit the program from
> OSX. 

Do you have other applications running when that happens? Are you, for example, doing a "silent download" (knowingly)? Do you often clear your memory cache and disk cache (also sometimes known as temporary internet files)?

> This occurs regularly, 

Then this is strange. Are there any common denominator when that happens? Say, the webpages have Flash.

> sometimes blowing me out of an online task, test,
> or long letter/email etc. that is completely lost. Sometimes, when FireFox is
> reopened, I will click "restore session" but get an empty window....in other
> words, it doesn't take me back to EXACTLY what I was doing before it crashed. 

This is what makes me suspect you may be having a memory chip defect of some kind... Who knows, you could even have viruses or an active trojan (key logger) or spyware in action when your resources are reducing.

> Reproducible: Sometimes

If other Mac users like yourself do not experience such problem, even if they have modest system resources, then the problem may be related to your system vs operating system itself.

I don't use a Mac but I've given you several questions to examine: you are the nr 1 person that can get this issue identified or even fixed.

Regards, Gérard

Comment 3

11 years ago
I use 2 macs, both laptops, and this occurs exactly as described ONLY on my 

15" macbook 10.4.10 

but not at all on my 12" powerbook working on version 10.3.9   

I can not predict when this will happen.
It happened about 5 times out of about 200 transitions today and I needed to force quit Firefox 

I don't know enough about fixing  bugs so I can't help..
Ken ANderson

Comment 4

11 years ago
> I use 2 macs, both laptops, and this occurs exactly as described ONLY on my 
> 
> 15" macbook 10.4.10 

Then what makes you believe that there is a bug with Firefox? You are posting in mozilla's bugzilla regarding a bug with Firefox. Bugzilla is primarly for reporting, filing, confirming, fixing bugs in Mozilla softwares: Bugzilla is not like an user-to-user support forum.

> but not at all on my 12" powerbook working on version 10.3.9   
> 
> I can not predict when this will happen.
> It happened about 5 times out of about 200 transitions today 

Transitions? I do not know what you are talking about.

> and I needed to
> force quit Firefox 
> 
> I don't know enough about fixing  bugs so I can't help..
> Ken ANderson


Ken, please consult
http://kb.mozillazine.org/Firefox_hangs
You may also try the mozillazine forums for support:
http://www.mozillazine.org/
I have had the exact same issue in 10.4.10 & 10.4.11. This issue has existed since I brought my Macbook 13.3 2ghz duo core 2 in late September.

I'll investigate further and see what other factors could be causing the issues. Doesn't sound like a firefox bug as more users would be reporting it. Prob another application that is interfering.

David, have you noticed any recurring themes when firefox crashes? I did install the facebook toolbar. I'm going to uninstall it and see if firefox hangs again.

Comment 6

11 years ago
Ken and Jonathan,

Is the problem still occuring if you use safe mode?
http://kb.mozillazine.org/Safe_Mode

Do you have Google Toolbar installed? Can you try surfing with and then without the Google toolbar? 

There are other bugs (bug 375727, bug 371863, bug 351420) which have some of the same external signs (application hang, Macbook) and which could be resolved as DUPLICATES. We need a clear way to reproduce the problem and then investigate it. 

This bug could be a DUPLICATE of bug 353962 too.

Comment 7

11 years ago
Hello all,

After carefully reading bug 375727, bug 371863, bug 351420 and bug 381212, I am resolving these as DUPLICATE bugs of bug 353962. From what I read in all 4 mentioned bug reports, their summary, description and external signs 
- hangs, 
- "frozen application", 
- spinning ball cursor, 
- weak stability, 
- revision version of Firefox involved clearly suggesting a regression, 
- impromptus/random occurences of hung application, 
- Machine Model: MacBookPro, 
- 2 have google search toolbar, 
- OS being OS X 10.4.x
all concur and convincingly lead me to resolve these as a DUPLICATE of bug 353962. If you strongly believe that this is a serious mistake, then you may REOPEN the bug by providing reasons, explanations, details as to why your bug should not have been resolved as a duplicate of bug 353962.

Thank you, Gérard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Summary: firefox freezes and is unresponsive, links don't work, buttons don't work, which causes me to force quit since the last update. spinning beach ball of death... → firefox intermittently freezes and becomes more often unresponsive (spinning beach ball) since the last update
Duplicate of bug: 353962
You need to log in before you can comment on or make changes to this bug.