If page offers a broken Feed, Firefox does not display an error message to the user.

VERIFIED DUPLICATE of bug 350365

Status

()

Firefox
RSS Discovery and Preview
VERIFIED DUPLICATE of bug 350365
11 years ago
9 years ago

People

(Reporter: sendmail.to, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

Open the Feed as in the URL. (I will attach a testcase soon).

Nothing is displayed -> because the Feed is broken.

We should offer an error message.
We already do this, but with a little mistake.
Below I post something from the page preview (it's from the German Firefox)
<div id="feedError" style="display: none;" dir="ltr">
      <h1>Fehler beim Verarbeiten des Feeds</h1>
      <p>Beim verarbeiten des Feeds ist ein Fehler in der Anwendung aufgetreten. Sie können den Feed trotzdem abonnieren, Falls Sie wissen, was er ist. Der Fehler lautet:</p>
      <p id="errorCode"/>
    </div>

I think we should drop style="display: none;", because this prevents showing the error message.

http://lxr.mozilla.org/mozilla1.8/source/browser/components/feeds/content/subscribe.xhtml#47







Reproducible: Always




Occurs also on trunk.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a4pre) Gecko/20070426 Minefield/3.0a4pre
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 350365
Verified Duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.